X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to clear a site from showing up in the address bar

Posted

Hi,

My little brother went on my laptop and visited the site: jizzhut.com

Now, everytime I type www into the address bar www.jizzhut.com shows up. I have cleared cookies, history and everything, yet it won't go away. I even deleted firefox all together and it still persisted.

Thanks...And hopefully you can help so he may live!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6638 answers

Is this website possibly bookmarked?

Question owner

Hi,

No not to my knowledge...doubt he would do that. I looked through my bookmarks and didn't see it. I just double checked and couldn't find it...i searched each folder.

thanks

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6638 answers

Ok, try the following:

Scan for Malware


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try some of the following programs to scan for malware:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.


Clear Cache and Cookies


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.


Reset Firefox


The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Use these steps to remove saved (form) data from a drop down list:

  1. Click the (empty) input field on the web page to open the drop down list
  2. Highlight an entry in the drop down list
  3. Press the Delete key (on Mac: Shift+Delete) to remove it.

Question owner

Hi Tyler,

I tried clearing cache, etc. one by one and no dice. I tried resetting my firefox a couple times and no dice. I am on a MAC...any suggestions for malware stuff for macs??

@Cor-el......It is weird, when you start typing the site shows up, but does NOT show up in the drop down bar. Also, I begin to type the website and it still won't show up anywhere but in the address bar itself.

For all....I have a MAC, but not the new Mtn. Lion (or whatever the newest OS is).

Thanks again guys!

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6638 answers

Would you mind giving us a screenshot of the issue (sorry about the malware stuff, I misread your OS).

Does this happen in a fresh profile? Use the Profile Manager to create and remove Firefox profiles

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can visit the site to create a fresh history entry and use "Forget About This Site".


You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar).

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks. You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


You can set the Boolean pref browser.urlbar.autoFill to false on the about:config page to disable autocomplete.

See "Prevent Firefox from automatically completing URLs":

Question owner

Hi,

So I tried to create a new profile and the application firefox-bin (or something like that) kept crashing. It would have the relaunch option, every time I tired it would reappear. I have attached a screen shot from how it looks when I type it in.

@core-el I tried the forget about it thing and it still shows up... every time it doesn't show up in the drop down even if I open it, just always up top in the address bar like in the photo. I also noticed once I start typing the address it will actually completely disappear once I get past the third "w"...so i type www (up until now jizzhut.com will appear), but once I go further say a "." or another letter (even if "j" ) the jizzhut reference will disappear.

I am beyond confused. Thank you guys for helping so much...really appreciate it.

dev678 0 solutions 1 answers

Firefox's drop-down address bar is great at getting you to sites after typing a few letters—unless you've mistyped a site, or visited similar-named pages. Fix Firefox's confusion forever with a right-click trick in your History list.Open up your History menu, choose "Show all History," then either search or click through your recent history to find the site that Firefox can't forget about. Right-click the site, then choose "Forget about this site." Now Firefox knows that you don't plan to head there again any time soon, and it stops showing up in your Awesome Bar results.


moderator removed spam link
Forum rules and guidelines

Modified by the-edmeister

jgummerm 0 solutions 1 answers

I'm having the same problem but with a different website. I type a single letter and the website autocompletes in the address bar. But the website doesn't appear in the drop-down box or in my history or in my bookmarks. I tried visiting the website and then using the "forget this" option, but the website still autocompletes. Obviously the autocomplete must access more than just history and bookmarks. I don't want to turn off autocomplete just because of one website. Please help!

anthony67 0 solutions 1 answers

An address in the address bar of Firefox, comes up with a list of sites that a user previously visited and a user clear this list because of privacy concerns. However going to Options > Privacy and selecting clear your recent history doesn’t do it. Typing about:config in the address bar and changing the setting for browser.urlbar.maxRichResult to 0 worked fine. But this doesn’t really clear it. It just makes the suggestions to go back 0 days. If a user decides to later change this setting again, it will still display the same items that were in there before.


moderator removed spam link
Forum rules and guidelines

Modified by the-edmeister

richard1985 0 solutions 1 answers

Helpful Reply

I had the same problem with Firefox on my Mac, with Firefox stubbornly remembering typed URL's even after all history and caches had been deleted. It seems Firefox is not properly cleaning traces from a file named 'places.sqlite'. The typed URL's appear to be located in the 'places.sqlite' file found in the /Users/<your username>/Library/Application Support/Firefox/Profiles/<Random no>.default directory. Closing firefox, deleting this file, then opening firefox should solve the problem.

It would be better though if on the next update, Firefox could be updated to correctly clean this file when history, caches, etc are cleared.

Sandun 0 solutions 1 answers

thnk you so much richard1985, your suggestion is the most possible one, i could delete my unwanted suggestions on the address bar without turning off the sites suggestion option.

t2thep5432 0 solutions 1 answers

I am having this problem now and still need a hand. How to I delete the "places.sqlite" file? I tried running a search on my computer for it, but my computer only found the file "prefs.js." Is this the file I need to delete?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
condor67 0 solutions 1 answers

"I had the same problem with Firefox on my Mac, with Firefox stubbornly remembering typed URL's even after all history and caches had been deleted. It seems Firefox is not properly cleaning traces from a file named 'places.sqlite'. The typed URL's appear to be located in the 'places.sqlite' file found in the /Users/<your username>/Library/Application Support/Firefox/Profiles/<Random no>.default directory. Closing firefox, deleting this file, then opening firefox should solve the problem.

It would be better though if on the next update, Firefox could be updated to correctly clean this file when history, caches, etc are cleared. "

THIS

tks richard, dat was awesome