X
Tap here to go to the mobile version of the site.

Support Forum

Firefox not responding

Posted

When I click on the firefox icon I get "non responding" and a blank page. Have uninstalled and reinstalled firefox twice using windows 7

When I click on the firefox icon I get "non responding" and a blank page. Have uninstalled and reinstalled firefox twice using windows 7

Chosen solution

Think I found it....hardware acceleration seems to be the problem. In windows 7 there is no tool tab... just options, which threw me for awhile. Thanks for your patience and help.

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

none

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

More Information

uninstalled and reinstalled firefox twice. there is no "help" to click on.

ideato
  • Top 25 Contributor
765 solutions 5508 answers

Hi mssnyder1

Can you check it in safe mode? start Firefox in Safe Mode by holding down the shift key while starting Firefox and select Start in Safe Mode.

thank you

Hi mssnyder1 Can you check it in safe mode? start Firefox in [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode] by holding down the shift key while starting Firefox and select Start in Safe Mode. thank you

Question owner

Yes and I am presently in safe mode....what's next?

Yes and I am presently in safe mode....what's next?
cor-el
  • Top 10 Contributor
  • Moderator
12905 solutions 118367 answers

Helpful Reply

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls

Question owner

It opens in safe mode. Deleted all the rules from permissions list. Did not see plug in container. Using Norton Security suite via comcast. I disabled the antivirus program and firewall....still not responding. Also before this lastest problem I would also get "firefox already open" problem when clicking on the icon.

It opens in safe mode. Deleted all the rules from permissions list. Did not see plug in container. Using Norton Security suite via comcast. I disabled the antivirus program and firewall....still not responding. Also before this lastest problem I would also get "firefox already open" problem when clicking on the icon.
cor-el
  • Top 10 Contributor
  • Moderator
12905 solutions 118367 answers

Helpful Reply

If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Try to disable hardware acceleration in Firefox.

If it does work in Firefox Safe-mode then disable all extensions (Tools > Add-ons > Extensions) and then try to find which is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/

Question owner

In Safe mode the extensions are disabled already. When I enable one at a time it is still non-responsive. By the way I don't see where tools is an option. I hit the add-on tab to get to the extensions.

In Safe mode the extensions are disabled already. When I enable one at a time it is still non-responsive. By the way I don't see where tools is an option. I hit the add-on tab to get to the extensions.

Chosen Solution

Think I found it....hardware acceleration seems to be the problem. In windows 7 there is no tool tab... just options, which threw me for awhile. Thanks for your patience and help.

Think I found it....hardware acceleration seems to be the problem. In windows 7 there is no tool tab... just options, which threw me for awhile. Thanks for your patience and help.