Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am having a strange problem with the awesome bar

  • 12 replies
  • 1 has this problem
  • 216 views
  • Last reply by bloggermind

more options

The awesome bar/location bar is no longer as awesome as it used to be. When I start typing in an address it seems like it no longer checks through my history and gives a list of possible matches but just gives the stem of an address. For example, if I type in 'goo' it will complete this to 'google.com' if I then append this with an '/a' it will complete this to 'google.com/analytics' but that's as good as it gets, as I say, no list from the history or bookmarks.

I've checked the options and also about:config and all the settings are as they should be, as far as I can tell (and I certainly hadn't changed any of them when it started misbehaving). I've also disabled all extensions and plug-ins.

It's driving my slightly bonkers because I quite often use sites with long addresses and can't remember each of the components of each address. I'd switch to using Chrome but I also use Firebug a fair bit so don't really want to do this.

Chosen solution

From the image it looks like there is a persistent add-on. Was it re-enabled??

Read this answer in context 👍 1

All Replies (12)

more options

Hi,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Hi cowtan,
Sorry you are having problems with the awesome bar.

I imagine the new behaviour may be reversed by changing some pref but I have not looked that up.

Regardless of the new behaviour you seem to have some fault as my awesomebar still gives bookmarked items.

As a troubleshooting step try adding an asterisk in the awesomebar (as first character or anywhere) that should then filter the results in the dropdown list to bookmarked only items, does that work ?

You possibly have some extension interfering with the awesome bar, try Firefox in safe mode (but do NOT* at this stage try the Reset Firefox option) *edit - personal opinion, if a user; such as you; is knowledgeable enough to use about.config the easy solution of FirefoxReset is probably not the best route, as it can have unwanted side effects that are avoidable.

Do your bookmarked items appear in safe mode ?

Try a new Profile.
The best method for troubleshooting this will be to set up a new Firefox profile, you can then: experiment, troubleshoot, alter settings or extensions installed in that profile without changing and potentially damaging your current profile.

I suggest to prevent unexpected problems you

Modified by John99

more options

Thanks for the suggestion. In fact, straight after I finished my originalk posting I spotted the reset button and decided to try but I'm afraid the problem's still there.

Just in case my original description of what's going on didn't make any sense I've added a couple of images to go with it.

more options

Do you not even briefly see a dropdown list of items ?


P.S.

  • Turn it off
    The item I linked to in my first post includes an explanation of how to turn off the new feature,
  • Firefox 14 change
    and the bug documenting it (long and probably not worth reading) is Bug 566489 - Enable inline autocomplete again, but make it smarter (perceived performance)

Modified by John99

more options

No, there's no sign of a list of items at all.

more options

Chosen Solution

From the image it looks like there is a persistent add-on. Was it re-enabled??

more options

Did you experiment with turning it off ? and with using an asterisk. (Assuming you have extensive bookmarks, and type something that may match a bookmark)

(I will not be posting again for a few hours)

more options

Yes, I did try the asterisk but it didn't seem to have any effect.

more options

OK. It seems to be working again now. @dumdidadida, the item you spotted was Trusteer Rapport (http://www.trusteer.com/). It didn't appear in the list of plug-ins or add-ons, but I disabled it using it's own console and everything started working again. (Strangely, Ive now re-enabled it and everything is still working.)

Many thanks for your help guys. It's much appreciated.

more options

Trusteer Rapport has often cause Firefox problems. The software is something some users need to use in order to make certain Financial transactions.

It is worth remembering how to disable or uninstall it if necessary, and also how to update it. Like a lot of other software it sometimes has a problem after Firefox upgrades to a new version (Next upgrade to Firefox is only about a week away) but new Trusteer Rapport releases will probably be made to fix problems so if you do have it installed make sure it is kept up to date.

more options

You can also try to set the Boolean pref browser.urlbar.autoFill to false on the about:config page to disable the auto-fill feature on the location bar.

See "Prevent Firefox from automatically completing URLs":

more options

This bug is caused by the Delicious Plugin, but you don´t have to uninstall the plugin in order to fix the issue, you just have to hack the plugin in order to work with your current Firefox installation ( 15.0 ++++ )

  • First Change the install.rdf file of your delicious extension, look for the max version ( currently 5 ) and change it to 16
  • Then change the overlay.css file under this path
\extensions\{2fa4ed95-0317-4c6a-a74c-5f3e3912c1f9}\chrome\skin
  • and comment out the following lines
/* Awesomebar component binding
.autocomplete-richlistitem
{
-moz-binding: url(chrome://ybookmarks/content/ybAwesomeBarBindings.xml#ybookmarks-awesomebar-autocomplete-richlistitem) !important;
}   */
  • Restart Firefox and your Delicious Plugin + Awesome Bar will be working again

If you need step by step instructions , you can found them here How to fix the Delicious Plugin + Awesomebar Bug on Firefox http://bloggermind.net/social-networks/delicious_on_firefox/

Modified by cor-el