X
Tap here to go to the mobile version of the site.

Support Forum

Flash-Addon "succesfully installed" but not listed in "add-ons", keeps asking to reinstall again and again...

Posted

I have FF 15.0.1 freshly installed on a new Win7-PC (home premium 64bit).

I have tried to install Adobe Flash from their site as well as through the automatically proposed add-on. Both claim it was "installed successfully". But when I check the addon-list, it's not there. Restarting firefox doesn't work.

I have some other plugins (pdf-reader) and extensions (ghostery, adblock) installed and they are working fine.

FF keeps me asking to install the plugin. I install it, and it's not there - asking me to install it. And so on. Could keep me busy for hours ;-(

Please help! Thanks :)

I have FF 15.0.1 freshly installed on a new Win7-PC (home premium 64bit). I have tried to install Adobe Flash from their site as well as through the automatically proposed add-on. Both claim it was "installed successfully". But when I check the addon-list, it's not there. Restarting firefox doesn't work. I have some other plugins (pdf-reader) and extensions (ghostery, adblock) installed and they are working fine. FF keeps me asking to install the plugin. I install it, and it's not there - asking me to install it. And so on. Could keep me busy for hours ;-( Please help! Thanks :)

Chosen solution

I noticed a message on the FF-addon-page like "Java was disabled for your security, as it's not up to date".

The pluginscheck page actually doesn't know why Java is missing, so it just presents that as its best guess. Sorry for the false lead.

Firefox detects plugins that are not in its own folders by checking the registry. The locations are different between 32-bit and 64-bit versions of Windows:

32: HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins

64: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins

I think if you set the following preference to false in about:config, then Firefox will NOT pick up those plugins:

plugin.scan.plid.all

But it should be true by default.

Can you think of any reason that Firefox might be blocked from accessing the Windows registry?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Allgemeine Informationen
Name
Firefox
Version
15.0.1
User-Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Profilordner
Ordner anzeigen
Aktivierte Plugins
about:plugins
Build-Konfiguration
about:buildconfig
Absturzberichte
about:crashes
Speicherverwendung
about:memory
Erweiterungen
Name
Version
Aktiviert
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Ghostery
2.8.3
true
firefox@ghostery.com
Password Exporter
1.2.1
true
{B17C1C5A-04B1-11DB-9804-B622A1EF5492}
Wichtige modifizierte Einstellungen
Name
Wert
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
972800
browser.places.smartBookmarksVersion
4
browser.search.update
false
browser.startup.homepage
google.de
browser.startup.homepage_override.buildID
20120905151427
browser.startup.homepage_override.mstone
15.0.1
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
extensions.lastAppVersion
15.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1348765011
places.history.expiration.transient_current_max_pages
104858
plugin.expose_full_path
true
plugin.scan.plid.all
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Grafik
Karten-Beschreibung
AMD Radeon HD 6450
Vendor-ID
0x1002
Geräte-ID
0x6779
Karten-RAM
1024
Karten-Treiber
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Treiber-Version
8.840.0.0
Treiber-Datum
3-9-2011
Direct2D aktiviert
true
DirectWrite aktiviert
true (6.1.7601.17514)
ClearType-Parameter
ClearType-Parameter nicht gefunden
WebGL-Renderer
Google Inc. -- ANGLE (AMD Radeon HD 6450) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU-beschleunigte Fenster
10/10 Direct3D 10
AzureBackend
direct2d
JavaScript
Inkrementelle GC
0
Bibliotheken-Versionen
Minimal vorausgesetzte Version
Verwendete Version
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

snowfi6916 0 solutions 11 answers

I had this problem with Java 7 U 7. Kept telling me to install Java, I did, restarted, and it wasn't there in the plugins.

I tried reinstalling Firefox, Java, clearing my cache, deleting my pluginreg.dat file, and nothing worked.

I ended up downloading a 64 bit version of Firefox from a third party called Pale Moon. (http://www.palemoon.org). I then downloaded the 64 bit version of Java, and it works (shows up under plugins in Pale Moon). They also have a 32 bit version I think if you don't have a 64 bit operating system. I think it's specifically for Windows though.

Anyway, that's what finally worked for me. The only downside is that my Kaspersky addons cannot recognize Pale Moon, so my Password Manager and other addons don't work. But I didn't use them anyway, so...

It might work with Flash. Good luck.

EDIT: Just noticed you do have Windows 7 64 bit. I would definitely give Pale Moon a shot then.

I had this problem with Java 7 U 7. Kept telling me to install Java, I did, restarted, and it wasn't there in the plugins. I tried reinstalling Firefox, Java, clearing my cache, deleting my pluginreg.dat file, and nothing worked. I ended up downloading a 64 bit version of Firefox from a third party called Pale Moon. (http://www.palemoon.org). I then downloaded the 64 bit version of Java, and it works (shows up under plugins in Pale Moon). They also have a 32 bit version I think if you don't have a 64 bit operating system. I think it's specifically for Windows though. Anyway, that's what finally worked for me. The only downside is that my Kaspersky addons cannot recognize Pale Moon, so my Password Manager and other addons don't work. But I didn't use them anyway, so... It might work with Flash. Good luck. EDIT: Just noticed you do have Windows 7 64 bit. I would definitely give Pale Moon a shot then.

Modified by snowfi6916

jscher2000
  • Top 10 Contributor
8568 solutions 70071 answers

Hi oliver69, you should see the add-on here:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

It will appear under the name Shockwave Flash and should show version 11.4.402.278 (at least as of this moment... it gets updated frequently).

You can test whether Flash is running on the "about" page: http://www.adobe.com/software/flash/about/

Hi oliver69, you should see the add-on here: orange Firefox button ''or'' classic Tools menu > Add-ons > Plugins category It will appear under the name Shockwave Flash and should show version 11.4.402.278 (at least as of this moment... it gets updated frequently). You can test whether Flash is running on the "about" page: http://www.adobe.com/software/flash/about/
jscher2000
  • Top 10 Contributor
8568 solutions 70071 answers

By the way, you should also find this file:

C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_4_402_278.dll

If you do not see that file or if you see older DLL files, you might want to do a clean up with the Adobe uninstaller and then reinstall. This article has a link: https://support.mozilla.org/en-US/kb/flash-113-crashes#w_step-1-uninstall-flash

By the way, you should also find this file: C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_4_402_278.dll If you do not see that file or if you see older DLL files, you might want to do a clean up with the Adobe uninstaller and then reinstall. This article has a link: https://support.mozilla.org/en-US/kb/flash-113-crashes#w_step-1-uninstall-flash

Question owner

@snowfi: I still want to give FF15 a chance, I'm so used to it :) I've been looking into the pluginreg.dat, and the only thing I see, is Foxit-PDF plugin:


Generated File. Do not edit. [HEADER] Version|0.15|$ Arch|x86-msvc|$ [PLUGINS] npFoxitReaderPlugin.dll|$ D:\Foxit Reader\plugins\npFoxitReaderPlugin.dll|$ 2.2.1.530|$ 1343720344000|0|1|$ Foxit Reader Plug-In For Firefox and Netscape|$ Foxit Reader Plugin for Mozilla|$ 1 0|application/pdf|Acrobat Portable Document Format|pdf|$

[INVALID]


@jscher: I know, where the addon is supposed to be, but despite the seemingly successfull installation, it doesn't appear there.

When I go to the adobe page, the flash-addon-installation pops up and asks me to install the plugin (again). Which I did countless of times without ever seing it in the addon-list.

I uninstalled it as you suggested with adobes "uninstallflash-player.exe" (I need to close FF before unistalling, so it's somehow "connected" to FF). I even tried the older version 10-flash: Same result: "successfully installed" but missing in the add-on-manager. However, the file is at the location, you indicated: C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll (for the flash 10).

How can I convince FF, it's already there and USE it? Can I manually add the Flash-plugin in the pluginreg.dat?

@snowfi: I still want to give FF15 a chance, I'm so used to it :) I've been looking into the pluginreg.dat, and the only thing I see, is Foxit-PDF plugin: ----------------------- Generated File. Do not edit. [HEADER] Version|0.15|$ Arch|x86-msvc|$ [PLUGINS] npFoxitReaderPlugin.dll|$ D:\Foxit Reader\plugins\npFoxitReaderPlugin.dll|$ 2.2.1.530|$ 1343720344000|0|1|$ Foxit Reader Plug-In For Firefox and Netscape|$ Foxit Reader Plugin for Mozilla|$ 1 0|application/pdf|Acrobat Portable Document Format|pdf|$ [INVALID] --------------- @jscher: I know, where the addon is supposed to be, but despite the seemingly successfull installation, it doesn't appear there. When I go to the adobe page, the flash-addon-installation pops up and asks me to install the plugin (again). Which I did countless of times without ever seing it in the addon-list. I uninstalled it as you suggested with adobes "uninstallflash-player.exe" (I need to close FF before unistalling, so it's somehow "connected" to FF). I even tried the older version 10-flash: Same result: "successfully installed" but missing in the add-on-manager. However, the file is at the location, you indicated: C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll (for the flash 10). How can I convince FF, it's already there and USE it? Can I manually add the Flash-plugin in the pluginreg.dat?
snowfi6916 0 solutions 11 answers

Modifying the pluginreg.dat file won't work. Even if you save it, Firefox automatically overwrites it everytime you start Firefox. I know cause I've tried. The only thing you can do with it is delete the file entirely and restart Firefox.

Modifying the pluginreg.dat file won't work. Even if you save it, Firefox automatically overwrites it everytime you start Firefox. I know cause I've tried. The only thing you can do with it is delete the file entirely and restart Firefox.

Question owner

I've uninstalled Foxit. Foxit was still in the pluginreg.dat. I deleted it and restarted FF. Now, there's no plugins, just the extensions. Reinstalled Flash 10: not in the plugins-list. Deinstalled Flash 10, installed Flash 11 from Adobe, from the automatic plugin-finder: neither is working. I even installed an older flash 8-version. Whatever I do, it refuses to appear in the plugin-list.

Are there any settings in about:config preventing flash being used? Any way to force FF just accepting, that what it needs is already there? Any ideas...?

I've uninstalled Foxit. Foxit was still in the pluginreg.dat. I deleted it and restarted FF. Now, there's no plugins, just the extensions. Reinstalled Flash 10: not in the plugins-list. Deinstalled Flash 10, installed Flash 11 from Adobe, from the automatic plugin-finder: neither is working. I even installed an older flash 8-version. Whatever I do, it refuses to appear in the plugin-list. Are there any settings in about:config preventing flash being used? Any way to force FF just accepting, that what it needs is already there? Any ideas...?
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156717 answers

Try to delete the addons.sqlite file in the Firefox Profile Folder.

Try to delete the addons.sqlite file in the Firefox Profile Folder.

Question owner

Deleted the addons.sqlite, it was generated with the same size after relaunching FF. Installed Flash: same result...  :-(

I noticed a message on the FF-addon-page like "Java was disabled for your security, as it's not up to date". So there must be some switch, FF can disable plugins and addons, if it believes this usefull. Can I disable that option somehow?

Deleted the addons.sqlite, it was generated with the same size after relaunching FF. Installed Flash: same result... :-( I noticed a message on the FF-addon-page like "Java was disabled for your security, as it's not up to date". So there must be some switch, FF can disable plugins and addons, if it believes this usefull. Can I disable that option somehow?
snowfi6916 0 solutions 11 answers

There's an addon you can install called Nightly Tester Tools that will disable the addon compatibility check in Firefox. Download it, and it will appear in the, uh, "Firefox" menu (upper left corner). There should be an option that says "force addon compatibility". Check that, then restart Firefox.

There is an option under the about:config page that will turn it off, but I forgot the command. And you DON'T want to mess with the about:config page unless you know what you're doing.

For Java, I found a better answer than "download Palemoon". Here's what I did, don't know if it will work for you.

There are two versions of Java that are safe currently: Java Version 7 Update 7, and Java Version 6 Update 35. I was having a problem getting Firefox to recognize 7 u7, but it could recognize 6 u35 just fine. So here's what I did:

1) I went to Oracle's website and downloaded the JRE directly from them, NOT from Firefox when it says to install the addon. Here is their site: http://www.oracle.com/technetwork/java/javase/downloads/index.html

Make sure you download the JRE, and NOT the JDK, unless you plan on making your own Java apps.

2) Download the following:

Java 7 u 7 (32 bit) Java 7 u 7 (64 bit) Java 6 u 35 (32 bit)

Install both Java 7's first, then install Java 6 u 35.

3) When you restart Firefox, go to your addons page and see which Java plugin it is pointing to. If it is pointing to version 6 u 35, then you are having the same problem as me, and I would just keep version 6 u 35. It should work and be compatible with Firefox, cause it worked for me.

If it says it is pointing to Java 7 u 7, then you can uninstall version 6 u 35. I would keep the 64 bit version of 7 u7 just in case you have a 64 bit browser like IE that you want to use it with. But that's what finally worked for me: download all three and throw them at Firefox and hope one of them sticks.

Hope that helps.

There's an addon you can install called Nightly Tester Tools that will disable the addon compatibility check in Firefox. Download it, and it will appear in the, uh, "Firefox" menu (upper left corner). There should be an option that says "force addon compatibility". Check that, then restart Firefox. There is an option under the about:config page that will turn it off, but I forgot the command. And you DON'T want to mess with the about:config page unless you know what you're doing. For Java, I found a better answer than "download Palemoon". Here's what I did, don't know if it will work for you. There are two versions of Java that are safe currently: Java Version 7 Update 7, and Java Version 6 Update 35. I was having a problem getting Firefox to recognize 7 u7, but it could recognize 6 u35 just fine. So here's what I did: 1) I went to Oracle's website and downloaded the JRE directly from them, NOT from Firefox when it says to install the addon. Here is their site: http://www.oracle.com/technetwork/java/javase/downloads/index.html Make sure you download the JRE, and NOT the JDK, unless you plan on making your own Java apps. 2) Download the following: Java 7 u 7 (32 bit) Java 7 u 7 (64 bit) Java 6 u 35 (32 bit) Install both Java 7's first, then install Java 6 u 35. 3) When you restart Firefox, go to your addons page and see which Java plugin it is pointing to. If it is pointing to version 6 u 35, then you are having the same problem as me, and I would just keep version 6 u 35. It should work and be compatible with Firefox, cause it worked for me. If it says it is pointing to Java 7 u 7, then you can uninstall version 6 u 35. I would keep the 64 bit version of 7 u7 just in case you have a 64 bit browser like IE that you want to use it with. But that's what finally worked for me: download all three and throw them at Firefox and hope one of them sticks. Hope that helps.

Modified by snowfi6916

jscher2000
  • Top 10 Contributor
8568 solutions 70071 answers

Chosen Solution

I noticed a message on the FF-addon-page like "Java was disabled for your security, as it's not up to date".

The pluginscheck page actually doesn't know why Java is missing, so it just presents that as its best guess. Sorry for the false lead.

Firefox detects plugins that are not in its own folders by checking the registry. The locations are different between 32-bit and 64-bit versions of Windows:

32: HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins

64: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins

I think if you set the following preference to false in about:config, then Firefox will NOT pick up those plugins:

plugin.scan.plid.all

But it should be true by default.

Can you think of any reason that Firefox might be blocked from accessing the Windows registry?

''I noticed a message on the FF-addon-page like "Java was disabled for your security, as it's not up to date".'' The pluginscheck page actually doesn't know why Java is missing, so it just presents that as its best guess. Sorry for the false lead. Firefox detects plugins that are not in its own folders by checking the registry. The locations are different between 32-bit and 64-bit versions of Windows: 32: HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins 64: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins I think if you set the following preference to '''false''' in about:config, then Firefox will NOT pick up those plugins: plugin.scan.plid.all But it should be true by default. Can you think of any reason that Firefox might be blocked from accessing the Windows registry?
ideato 893 solutions 6250 answers

Hi oliver69

see in the next link the Chosen solution by madperson

https://support.mozilla.org/en-US/questions/937543


thank you

Hi oliver69 see in the next link the '''Chosen solution by madperson''' https://support.mozilla.org/en-US/questions/937543 thank you

Question owner

jscher2000 gave the decisive hint: plugin.scan.plid.all was set to FALSE.

Set to true, restarted FF and Hurray: it works! Also all the other addons appeared by miracle (Java, VLC...).

Not sure, how a freshly installation could set this option to false. And what I don't understand either is, why the Foxit-Addon was displayed despite the preference that should inhibt any addon.

Anyway, I'm happy, it behaves like it's supposed to be :)

Thanks to everyone for your help and Herzlichen Dank für den entscheidenen Hinweis :-)

jscher2000 gave the decisive hint: plugin.scan.plid.all was set to FALSE. Set to true, restarted FF and Hurray: it works! Also all the other addons appeared by miracle (Java, VLC...). Not sure, how a freshly installation could set this option to false. And what I don't understand either is, why the Foxit-Addon was displayed despite the preference that should inhibt any addon. Anyway, I'm happy, it behaves like it's supposed to be :) Thanks to everyone for your help and Herzlichen Dank für den entscheidenen Hinweis :-)
jscher2000
  • Top 10 Contributor
8568 solutions 70071 answers

Not sure, how a freshly installation could set this option to false.

Maybe the Firefox installer turned it off for some reason related to your account settings on Windows, or it found an old settings file somewhere. Someone with more intimate knowledge would need to take a look. If you notice it being reset to false on a future restart, that might be a clue.

And what I don't understand either is, why the Foxit-Addon was displayed despite the preference that should inhibt any addon.

The setting prevents a registry scan, but Foxit might have installed its plugin directly into the Firefox plugins folder. In that case, it would be found without the registry scan.

''Not sure, how a freshly installation could set this option to false.'' Maybe the Firefox installer turned it off for some reason related to your account settings on Windows, or it found an old settings file somewhere. Someone with more intimate knowledge would need to take a look. If you notice it being reset to false on a future restart, that might be a clue. ''And what I don't understand either is, why the Foxit-Addon was displayed despite the preference that should inhibt any addon.'' The setting prevents a registry scan, but Foxit might have installed its plugin directly into the Firefox plugins folder. In that case, it would be found without the registry scan.