X
Tap here to go to the mobile version of the site.

Support Forum

Proxy in firefox doesn't really work!?!

Posted

I live in Thailand and several websites are blocked by the goverment. Well I tried to use a proxy and checked my IP at samair.ru and the ip of the proxy is shown. So I surf with that proxy. But the several websites are still blocked and you can see that firefox connects to the goverment site. But it does work with chrome and internet explorer! doesn't make any sence to me. I've deleted all cookies!

I live in Thailand and several websites are blocked by the goverment. Well I tried to use a proxy and checked my IP at samair.ru and the ip of the proxy is shown. So I surf with that proxy. But the several websites are still blocked and you can see that firefox connects to the goverment site. But it does work with chrome and internet explorer! doesn't make any sence to me. I've deleted all cookies!

Chosen solution

You can also check if you use the proxy for all protocols and disable all plugins because some plugins may use their own connection.

Read this answer in context 2

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Winamp Application Detector
  • 5.1.10411.0
  • Version 0.9.19, Copyright 2006-2012 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • GEPlugin
  • Office Live Update v1.5
  • NPWLPG
  • Version 0.9.17, copyright 2008-2010 Veetle Inchttp://www.veetle.com/
  • Zeon PDF Plugin For Mozilla
  • Adobe PDF Plug-In For Firefox and Netscape
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

dumdidadida 155 solutions 1440 answers

Helpful Reply

Hi,

Please also try setting network.proxy.socks_remote_dns to true in about:config. You can get a list of SOCKS proxies from samair. You may have to restart Firefox and also Clear Now the Cache and Cookies in Tools (Alt + T) > Clear Recent History.

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

about:config Entries

Hi, Please also try setting '''network.proxy.socks_remote_dns''' to true in [http://kb.mozillazine.org/About:config about:config]. You can get a list of SOCKS proxies from [http://samair.ru/proxy/socks01.htm samair]. You may have to restart Firefox and also '''Clear Now''' the '''Cache''' and '''Cookies''' in '''Tools''' ('''Alt''' + '''T''') > [https://support.mozilla.org/en-US/kb/Clear%20Recent%20History Clear Recent History]. # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. [http://kb.mozillazine.org/About:config_entries about:config Entries]
cor-el
  • Top 10 Contributor
  • Moderator
12738 solutions 117068 answers

Chosen Solution

You can also check if you use the proxy for all protocols and disable all plugins because some plugins may use their own connection.

You can also check if you use the proxy for all protocols and disable all plugins because some plugins may use their own connection.

Question owner

thank you for your replies. Your are right Cor el. Now it works.

thank you for your replies. Your are right Cor el. Now it works.