X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash causes Firefox to slow down and even freeze (and on a gaming laptop, too). How to fix this?

Posted

Every time I use the Flash plug-in (for videos on YouTube or PutLocker or whatever), FireFox just slows down a lot and even freezes. It happens very often now and it's really annoying.

By the way, I am using a gaming laptop so I am not sure why I am having these problems. My Flash plug-in and firefox are updated to the latest versions, too.

My specs: Windows 7 Home Premium Intel i7-2670QM CPU @ 2.20GHZ (8 CPUs) nVidia GTX 560m 3GB vRAM dedicated 16GB RAM

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • Pando Web Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Application Basics
Name
Firefox
Version
15.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
avast! WebRep
7.0.1466
true
wrc@avast.com
Canadian English Dictionary
2.0.5
true
en-CA@dictionaries.addons.mozilla.org
deviantAnywhere
1.1
true
deviantAnywhere@cvds.ro
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
993280
browser.places.smartBookmarksVersion
4
browser.startup.homepage
https://www.facebook.com/
browser.startup.homepage_override.buildID
20120905151427
browser.startup.homepage_override.mstone
15.0.1
browser.tabs.onTop
false
extensions.lastAppVersion
15.0.1
font.language.group
ja
font.name.sans-serif.ja
Meiryo
font.name.serif.x-western
Georgia
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1348251936
places.history.expiration.transient_current_max_pages
104858
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.offlineApps
true
privacy.clearOnShutdown.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
privacy.sanitize.timeSpan
4
security.default_personal_cert
Select Automatically
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce GTX 560M
Vendor ID
0x10de
Device ID
0x1251
Adapter RAM
3071
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
9.18.13.623
Driver Date
8-30-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400 ] DISPLAY4 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400 ]
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560M ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

kvnstv1 0 solutions 3 answers

Just to check, does your CPU usage spike too? Try checking it with your system monitor. This used to happen to me and the problem lay with flash. You should try uninstalling flash fully using add/remove programs and then reinstalling from Adobe's website. Get the download from here:

http://get.adobe.com/flashplayer/

I hope this helps. In my case, I had done the same thing and it worked fine from then on.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hi AdelaisAer,

First try to Turn off hardware acceleration in Firefox and "disable the hardware acceleration" in the Flash Player too :

http://helpx.adobe.com/flash-player/kb/video-playback-issues.html

http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html

also try to Disabling Protected Mode in Flash (the link is for 11.3, do the same for 11.4), see the same in "Last resort" in the next link from adobe forum http://forums.adobe.com/thread/1018071?tstart=0


thank you

Question owner

Disabling Hardware Acceleration didn't really work. I'll try to just uninstall Flash and do a clean install. I'll update as I go along and see if it solves anything.

EDIT: It still does it a bit. :S

Modified by Amnon

Helpful Reply

Okay, so I uninstalled and reinstalled it. That helped only for about ten minutes and it started doing it again.

I don't know what else to do. :S

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Try to Downgrade to Flash 10.3 , but as the suggestions in the link said uninstall first uninstall Flash with uninstaller provided by Adobe (it is in the link) and then download and install 10.3

[the 10.3 flash is updated before 6 - 7 days(https://support.mozilla.org/en-US/forums/contributors/708573?last=48772#post-48758)]


thanks again

Helpful Reply

Actually, I think it might be FireFox, because sometimes it slows down or freezes even without me using a Flash video. Like, I'd open a link in a new tab (something simple, like TD Bank or Google) and the tab wouldn't appear and the window would freeze. :S

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Try to rename or delete the files places.sqlite and places.sqlite-journal (if exists), see how to do that easily :

Firefox hangs at random times

also Delete duplicated Session Restore files


thanks again

Question owner

I deleted places.sqlite and duplicate session restore files. It still seems to do it. :S

Question owner

On top of this problem, a new one arises - sometimes, flash videos just randomly restart mid-way. o-O;

anon147 0 solutions 1 answers

Guys. Wake up. Why would we go to all this trouble just to get Firefox to run properly? Why can't it just work correctly right out of the box, like Chrome? Myself and I suspect many others are just about through trying to use Firefox in its currently unusable state. The rats are jumping ship. A few more months of this level of unacceptable browser performance and you will be hanging up your hats, or rather tipping your hats in salutation as you slink off in defeat, having had your derrieres soundly thrashed up one side of the street and down the other, by Chrome. Hope you can find new jobs in this economy. By the way, I am currently using Linux Mint, it's awesome! Yet some mega-companies are trying to stem the tide and drop support for Linux. They will be left in the dust. Fair warning.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello anon147, you said.....By the way, I am currently using Linux Mint, it's awesome! Yet some mega-companies are trying to stem the tide and drop support for Linux..."

think if this already try to happen in firefox too !

thank you

valtih78 0 solutions 6 answers

Look for disabling ProtectedMode in the Flash player. It will eliminate the hanging. However, it replaces it with another problem, I seen before:

https://bugzilla.mozilla.org/show_bug.cgi?id=745433

mouse clicking becomes unreliable in the Flash. It just cannot handle mouse properly when controls are small (yet large enough for the human to easily point over them precisely). I had to zoom the page to make flash capturing the mouse events properly.

Developers say that it is a Flash problem but none exist when I run the Flash in IE.

Now, I have realized that my too high Windows 7 screen resolution (custom text size of 200% = 192 DPI) or DPI virtualization used to achieve that can be a problem for many video applications http://www.techrepublic.com/blog/window-on-windows/get-a-better-view-in-windows-7-by-adjusting-dpi-scaling/5404 http://msdn.microsoft.com/en-us/library/windows/desktop/dd940516%28v=vs.85%29.aspx

It seems that not only Firefox freezes, some MS products also suffer from the same, DPI virtualization, problem http://stackoverflow.com/questions/9663585/vs2010-stuck-freeze-in-any-kind-of-scrolling

And the solution used thereby, to "Disable display scaling on high DPI settings" in Firefox shortcut -> Properties -> Compatibility also fixes both the freezing and broken mouse problem! So, try FF compatibility before blaming the Adobe Flash Protected Mode. I think that it is a FF bug because it does not exist in IE and FF is an "older program".

Modified by valtih78

Peter_Rabbit 0 solutions 3 answers

Because it has nothing to do with firefox? Nothing else causes firefox to freeze like this and it all started going wrong when I updated flash a few months ago. If anything this is evidence of why I should ditch flash, not my perfectly good browser.

valtih78 0 solutions 6 answers

Check your not-that-good browser. How is it with flash?

Peter_Rabbit 0 solutions 3 answers

Or rather, how is flash with my browser? Mozilla can't force another organisation to fix their bugs. All the more reason to switch to open standards like webGL.

Question owner

Flash still causes my browser to freeze every so often. Hell, sometimes, it crashes. :/ And I already went through all the suggestions in this thread, so I think it's a problem with the Flash plug-in for Firefox.

My computer is Asus G74SX-DH72, so I wouldn't say that it's my computer that can't handle it.

yazzit 0 solutions 1 answers

I suffer the same severe Flash sluggishness on firefox using Ubuntu. Not so with Chrome. What's a bit laughable is that Seamonkey (former "bloated" Mozilla suite replaced by Firefox) runs flash better- and has been a quicker browser all-around for some time. I assume firefox code bloat/ extensions and Flash's unecessarily heavy resource appetite account for the embarrasing performance.

TranceWarp 0 solutions 2 answers

If you have extensions that can do things with IP addresses (my problem was Fiddler), try to disable that extension. It stopped my problems

AlexKey 0 solutions 2 answers

I use and im using firefox since i had got Netscape Navigator and want to tell everyone that it flashplayer poblem! Not Firefox, because when you kill that process from the taskmanager - everything is ok! May be we need to update Flashplugin or may be we need alternative!

Peter_Rabbit 0 solutions 3 answers

Does Netscape Navigator still exist? O.o

At any rate, there isn't anything Mozilla can do, it's up to Adobe to fix the problem with flash. I have the latest version but it's still not great. The alternative is the HTML5 canvas element, which alot of websites are switching over to.