Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 15.0.1 won't load disqus even in safe mode

  • 12 replies
  • 17 have this problem
  • 3426 views
  • Last reply by Dutch_Boy

more options

This is at the NPR site. I cleared my cache, deleted all cookies, and restarted in safe mode. Disqus still loads endlessly without ever getting there. What do ya think?

Chosen solution

Would you mind testing in a clean profile? In addition to bypassing your currently installed extensions and custom settings, it should have completely fresh settings databases and a fresh cache folder.

Close Firefox and start up in the Profile Manager:

Start > search box: firefox.exe -p {ENTER}

Click Create and accept the defaults and start up in the new profile. To switch among profiles, close Firefox and return to this dialog.

Does NPR/DISQUS work any better?

Note that you also could disable nonessential plugins here:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

Read this answer in context 👍 1

All Replies (12)

more options

Do you have any add-ons or external filters that might be blocking any part of the comments? In particular, consider ad blockers and script filters.

Edit: Deleted suggestion about Safe Mode since you mentioned trying that already.

Modified by jscher2000

more options

You also could take a look at proxy settings e.g., change to No Proxy here:

orange Firefox button or classic Tools menu > Options > Advanced > Network > "Settings" button

Do the comments load normally in IE8/IE9?

more options

The proxy setting is already at "no Proxy". Yes, it loads normally in IE8.

thanks, Ian

more options

Do the comments appear, despite the appearance that the loading never stops? There are some sites that seem to have that issue, or should I say, for some sites, Firefox seems to expect that more will be sent for one reason or another...

more options

Nope, no comments appear. I get the message "DISQUS seems to be taking longer than usual. Reload?"

more options

its working on mine, do you uninstall and reinstall it ... and used a google dns ..?

more options

Chosen Solution

Would you mind testing in a clean profile? In addition to bypassing your currently installed extensions and custom settings, it should have completely fresh settings databases and a fresh cache folder.

Close Firefox and start up in the Profile Manager:

Start > search box: firefox.exe -p {ENTER}

Click Create and accept the defaults and start up in the new profile. To switch among profiles, close Firefox and return to this dialog.

Does NPR/DISQUS work any better?

Note that you also could disable nonessential plugins here:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

more options

Yes, that worked, thanks. How do I figure out what is wrong in my original profile? I figured safe mode would set everything to default while operating that way.

more options

I exported my bookmarks from the old profile and imported them into the new one. All is well now. I'll just use the new profile and not worry about what is wrong with the old one.

thanks again... Ian

more options

Profiles contain so many customizations, it's difficult to point to one particular issue...

There is an intermediate approach between a new profile and safe mode, which is the Reset feature. If you wanted to try that and carry over more of your data, I think you would need to first go back to the profile manager and start up in your old profile to make it the default.

More info on the Reset feature: Refresh Firefox - reset add-ons and settings.

more options

I was having problems with flash always being zoomed anyway. Maybe this will solve that problem also. I deleted the old profile. I think it's loading faster now anyway. This might be like the computer sometimes just needing to be formatted for a new start. Just too much old junk hanging around bogging things down.

more options

I had trouble getting Disqus to load, too. Searching for answers, I found that the problem may be caused by a lot of different things. I would suggest that all solutions to this rather annoying issue are brought together on one Mozilla help page. In my case, the "culprit" was the add-on, RefControl. The easiest solution is to include Disqus in the list of exceptions, giving it "normal" status, like this:

disqus.com <Normal>