Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Freezing and crashing constantly, even with no add-ons or extensions

  • 6 replies
  • 8 have this problem
  • 359 views
  • Last reply by mainpress

more options

First of all, thank you so much for even having this support service! :)

I've been seeing a TON of crashing with Firefox. I will be surfing and suddenly firefox crashes, and then attempts to report the the error and restarts. This is not related to extensions or add-ons and I have disabled every plugin and add-on, and the crashing continues. It is also NOT related to opening new tabs or windows. I can walk away from the computer sometimes for 5 minutes, and when I come back I see that firefox has crashed once again. Firefox appears to never crash in safe mode however...

Some things I've tried: -Update Firefox to latest version -Uninstall Firefox and reinstall -Uninstall Firefox and install previous version (13) -Disable all add-ons, plugins, extensions -Update Windows -Update graphics driver -Create a new Firefox profile -Update anti-virus

So, I've really tried to do my homework before I reached out to you. Please let me know if you can help!

My system: Desktop computer running Windows 7 x64, service pack 1.

Chosen solution

Could you try disabling Firefox's hardware graphics acceleration? Due to some recent driver updates, many people have been afflicted by performance and stability issues associated with this feature.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved or at least improved?

Read this answer in context 👍 2

All Replies (6)

more options

Chosen Solution

Could you try disabling Firefox's hardware graphics acceleration? Due to some recent driver updates, many people have been afflicted by performance and stability issues associated with this feature.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved or at least improved?

more options
more options

Thank you very much! I turned off Hardware Acceleration, and that fixed it. I almost can't believe it! It's been a few days now, and zero crashes. Thank you again!

more options

Same problem here, tried turning off hardware graphics acceleration, disabled all extensions and plugins, even tried safe-mode, nothing seems to work A killer is http://www.ad.nl/ Stranger even; some systems, running te same old configuration (HP7700 running Win XP sp3) do not have the problem. Drives me nuts!

more options

Hi mainpress, does Firefox crash? If so, could you retrieve one or more crash IDs and post them here? You can access those by typing or pasting about:crashes into the address bar and pressing Enter.

more options

Alas ... no crash report whatsoever. That's what makes it so frustrating.