Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps crashing after much troubleshooting...

  • 5 replies
  • 8 have this problem
  • 59 views
  • Last reply by jscher2000

more options

Whenever i put some load onto firefox as in multi tabs open... streaming, surfing, maybe a download... pretty much my normal interweb abuse it has been crashing... like every 5-10 minutes and it is killing me. Some fixes i tryed: -New profile -Updates addons (even though it still shows flash as out of date even though i have installed the update twice now.) -Disabled addons -Reinstalled firefox freshly... no addons/bookmarks... anything -reset firefox.

No crash sig on any of my reports... please help starting to think it is system based not firefoxes fault... however that works...

Chosen solution

Could you try disabling Firefox's hardware graphics acceleration? Due to some recent driver updates, many users are experiencing strange performance and stability issues linked to this feature.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved or at least improved?

Read this answer in context 👍 3

All Replies (5)

more options

Chosen Solution

Could you try disabling Firefox's hardware graphics acceleration? Due to some recent driver updates, many users are experiencing strange performance and stability issues linked to this feature.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved or at least improved?

more options

well damn... i think this might have just worked.... hasent crashed since i changed it this morning... will keep you posted, havent had time to really test it.... will update tomorrow... but for now... ty

more options

yep looks like that was the problem!!!! not a single crash... ty

more options

I have tried Firefox's hardware graphics acceleration and uninstalling and re-installing Firefox, but it continues to quit on me regularly. I am running Vista Home Premium 64 bit.

more options

Hi lkingsland, can you associate the problem with any particular kind of content, such as Flash or other media?


Assuming you are running a recent version of Flash, try disabling the new protected mode, since that feature is still being debugged. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?


A standard diagnostic to bypass interference by extensions (and some custom settings) is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode."

Any improvement?