X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Disabeling auto refresh of tabs from old session upon restart. Firefox 15.0

Posted

After updating FF to 13.something and later to 15.0 from an unknown version, perhaps FF12

I have this problem, tabs would automatically reload once an old session were restarted.

I would very much like to disable all kinds of auto refresh on tabs when FF is restarted and old tabs is restored. No auto reload of tabs even though internet connection is available.

I'm familiar with the setting: "Don't load tabs until selected", this is of no use, as it will either reload all tabs on restart, or reload the tab i would like to use as soon i select it.

F5 is useful enough for me :)..

Thx for your effort.

Modified by sponkii

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.3 r300
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Mike Won 6 solutions 32 answers

The Shockwave and Java applications may need 'PLUGIN UPDATE' for newer versions. Suggest a check for any outdated PLUGIN UPDATE found from the Mozilla Firefox Toolbar 'Help' Menu > 'Firefox Help' > [lower right margin displays link to more info to review and 'UPDATE PLUGIN's!

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

You can try to switch to offline mode to prevent loading tabs from the internet.
You can do that via the startup window of the Profile Manager.

Helpful Reply

MikeWon: I cant see how this will solve this problem?

cor-el: But wont this disable further "interactions" on the page? - I would like to be able to continue surfing, but I don't want mozilla to automatically refresh/re download the content of a page, after a restart, it should only display the cache from last time.

Modified by sponkii

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

If the page is in the cache then Firefox will use the copy in the cache on the next start AFAIK.
That is always a problem if you want an updated page on the next start without having to refresh the page.
I even see that happen if I use "Reload All Tabs" to load all the tabs and still notice old pages from the cache if I switch to another tab.

Question owner

I was like that in older versions of FF, that I would use the cache, but it don't work the same any more, it uses the chache untill it auto reload page.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

Do not use "Clear history when Firefox closes" to clear the "Cache" because Firefox will disable the disk cache in such a case.

Helpful Reply

It is set to "Remember History", so I don't have that setting.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

Select "Use custom settings for history" to inspect all history and cookie settings.

  • Tools > Options > Privacy > History: Firefox will: "Use custom settings for history"

Question owner

I did not find anything usefull.

Thx anyway :)

romarin12 0 solutions 6 answers

FYI, I've added this to Feature Request: http://forums.mozillazine.org/viewtopic.php?f=8&t=2634431

Please backup this request.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

If you have to login again to websites after restarting Firefox then check if you have a allow exception for cookies from those domains and also aren't using "Clear history when Firefox closes" to clear cookies and Site Preferences and Active Logins.

PurrPurr 0 solutions 2 answers

There may be some inconveniences to disabling this, but I have, and I did it by doing this: In FireFox's address bar, type: about:config. Go to: accessibility:blockautorefresh. Double click to change setting from false to true. Easy to change back if you don't like the change.

Modified by PurrPurr

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97054 answers

That accessibility.blockautorefresh pref has nothing to do with loading tabs automatically after a start of Firefox

See also:

  • Firefox/Tools > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Tools > Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.