X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to I TURN ON the new tab page? Can't seem to make that work. The toggle switch is missing.

Posted

The toggle switch for the new tab page is not there in the top right corner. Where is it?

Chosen solution

If browser.newtab.url was "grayed-out" in about:config that's probably because it's already set to the default, which is about:newtab ... so you don't need to reset it. Since you did have to reset the the browser.newtabpage.enabled preference (to true, the default value) then the "toggle switch" should appear, as shown here:

If browser.newtabpage.enabled is now set to true and you still don't see the "toggle switch", you could try the Search Reset add-on which will restore the browser.newtab.url setting (along with other preferences related to search and home page) to the default value.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • DYMO Label Framework Plugin
  • 4.1.10329.0
  • Next Generation Java Plug-in 10.2.0 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

Helpful Reply

type about:config into your address bar, press Enter. Accept the warning. Search for browser.newtabpage.enabled, right click it, and press Reset.

Then search for browser.newtab.url, right click it, and press Reset.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

See this article about the New Tab (about:newtab) page:


Question owner

This did not work. I was able to reset "browser.newtabpage". HOWEVER, reset option was NOT available for "browser.newtab.url" It was 'grayed-out"

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

Chosen Solution

If browser.newtab.url was "grayed-out" in about:config that's probably because it's already set to the default, which is about:newtab ... so you don't need to reset it. Since you did have to reset the the browser.newtabpage.enabled preference (to true, the default value) then the "toggle switch" should appear, as shown here:

If browser.newtabpage.enabled is now set to true and you still don't see the "toggle switch", you could try the Search Reset add-on which will restore the browser.newtab.url setting (along with other preferences related to search and home page) to the default value.

Question owner

For this reply. See the next entry.

Modified by Marlene

Question owner

Hold the presses!! The Search Reset evidently DID work, AFTER I clicked on the link at the bottom of the page that said "Restore New Tab page". I initially did not notice this, and did not know to look for it.

Thanks so much for everyone's help!!

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

Hey, that's great! Thanks for posting back that the Search Reset add-on evidently worked and that you were able to restore the new tab page after using it.