X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

facebook post area when clicked gives https://www.facebook.com/ajax/metacomposer/attachment/status/status.php?targetid=695296250&xhpc=composerTourStart

Posted

This is when you click the "whats on your mind" box. Started happening yesterday. Works OK on IE. Scanned page source and found composerTourStart on firefox but not IE. COMPLETELY deleted firefox, saving and restoring only bookmarks. ALL plugins and extensions are disabled. Same thing. I see this exact problem reported a lot, but on Chrome.

Also, the buttons for friend requests/messages/ all clear the number and do nothing. Both started happening at the same time.

Firefox 14.0.1, XP SP3

I put what I think is the area causing the message from the Page Source area.

Chosen solution

ATTENTION!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

RESET FIREFOX TOOK CARE OF THE PROBLEM...

THIS LINK TELLS HOW

https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems

WILL NOW TRY READING THE ADDONS ONE BY ONE AND SEE IF ANY OF THEM BRINGS BACK THE PROBLEM

Read this answer in context 1

Additional System Details

Sites Affected

https://www.facebook.com

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

EfDff6u5Xh0\":function(){return new Composer($(\"ut9ggj_6\"), {\"xhpc\":\"composerTourStart\",\"endpoint\":\"\\\/ajax\\\/updatestatus.php\",\"formType\":1,\"placeholder\":\"What's on your mind?\",\"buttonLabel\":\"Post\",\"autoscrape\":true,\"metaContent\":\"\\u003Cdiv>\\u003C\\\/div>\",\"barCo

Tova 0 solutions 2 answers

A reset solved for me as well. Sadly I forgot to backup my home page links. As dino suggests, I'll watch to see if the problem returns. I hadn't made any setting changes to my Firefox in a very, very long time so if it is a problem with a cookie setting how did it get changed? Or maybe it was set that way for a very long time and facebook or Firefox changed something that caused a conflict? Maybe rebooting my computer for Windows Update, in other words closing and reopening Firefox caused Firefox to run an update if its own that created the problem to go into effect?

dino.mueller 0 solutions 3 answers

Could you please check if the problem returns if you change your cookie settings to "ask me every time"?

Thanks

bmwracer 0 solutions 4 answers

I just restarted my work PC (FF 14.0.1, XP SP3) after installing the latest XP updates and everything is still OK with Facebook... My cookie settings are "Ask me every time" as they were before, so it doesn't appear that it's the cause.

I also noticed that on the PC with the non-functioning Facebook doesn't allow you to log off via the down arrow menu in the upper right corner...

dino.mueller 0 solutions 3 answers

Okay, now I set up a VM with a clean XP SP3 and installed Firefox 3.6.28 with no Add-Ons. There were no problems with the setting "Ask me every time"!

Then I installed Firefox 14.0.1 and went to facebook. What should I say... same problem, same errors!

So it's a Firefox problem! Old versions are okay.

cu,

 Dino
jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi ailios, if you used the Reset feature under Help > Troubleshooting Information, your old settings folder (AKA Firefox profile folder) was preserved and you can mine it for settings and other information. The following article may help. If you have questions about how to work with the files, it probably makes sense to start a new thread.

Recovering important data from an old profile

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Helpful Reply

Hi dino.mueller, do you know which was the last version of Facebook in which those icons worked? This would help in tracking down the change.

It appears to be related to how Firefox stores the permission you gave Firefox to set cookies for www.facebook.com -- it isn't extending to facebook.com without the www.

The workaround is to create an exception manually:

(1)

(WIN) orange Firefox button or classic Tools menu > Options > Privacy
(MAC) Firefox > Preferences > Privacy

(2) Click the Exceptions button to the right of "Accept cookies from sites"

(3) In the box at the top type facebook.com and click either Allow (if you want data stored between restarts of Firefox) or Allow for Session (to have cookies cleared between restarts of Firefox)

(4) Scroll down to the entry for www.facebook.com and remove it to avoid possible inconsistency. Click Close. Click OK.

See also: https://support.mozilla.org/en-US/questions/934784#answer-360431

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi mikemercury, I'm glad you got it solved. Sorry it took 12 hours to get there, and we need to give thanks to the user detective in the other thread who discovered the connection with the "ask me every time" cookie setting.

Question owner

Nope, have to disagree. I've always and still have ask every time. the reset is the only thing that accomplished anything.

ozite 0 solutions 1 answers

Every time I clicked on the FB "Post Update" the FB page would close and it would re-direct to a composer page. I noticed that the address was "ajax/metacomposer/attachment", did a search in Windows (C:\) and found a file called "ajaxupload" in the temp internet folder. I deleted all the files in the temp internet folder and the problem was solved. As a matter of interest I also went through the process of removing (even in the registry) and reinstalling Firefox, which did not solve the problem.

Question owner

No. its back again. you are right Dino, it is related to that ask me every time option. But I want that option on. Now have to look at that issue. I forgot that the reset changed that option back. Today I noticed it wasn't on, turned it on, and the option came right back. Reset. OK. Changed option. Boom. GRRRRRRRRRRRRRR

I have had this option on for years and have NEVER had any problem unless I got a message that cookies were turned off.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi ozite, Hi mikemercury, did you try the workaround of creating a cookie permission for facebook.com as described here: https://support.mozilla.org/en-US/questions/934791?page=2#answer-360642 ?

Question owner

Yes, I did jscher. That is the real fix, not the 50 or other things I tried. I thought the reset did it, but that got rid of ask every time which I didn't notice right away. In fact I reposted this topic as a new question with the facebook.com cookie name as an exception to keep other folks from having to go through all the changes some of us did. Thanks!

Bugman 0 solutions 1 answers

Awesome....I'm glad I didn't reset like the previous help suggested! Weird that cookie setting would cause such a strange result! Just keep those cookies till they expire! Here's a nice Screen shot....https://support.mozilla.org/media/uploads/gallery/images/2011-02-01-13-08-51-a28843.png

Modified by Bugman

TeeQVee 0 solutions 2 answers

dino.mueller's fix (changing third-party cookie retention from "ask me every time" to "when FF closes" worked perfectly, thanks!

Modified by TeeQVee

Question owner

The solution is NOT to change the every time option!!!!! Just add an exception in Privacy called facebook.com.

NO OTHER CHANGES NEED TO BE MADE!!!

TeeQVee 0 solutions 2 answers

No, exclamation points aside, the solution is whatever works. dino.mueller's fix worked for me. I prefer not to add an exception for facebook.com. "When Firefox closes" is a perfectly adequate cookie setting for me. YMMV.

MichaelBrant 0 solutions 1 answers

Holy Moley! I've been going nuts with this Facebook problem for weeks, and your suggestion to change how cookies are responded to fixed it instantly! I just changed the Firefox setting to "Accept Third Party Until I Close" and I can post again! Still not sure what caused this problem suddenly, but thanks so much for the fix! Kinko's will wonder where the business went!!