Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Certain websites do not work properly in normal browsing mode but work in private browsing perfectly.

  • 14 replies
  • 46 have this problem
  • 18306 views
  • Last reply by dreamnet

more options

Hi. I'm using Firefox 14.0.1, and recently developed an issue that is extremely frustrating. Two particular websites which I visit often are behaving irregularly. In the first case, on Facebook, when I login and my main page loads, the icons in the top left (friends, messages, and notifications) are not "clickable," that is to say that clicking on them no longer brings up the windowpane that corresponds with them. On another website, Battlelog.com, certain images do not load and instead are replaced with oversized text. I have tried clearing my cache and history in Firefox, turning on and off extensions one by one, running in safe mode, etc. but none of these solutions have helped.

I finally tried running Firefox in private browsing mode. These websites now work perfectly. I cannot explain it, as the URLs for each are identical. If there is anyone who could offer advice on settings or changes I could make so that Firefox will work properly with these sites in default browsing mode, it would be most greatly appreciated.

Chosen solution

I think I see the problem. When Firefox prompts you to approve cookies on Facebook, it displays www.facebook.com. However, apparently that is not enough to cover all of the cookies on the site and Firefox is not prompting for the more general domain facebook.com. If I go into the Exceptions dialog and manually create an entry for facebook.com (Allow for Session in my case), then the setting works. Not sure why Firefox isn't prompting for all cookies. ??

Read this answer in context 👍 45

All Replies (14)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Tyler - Thanks for your reply. I was just doing this as you messaged me, but wanted to save it as a "last resort." It has helped clarify the problem, and I'd really appreciate any input you can offer.

I can trace the problem to Firefox's cookie management and, specifically, the Options > Privacy > History tab. One feature I have always liked is that I can control which cookies I allow and for how long. My default setting for keeping cookies has been to "Ask me every time." When I reset Firefox, this was set to "they expire."

If I load the trouble pages with the "they expire" setting, everything works fine. If I switch to my preferred setting (and reload the page so it takes effect) - "ask me every time" - the sites break as in the original post.

At this point there are no add-ons, extensions, etc. It is vanilla Firefox. Do you have any ideas how I can solve this problem and use my preferred method of cookie management? Thanks!

Modified by Double-J

more options

Well, I don't think the problem can be the "Ask me every time" option, but choosing Block in the dialog... no?

You should allow the FB-related domains (facebook.com, facebook.net, fbcdn.net) at least for the duration of the session. You can edit your saved cookie permissions here:

orange Firefox button or classic Tools menu > Options > Privacy > Exceptions

more options

I'd think the same thing, but I've allowed them whenever prompted (I've also double checked in the cookies manager). It doesn't matter.

It is literally like flipping a switch. If I am on Facebook with the default setting ("they expire"), everything works. Switch it to "ask me every time," reload the page, and boom, its broken again. Weird, I know. And frustrating.

Modified by Double-J

more options

Chosen Solution

I think I see the problem. When Firefox prompts you to approve cookies on Facebook, it displays www.facebook.com. However, apparently that is not enough to cover all of the cookies on the site and Firefox is not prompting for the more general domain facebook.com. If I go into the Exceptions dialog and manually create an entry for facebook.com (Allow for Session in my case), then the setting works. Not sure why Firefox isn't prompting for all cookies. ??

more options

@jscher2000 - Thank you so much! That worked perfectly. I'm wondering if it isn't because I'm forcing Facebook to browse with the secure connection (https://) instead of the default, but no matter. I made an exception like you suggested (for both Facebook and Battlelog) and everything is right as rain. Many thanks!

more options

Echoing much thanks to jscher2000! I was having the same problem, and this fixed it. I'm curious as to what changed to suddenly cause this problem?

more options

Where's the history tab?

more options

To see all history and cookie setting you need to select this:

  • Tools > Options > Privacy > History: Firefox will: "Use custom settings for history"
more options

Hello, i have the same problem, i tried to add facebook.com to exceptions but it still don't work, i tried to reinstall firefox, desactivate and activate all modules.. i don't know how to resolve this problem ? Thanks for help

more options

dreamnet:

What kind of problems do you have?

If it works in Private Browsing mode then that suggests a cookie or cache issue. If text isn't showing properly then you may have other problems (zoom or default font size too big).

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

Thank you for your answer, but i think it doesn"t need a screenshot, the problem is when i click on the chat of facebook or on message, friend and notification logo, it shows nothing, and it's the same problem when i try to upload a file in a storage site (med..fire) after selecting a file when i click on upload nothing happens, it also doesn't work with private navigation. I usually resolve my problems with no or just some searches, but know i don't see to resolve this, just a few days ago all works perfectly!. PS : this problem seems to disappear on firefox 3 but not on 10,15 and16

more options

Hi dreamnet, I'm not sure you have the same problem as the original poster in this thread. Would you mind starting a new question? The forum software will take you through a number of suggestions. If none help, please scroll down past the suggestions to continue posting.

https://support.mozilla.org/en-US/questions/new/desktop/d1

With respect to uploading files, some sites use regular HTML controls (like the "Add images" control below this box and others use Flash. If you have noticed any problems with Flash on other sites, that could be related.

more options

Hi, i finally resolved the problem, it was cause by the module http://controledescripts.mozdev.org/ i have blocked window.prompt/alert.. and some fonctions and when i have disactivated the module the problem persists, so i have reactivated the module and choose to "Allow" those javascript fonctions because i can"t delete them ( they come back automaticly ). Thank you for your answers all, dreamnet.