X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Drop down menus keep flickering out, what's wrong?

Posted

Whenever I click on the button on the Firefox toolbar and then start scrolling down, as soon as I want to go into a folder or press a button the drop down menu flickers out and then I have to go back to the toolbar and start again.

Any future answerer please keep in mind that I am talking about the browser itself, not a web site.

I have the latest version of Firefox for Mac and this only started happening a few days ago. Pleas help.

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.2 r202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

Try to repair the disk permissions:

Try to remove the Firefox plist file (org.mozilla.firefox.plist).

Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)

Question owner

Thank you cor-el but that didn't solve the problem and the plist file for Firefox isn't showing up anywhere in my computer.

Oo0Bailey0oO 0 solutions 19 answers

Still having this problem or were you able to resolve? I've been dealing with a flickering right-click context menu selection since about Firefox 14.

Hardware acceleration has no effect on it. Removing the plist file has no effect.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Does this still happen if you start Firefox in Safe mode?

You can use one of these to start Firefox in Safe mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled
nodakgaragedoor 0 solutions 1 answers

Helpful Reply

I had this same issue. Dual screen, right side screen drop down menus flicker out, left side screen operates normally. Dell PC Windows 7 Firefox 16 (just updated today) All Java applets up to date

I dug around and found a resolution to this problem. It's been a problem since 5.0. I have 16.0 and it still is an issue. My drop down menus go wonky, flickering, and can't be seen or legible.

The resolution I found had me fighting for the resolution because it lacked detailed steps so I'll post them here.

1. Point to "start", click. 2. Point to "Search programs and files" box and type "run" in that box, HIT ENTER. 3. With "Run" dialogue box open, type in "sysdm.cpl", CLICK "OK" button 4. In the "System Properties" dialogue box, CLICK on the "Advanced" tab. 5. Under the "Advanced" tab, in the "Performance" section, CLICK on the "Settings..." button. 6. Under this "Performance Options" dialogue box, under the "Visual Effects" tab, select the radio button next to "Adjust for best appearance". CLICK the "apply" button. 7. Lastly, under these options is a box with visual options. CLICK on the check box to remove the check next to "Show shadows under windows". CLICK "apply" button again. This worked for me.

Modified by nodakgaragedoor

Oo0Bailey0oO 0 solutions 19 answers

It does occur in safe mode, but not consistently. It's more obvious in sub-menus of the context menu which safe mode doesn't always have (depending on what you're right-clicking). I'll have to see if I can pin down reliable steps to reproduce.

Oo0Bailey0oO 0 solutions 19 answers

So I'm using Firefox for Mac, not Windows. I'm curious though if you have any similar add-ons as me.

Do you have "FFchrome" or "Save File To" installed?

charodon 0 solutions 1 answers

@nodakgaragedoor I had the same issue (dual screen, flicker only on right screen) and this worked -- but I think the check box is "Show shadows under menus".

Modified by charodon