X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Is it possible to disable the plugin-container in Firefox 14?

Posted

With an older version of Firefox, I was able to disable the plugin-container by typing in 'about:config' in the toolbar, typing 'ipc' in the search bar on that page, then changing the value of the executable (or whatever it's called) for the plugin-container to 'false', and, finally, restarting Firefox.

However, even after doing that in Firefox 14, it still runs when I use Flash applications. Does anyone know another way to disable the plugin-container? Because in my honest opinion the plugin just causes more lag since it takes up a lot of memory (at one point it was at 100,000 k, which is ridiculous).

Sorry if someone has posted this question before.

Modified by Help_is_Required

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • 4.1.10329.0
  • iTunes Detector Plug-in
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

jscher2000
  • Top 10 Contributor
2348 solutions 20816 answers

Due to changes in the Flash plugin, it no longer runs stably in firefox.exe, so it is no longer possible to force it to run in the firefox.exe process instead of the plugin-container.exe process.

As far as I know, executing a plugin for a particular piece of media would use the same amount of memory either way, but running it in a separate process prevents the plugin from crashing the rest of Firefox.

Question owner

If that's the case, and I can't run Flash applications without the plugin-container, then I might go back to older versions of Firefox, or try Google Chrome, and see if I get better performance when running Flash applications.

Thank you for your response though. It is appreciated. I'll wait a while and see what other responses I get before deciding if my question is 'solved'.

jscher2000
  • Top 10 Contributor
2348 solutions 20816 answers

What is the performance problem with Flash?

The "More system details" for your post shows you currently are running an older version (10.3). If you decide to load Flash 11.3, you might consider disabling the new protected mode in Flash 11.3, since that feature is currently being debugged. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Question owner

Ah, I thought I had the most recent Flash, but I guess I didn't really check what version of Flash I had. Suppose I could get the most recent Flash, disable the 'protected mode' and see if it helps. In the past disabling the plugin-container resolved the lag I had with Flash applications, so not being able to disable it is a hindrance for me.

If disabling the 'protected mode' doesn't help, then I'll probably go back to using an older version of Firefox, or use Google Chrome (though I prefer Firefox since you can personalize your browser with themes and such), unless there are better ways to resolve the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96644 answers

Make sure that you allow the plugin-container in the firewall and other security programs.

big_v 0 solutions 1 answers

Helpful Reply

Yes, it is possible with Firefox 14. At the time of writing this reply there is no mentioning of this anywhere on Google, I had to research this by myself because everybody else was saying that this is not possible..

Anyway, you should set **environment variable** in Windows Vista/7 (either as user variable or system variable, doesn't matter) with name MOZ_DISABLE_OOP_PLUGINS to a value of 1 If you don't know how to edit environment variables, search internet... After that, restart firefox, play flash content - plugin-container.exe is no more.

Also, if you using latest flash version and want "old" behaviour completely, you should edit %systemroot%\System32\Macromed\Flash\mms.cfg file and add ProtectedMode=0 Now only process playing Flash will be firefox.exe.

P.S. --------

Btw, this Firefox "new features" are becoming more and more annoying, after every version update I found myself searching how to set things to work like in older versions. I'm becoming tired of this...

Also, this "environment variable" thing is ugly stupid, instead of putting things in prefs.js or application.ini or user.js or userChrome.css (yes, we have at least five places for different settings now... :( ) Mozilla started to use this as "place for *really* hidden settings"! It's like things are getting out of control with this...

Example, setting env.variable MOZ_CRASHREPORTER_DISABLE to 1 is a way to disable crash reporter now (no, that checkbox in setting does not work right). Previously we could edit application.ini . In new FF versions we can't. And *I* *really* do not need this feature since my Firefox is stable...

Regards, V

Modified by big_v

jscher2000
  • Top 10 Contributor
2348 solutions 20816 answers

Hi big_v, I suspect many of those environment variables were created for embedded uses of Mozilla technologies rather than for Firefox. Having them override Firefox's normal behavior probably is an oversight.

ultramannMX 0 solutions 2 answers

Very nice, I was using firefox 13 along with flash player 11.2 with a almost 17 add ons, with an old computer from 2006 with WIN7 installed and only 1.5 Gb of ram, and everything was smooth and modestly fast, even if I had two firefox windows opened with lots of tabs it was smooth and fast....

then I Upgraded to firefox 14 and notice plug-in container and slowing of my computer, and it became worst when installing adobe flash player 11.3, my CPU will stuck at 100% for a long while

    I did what the post about "environment variables" and now my CPU barely gets to 100% and most of the time my CPU is calmed down, even If I play a video my CPU will barely get to 100% 

thanks a lot, Firefox the best of the best, Adobe flash is the garbage that messes up firefox, I though it was the end of firefox for me since it will just slow down my CPU feeling in hell, I blame Adobe flash for all this!

Modified by ultramannMX

jscher2000
  • Top 10 Contributor
2348 solutions 20816 answers

Hi ultramannMX, if you are running Flash 11.3 on Windows 7, consider disabling the new protected mode in Flash 11.3, since that feature is currently being debugged. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

ultramannMX 0 solutions 2 answers

thanks for your reply, I did that the mere day I installed flash player 11.3, I disabled protected mode, but still firefox was slow using the 14 version, I just did the "environment variables" thing and firefox became fast and smooth, with a lot tabs opened and add ons

I dont know that exactly they mean with "last resort" , but in such case if it is related to some security concerns, thats not a problem for me at all, if you may please explain to me in your understanding, what do they exactly mean with those creepy words "last resort" I will appreciate it i already took a read about protected mode, and find it not necessary but I may be wrong,, still my concern is about firefox being fast and smooth, and it is just by doing the "environment variables"

reply if you want or not about "last resort" , Im happy right know after fixing what flash messed up
Pink_Freud 0 solutions 1 answers

@ big_v : TY!!!! Even for a relative NOOB like me the whole process--including researching edit environment variables-- took about 6 minutes & worked perfectly!

Cheers! "Pink"

Modified by Pink_Freud

SniperFodder 0 solutions 1 answers

Helpful Reply

I actually found that Flash Player started functioning normally again after I disabled protected mode. I tried toggling the plugin container on and off with protected mode off in flash, and it made no difference in the videos lagging.

In all honesty, this really isn't a problem with Firefox and the plugin container. It's a problem with Adobe using the public to beta test a feature that shouldn't be published just quite yet.