X
Tap here to go to the mobile version of the site.

Support Forum

FireFox is blocking many sites and says This Connection is Untrusted

Posted

many sites is blocked by firefox like facebook , yahoo mail and even this site. its saying This Connection is Untrusted and this sites working on other browsers and i'm sure that the pc date is right and up to date so what???

many sites is blocked by firefox like facebook , yahoo mail and even this site. its saying This Connection is Untrusted and this sites working on other browsers and i'm sure that the pc date is right and up to date so what???

Chosen solution

Which security software (firewall, anti-virus) do you have?

Some monitor secure connections and send their own certificate instead.

Some examples:

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol
  • BitDefender -> Privacy settings -> disable Scan SSL
Read this answer in context 7

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Google Update
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50826.0
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12328 solutions 114054 answers

Chosen Solution

Which security software (firewall, anti-virus) do you have?

Some monitor secure connections and send their own certificate instead.

Some examples:

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol
  • BitDefender -> Privacy settings -> disable Scan SSL
Which security software (firewall, anti-virus) do you have? Some monitor secure connections and send their own certificate instead. Some examples: *ESET setup -> advanced setup -> extend web and email tree -> SSL *SSL protocol: Do not scan SSL protocol *BitDefender -> Privacy settings -> disable Scan SSL

Question owner

tnx man it's working good now thank you

tnx man it's working good now thank you
cor-el
  • Top 10 Contributor
  • Moderator
12328 solutions 114054 answers

You're welcome

Which security software do you have?

You're welcome Which security software do you have?
toffa 0 solutions 6 answers

Hi am not clear on the instruction: SSL protocol: Do not scan SSL protocol do I select that function or deselect it. Am having hell after reset and troubleshooting I cannot access any site without the Untrusted message coming up ..I use eset

Hi am not clear on the instruction: SSL protocol: Do not scan SSL protocol do I select that function or deselect it. Am having hell after reset and troubleshooting I cannot access any site without the Untrusted message coming up ..I use eset
philipp
  • Top 10 Contributor
  • Moderator
2974 solutions 13817 answers

"Do not scan SSL protocol" in the ESET options should be selected when you're having issues with the "This Connection is Untrusted"-error message showing up on any secure page.

"Do not scan SSL protocol" in the ESET options should be selected when you're having issues with the "This Connection is Untrusted"-error message showing up on any secure page.
toffa 0 solutions 6 answers

Am still having the problem even though I selected it. Thank you for quick response

Am still having the problem even though I selected it. Thank you for quick response

Modified by toffa

philipp
  • Top 10 Contributor
  • Moderator
2974 solutions 13817 answers

maybe it will take a restart of the pc for the settings to take effect. if this doesn't work either, could you look under "technical details" on the error page & tell us which error code is being displayed there?

maybe it will take a restart of the pc for the settings to take effect. if this doesn't work either, could you look under "technical details" on the error page & tell us which error code is being displayed there?
toffa 0 solutions 6 answers

(Error code: sec_error_untrusted_cert) this is what am getting as an error in technical details

(Error code: sec_error_untrusted_cert) this is what am getting as an error in technical details
philipp
  • Top 10 Contributor
  • Moderator
2974 solutions 13817 answers

ok, then the problem is likely caused by something else here (i think in the cases where ESET SSl scanning interfered sec_error_reused_issuer_and_serial would be shown).

please try this: go to firefox > help > troubleshooting information and open the profile directory (then close firefox). in the profile folder rename the files cert_override.txt & cert8.db to something like oldcert or delete them... afterwards restart the browser (this will regenerate the file in question again).

ok, then the problem is likely caused by something else here (i think in the cases where ESET SSl scanning interfered sec_error_reused_issuer_and_serial would be shown). please try this: go to firefox > help > troubleshooting information and open the profile directory (then close firefox). in the profile folder rename the files cert_override.txt & cert8.db to something like oldcert or delete them... afterwards restart the browser (this will regenerate the file in question again).
toffa 0 solutions 6 answers

Hi I tried it not happening. Ok am having trouble just getting into twitter, i can do my facebook, yahoo etc..its just strange as I was on twitter earlier today..

Hi I tried it not happening. Ok am having trouble just getting into twitter, i can do my facebook, yahoo etc..its just strange as I was on twitter earlier today..
philipp
  • Top 10 Contributor
  • Moderator
2974 solutions 13817 answers

this seems strange - can other browsers on your pc display those secure sites without any error messages?

another thing you could try in firefox is to create a new profile & see if this works...

this seems strange - can other browsers on your pc display those secure sites without any error messages? another thing you could try in firefox is to [[Use the Profile Manager to create and remove Firefox profiles|create a new profile]] & see if this works...
toffa 0 solutions 6 answers

Yes am able to open twitter on IE with no problem at all..Thanks

Yes am able to open twitter on IE with no problem at all..Thanks
cor-el
  • Top 10 Contributor
  • Moderator
12328 solutions 114054 answers

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate. You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates. *Click the link at the bottom of the error page: "I Understand the Risks" Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate". *Click the "View..." button and inspect the certificate and check who is the issuer. You can see more Details like intermediate certificates that are used in the Details pane.
toffa 0 solutions 6 answers

Hi Thanks, managed to get it going. Much appreciated.

Hi Thanks, managed to get it going. Much appreciated.
three_random_words 0 solutions 2 answers

Helpful Reply

I have been having the same problem, chased my tail around for ages and then realised that my system clock was out of date because my laptop battery is toast.

I reset my clock to today's date and the certificate errors disappeared.

Check your clock?

I have been having the same problem, chased my tail around for ages and then realised that my system clock was out of date because my laptop battery is toast. I reset my clock to today's date and the certificate errors disappeared. Check your clock?