Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox menu, right click menu, dropbox menu doesn't show up

  • 23 replies
  • 21 have this problem
  • 11084 views
  • Last reply by Cadeyrn

more options

I had a problem with Firefox. When I start the firefox, it works. But for a while (randomly) I can't click on firefox menu anymore. The right click menu doesn't work either. The dropbox (select box) in website does not work.

I'm using Xubuntu 12.04 64 bits:

   Linux minh-desktop 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux.

Everytime I get this problem, I have to restart the firefox. I had no problem with Firefox 12 had the problem with 13 and 14. I'm not sure if Firefox version or Linux Kernel causes the problem.

I tried safe mode but it doesn't help.

Please help. Thank you.

Chosen solution

Interesting...

Read this answer in context 👍 0

All Replies (20)

more options

Hi,

You can consider the Reset Firefox feature via Help (Alt + H) > Troubleshooting Information. To revert to the previous profile, you can close the new profile, start Firefox and choose the *.default profile. While the Profile Manager is open, you can also delete the newly reset profile (the one containing random numbers).

Managing profiles

Profiles Howto

The Xubuntu forum would also be helpful.

more options

I tried to create new profile but it doesn't help. I'm still having that problem. But it seem to be fewer.

more options

If you have Flash media open it could freeze the mouse for a few seconds. Also, you can check if there are any default Extensions and Plugins in Tools (Alt + T) > Add-ons and try to Disable those.

more options

It doesn't just freeze the mouse for a few second. I can still use mouse and left click but all menus are hidden. I think when it happen, only 1 layer of web/browser can display.

I try to disable all plugins, let's see what if can help. Thank you.

more options

But it doesn't. I'm still having this problem.

more options

You can try to create a new user account and check Firefox in that. You can also try the failsafe mode in the login screen options. The Xubuntu forum may also have useful pointers on new issues.

more options

Hi minhna,

I got the same problem here: menus + context menus freeze on my friefox 14 . All the usual tips didn't help (new profile, new .mozilla, safe mode, removed any unity dependent stuff). I got these problems when I went from ubuntu 10.11 to 04.12. I have the same problem with thunderbird (can you confirm this?) but not with drop down select boxes in web pages. Chrome is working fine. No clue yet. Will keep you updated.

more options

http://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/454708-pulseaudio-freezes-firefox.html https://bbs.archlinux.org/viewtopic.php?id=132580

and some other entries are refering to a problem with pulseaudio + firefox / thunderbird.

I removed ~/.pulse +!!! ~/.pulse-cookie . Removing ~/.pulse-cookie solved my problem. If you you are experienced you could try: "strace firefox 2> /tmp/strace.txt". open a menu and kill firefox once it freezes. Open /tmp/strace.txt and have a look at the last lines. If you see sth. like ".pulse-cookie" you're on the right track. Some people completely removed pulseaudio from their system. In my case "rm ~/.pulse-cookie" helped.

more options

I confirm that I have the same problem with the thunderbird but it's not quite often like with the firefox. I tried strace command but I didn't find any "pulse". But I removed the ".pulse-cookie" directory, hopefully this will help. I will update the result later.

more options

I have this exact problem with the same versions of Firefox and Ubuntu. I was beginning to wonder if I would ever find help. Trying the pulse thing now.

EDIT: So far, so good. I'll edit this post again if the right-click menu stops working again. Also, "pulse" wasn't in my strace either, so you might still be able to fix it by removing .pulse-cookie anyway.

Modified by Cadeyrn

more options

It's about 1 day and still fine. I think remove the .pulse-cookie is the solution.

more options

BAD NEWS, EVERYONE! Removing .pulse-cookie doesn't solve it forever. Also, .pulse-cookie keeps coming back despite my having uninstalled pulseaudio (I can do that because I use KDE). I had to workaround that by making a read-only empty file named .pulse-cookie so that it can't be overwritten.

Anyway, it isn't solved forever because if you click on ANYTHING AT ALL in the menus, the bug happens. This includes history, bookmarks, Web Developer features, and even Preferences. Try it. Curiously enough, if I use the sidebar, rather than menus, for my history or bookmarks or web developer things, it works fine. This is all with .pulse-cookie deleted.

I'm beginning to think this isn't .pulse-cookie's fault. I think .pulse-cookie runs an operation that clicking on a menu item also runs, and said operation causes this bug. If anyone here is a master at tracing these sorts of things (not me), you would be VITAL to fixing this problem.

EDIT: I've investigated the links posted earlier. The OpenSUSE forums topic, and the bug report it links to, are not related to our bug. They can fix their problem by disabling IPv6. I disabled IPv6 in /etc/sysctl.conf, and it didn't fix the problem. The Arch Linux forum topic is the same problem.

Modified by Cadeyrn

more options

I removed the pulse server but the .pulse-cookie still appears. Today I get lots of freezes. So there is no solution right now?

more options

You could also try to check the original Firefox which can be unpacked and used, separate from the distribution specific Firefox: https://www.mozilla.org/en-US/firefox/new/

Installation

System requirements

more options

minha, did you even read my extremely informative post? You can fix the .pulse-cookie issue by making a read-only empty file named .pulse-cookie. That way, when the actual file tries to come back, it won't be able to overwrite. But even then, we still can't use the menus without the bug coming back.

dumdidadida, downgrading back to the version of Firefox you had before this problem occurred (for me, that's 13) also fixes the problem, so yes, picking another version of Firefox is a confirmed workaround. However, I like to stay up-to-date. FF is improving significantly, and I don't want to miss out. And I really really hate dealing with tarballs because they don't get integrated into the dpkg system.

Modified by Cadeyrn

more options

I've filed this bug in bugzilla. Hopefully, we can actually get some attention there. https://bugzilla.mozilla.org/show_bug.cgi?id=779900

more options

chmod .pulse-cookie to readonly doesn't help. Is there any solution right now? I get lots of this problem.

more options

Still no fix, but the problem will stop getting in your face if you refrain from touching the menus.

more options

I have this problem in Kubuntu 12.10 running FF 17.0.1.

Has anyone tried anything higher than 17, like the Aurora or Nightly builds?

more options

^Are you another one who still has the issue after disabling the Unity menu extension? That fixed it for me.

  1. 1
  2. 2