Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not trust any secure connections/certificates

  • 10 replies
  • 22 have this problem
  • 7119 views
  • Last reply by dumdidadida

more options

I have just updated to the newest version of firefox and now whenever I visit a secure website I am told it is an untrusted connection and have to add an exception to visit it. When viewing the certificate it states it cannot be verified for unknown reasons.

This is happening with all websites including reputable sites like Google or Facebook.

I have tried a few things I found on the web but the posts were all quite old and didn't solve the problem so would appreciate any help I can get

Chosen solution

Also, it looks like the ESET AV is intercepting the secure traffic. If ESET has an option to install its root certificate into Firefox you can try that. You can also temporarily check by trying to disable HTTPS scanning in ESET. The ESET support would also be helpful.

Read this answer in context 👍 1

All Replies (10)

more options

Hi,

Please also try deleting the cert8.db file in the Firefox Profile Folder after exiting Firefox. You can also open the profile folder via Firefox Help (Alt + H) > Troubleshooting Information > Show Folder.

Firefox Profile Folder & Files

You can also consider the Reset Firefox feature via Help (Alt + H) > Troubleshooting Information.

If you have security software, you may have to fully re-trust the updated Firefox and its processes/files. Please see this for common configurations.

AV/Firewalls Configuration

more options

Thanks for the reply, I tried all of your suggestions with no luck. I still get the warning messages and am required to add an exception to get onto the website.

more options

Can you please create a screenshot of the error and also the certificates you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. You really help us to visualize the problem.

more options

Here is an example from a bank's website but i receive similar errors on all secure servers

more options

Check the data and time in Windows to make sure the year is set correctly.

more options

Chosen Solution

Also, it looks like the ESET AV is intercepting the secure traffic. If ESET has an option to install its root certificate into Firefox you can try that. You can also temporarily check by trying to disable HTTPS scanning in ESET. The ESET support would also be helpful.

more options

I just had a look in the ESET advanced setup and changed a setting and everything now seems to be working fine. I set it to 'Do not use HTTPS protocol checking'

Has this resolved my issue? Or disabled a layer of security that I should try and fix?

more options

I think you should definitely try to fix it, because even reputable sites including their HTTPS versions have been known to be compromised. Most probably ESET may have an option, or would have automatically installed its root certificate into Firefox, but it may have been corrupted. You can try to check the options in ESET to reinstall, or you may also be able to Import it manually via Firefox Tools (Alt + T) > Options > Advanced > Encryption > View Certificates > Authorities. The ESET support would also be helpful.

Options

more options

I think i have managed to enable it again and install the root certificate. Although i did reset ESET to its defult settings during this process and SSL filtering was disabled by defult.

Everything seems to be working as it should now so thanks very much for your help :)

more options

No problem :)