X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Spell checker doesn't work correctly

Posted

Despite loading the English (UK) dictionary, and selecting English(UK) the spell checker still highlights correctly spelt words. It still reverts to the strange American spellings.

It is extremely irritating and I would like to rectify this anomaly.

Iain

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • VLC media player Web Plugin 2.0.0
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

Chris Ilias
  • Moderator
115 solutions 1064 answers

After you've added the UK dictionary, right-click on any text field, go to Languages, and make sure English (UK) is check marked.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

See also:


Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

If you do not keep changes then see:

Modified by cor-el

Question owner

Hello Chris,

thanks for the reply but that is the problem, Eng (gb) is selected as a dictionary and in options.

Cor-el, I'll try running in safe mode, and see what happens.

Thanks both,

alec

Question owner

Hello Cor-el,

when I run in safe mode the English UK language option is not available. Perhaps I'll revert to 'add to dictionary' for the words it highlights that are correct in English English.

Alec

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

In safe mode all extensions are disabled and that includes extra dictionaries that you've installed.

Did you install the en-US Firefox version and the British-English dictionary?

You can check the value of the general.useragent.locale pref on the about:config to see which locale you've installed.

If you do have the en-US locale and do not need the en-US spell dictionary then you can uninstall the en-US version and install the en-GB version instead.

Your bookmarks and other profile data are stored elsewhere in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that you do not select to remove personal data if you uninstall Firefox.


Question owner

Hello Cor-el,

it seems that I have a US version, and I now see that the selection of the English(GB) dictionary only works for that particular text field then it reverts to the English (US), which explains my problem. How can I delete the English(US) dictionary? It doesn't seem that obvious?

Alec

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Easiest is to uninstall the en-US version to remove the dictionary and install the en-GB version.

The default dictionaries are located in the dictionaries folder in the Firefox program folder.

What is the value of the spellchecker.dictionary pref on the about:config page?

If you do not keep changes then see:

Question owner

Hello Cor-el,

it looks right it shows spellckecker\dictionary user set en-GB.

However if type, e.g. authorise it highlights it as wrong and when I check the languages the selected dictionary is en-US?

I'll try deleting it from the programme files.

Thanks,

Alec

efAston 0 solutions 1 answers

I had the same problem until I reinstalled the Australian (in my case) dictionary (I read someone on this forum fix the problem with the Canadian one that way).