X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Most of the sites opened in firefox get a small pop-up saying " the page at htpp://facebook.com says: please allow popups in your browser".. I reinstalled FF

Posted

Most of the sites opened in firefox get a small pop-up saying " the page at htpp://facebook.com says: please allow popups in your browser".. I reinstalled FF but no luck. I'm getting this issue since15 days

Chosen solution

Perhaps you have a misbehaving add-on. You could test using Firefox's Safe Mode, which disables graphics acceleration, many custom settings, and your add-ons.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

Do the messages go away?

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

That seems very strange: this is a little box with an OK button, and not an "infobar" that appears above the page?

If you want to change your popup setting for Facebook.com, right-click the page, choose View Page Info, click the Permissions tab, and adjust the setting there. Does it help? Make it worse?

Question owner

yes Youare correct.. its a little box with OK button. Tried the permissions tab for facebook.com ... blocked pop-ups .. but dosen't help. still the box appears on most of the websites.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Chosen Solution

Perhaps you have a misbehaving add-on. You could test using Firefox's Safe Mode, which disables graphics acceleration, many custom settings, and your add-ons.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

Do the messages go away?

Modified by jscher2000

Question owner

It still pops up in safe mode too... weird thing is it happens even with fresh installation of firefox... IE is fine gain...

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

If you disable Firefox's pop-up blocker, does the message go away? Do you get a lot of new pop-ups?

orange Firefox button or classic Tools menu > Options > Content

Try unchecking the first box and see how the behavior changes.

Question owner

pop-up blocker is already selected. pop-ups are blocked successfully... but not this small OK box... and that too from facebook.. Is there a way to attach a screenshot of that pop-up box... ?

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

I am suggesting you turn OFF the pop-up blocker by UNCHECKing the box, to see how things change.

Question owner

Oh sorry I didnt notice that... yes turned the pop-up OFF... and the box with OK button is no where :-) .. but the normal popups are visiting again ...

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Go ahead and turn off the pop-up blocker again. Can you give some URLs for pages where you get the little alert dialog requesting that you turn it on? I'd like to take a look at the scripts on those sites. Maybe we can find a way to target those selectively and get rid of them without using a higher maintenance approach such as the NoScript add-on.

Question owner

Sorry for the delay in replying. Here are few of the websites

facebook.com idlebrain.com extratorrent.com