X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox frequently loses window focus

Posted

It seems that Firefox frequently loses window focus when I open a new page. It may be a bookmark, a link opened into a new tab via CTRL+Left-Click, or whatever. The following scenario always results in the window losing focus (for me).

  1. Open Firefox.
  2. Open this link and bookmark it.
  3. Close and reopen Firefox.
  4. Open the page just bookmarked using the bookmark list and don't touch the window.

I read this page daily, so when I start Firefox and open the page, I have to click in it so as to scroll, etc..

Firefox 13, Windows 7 Home Premium 64-bit

I wish this site had "Preview" for its posts. Geez Louise.

Modified by RETierney

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox 12 or 13

Installed Plug-ins

Adobe Acrobat 10.1.3.32 Java Deployment Toolkit 6.0.310.5 Java Platform SE 6 U31 6.0.310.5 Shockwave Flash 11.3.300.257 Shockwave for Director 11.6.4.634 Silverlight Plug-In 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

Application Basics
Name
Firefox
Version
13.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
My Homepage
1.2
true
myhomepage_manishjain9@gmail.com
DigitalPersona Extension
5.0.0.4490
false
otis@digitalpersona.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.link.open_newwindow
1
browser.places.smartBookmarksVersion
3
browser.startup.homepage
about:home
browser.startup.homepage_override.buildID
20120601045813
browser.startup.homepage_override.mstone
13.0
browser.tabs.animate
false
browser.tabs.loadInBackground
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
13.0
font.name.monospace.x-western
Consolas
general.autoScroll
false
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1339362978
places.history.enabled
false
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
plugin.disable_full_page_plugin_for_types
application/vnd.fdf,application/pdf
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Mobility Radeon HD 6370
Vendor ID
0x1002
Device ID
0x68e4
Adapter RAM
512
Adapter Drivers
atiu9p64.dll atiuxp64 atiuxp64 atiu9pag atiuxpag atiuxpag atiumdva atiumd6a atitmm64
Driver Version
8.771.1.0
Driver Date
9-9-2010
Adapter Description (GPU #2)
Intel(R) HD Graphics
Vendor ID (GPU #2)
0x8086
Device ID (GPU #2)
0x0046
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version (GPU #2)
8.771.1.0
Driver Date (GPU #2)
9-9-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Mobility Radeon HD 6370 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS Util
3.13.4.0
3.13.4.0
NSS SSL
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS S/MIME
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC

rebmcr 0 solutions 2 answers

I can confirm that looncraz's solution works for me.

tzhu07 0 solutions 4 answers

I can also confirm that looncraz's solution works. Thanks for the contribution. You should get in touch with Adobe and let them know.

looncraz 0 solutions 5 answers

They know of the work-around. Why protected-mode causes the problem is trying to be resolved.

bob_the_backpacker 0 solutions 2 answers

I'll stay out of the English language debate - literary criticism isn't my field - but I'll express my appreciation to looncraz for a clearly-expressed and simple solution. At least, it works here, so far! Thanks.

pocketlama 0 solutions 2 answers

This bogs down for me at number 4. I just don't see a 32-bit Windows on the list. What shows up by default is the Desktop so I change it. I presume I'm searching in c:\. Is this where am I going wrong? I'm using Windows 7 Home Premium and it's a 64-bit operating system. Does that make a difference?

looncraz 0 solutions 5 answers

The original layout was lost in my comment. You have TWO possible places to find the configuration file. On 32-bit Windows (Vista/7/XP) it is c:\windows\SYSTEM32\macromed\flash. On 64-bit Windows (Vista/7) it is c:\windows\SYSWOW64\macromd\flash.

SYSWOW64 stands for System Windows (32-bit) on Windows 64-bit - it is where 32-bit programs (such as flash) store their system files or registry entries on a 64-bit version of Windows.

Gwynplaine 0 solutions 1 answers

Thanks looncraz, it works a treat!

Bussani 0 solutions 1 answers

I fixed this problem by adding the line of code that switches off Protected Mode, but as a result, I now get nothing but a black when make a video (on YouTube, for example) full screen. I'm not sure that trade-off is worth it for me...

looncraz 0 solutions 5 answers

Try uninstalling Flash and reinstalling. You may, otherwise, need to update your video drivers (I'm willing to bet you have intel or nVidia graphics - most likely intel).

Fail that, an older version of flash may be your only hope. Good luck!

Mickets 1 solutions 5 answers

I have the same problem, specially when watching videos on YouTube.

But, I am using Flash 10.3.183.20 with Nightly 17.0a1 and Firefox 14. The problem happens in both, and I'm using an older version of Flash.

55brianb 0 solutions 8 answers

The sooner someone replaces Flash the better. It's the single most annoying bit of software available at the moment, and has been for some time.

Adobe used to produce good stuff - now they seem to produce buggy crap.

polygnotus 0 solutions 1 answers

Wow, after all this time, that did it! Thank you looncraz.

tailwhip 0 solutions 1 answers

I uninstalled flash and the browser is working better, time will tell.