X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox frequently loses window focus

Posted

It seems that Firefox frequently loses window focus when I open a new page. It may be a bookmark, a link opened into a new tab via CTRL+Left-Click, or whatever. The following scenario always results in the window losing focus (for me).

  1. Open Firefox.
  2. Open this link and bookmark it.
  3. Close and reopen Firefox.
  4. Open the page just bookmarked using the bookmark list and don't touch the window.

I read this page daily, so when I start Firefox and open the page, I have to click in it so as to scroll, etc..

Firefox 13, Windows 7 Home Premium 64-bit

I wish this site had "Preview" for its posts. Geez Louise.

Modified by RETierney

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox 12 or 13

Installed Plug-ins

Adobe Acrobat 10.1.3.32 Java Deployment Toolkit 6.0.310.5 Java Platform SE 6 U31 6.0.310.5 Shockwave Flash 11.3.300.257 Shockwave for Director 11.6.4.634 Silverlight Plug-In 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

Application Basics
Name
Firefox
Version
13.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
My Homepage
1.2
true
myhomepage_manishjain9@gmail.com
DigitalPersona Extension
5.0.0.4490
false
otis@digitalpersona.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.link.open_newwindow
1
browser.places.smartBookmarksVersion
3
browser.startup.homepage
about:home
browser.startup.homepage_override.buildID
20120601045813
browser.startup.homepage_override.mstone
13.0
browser.tabs.animate
false
browser.tabs.loadInBackground
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
13.0
font.name.monospace.x-western
Consolas
general.autoScroll
false
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1339362978
places.history.enabled
false
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
plugin.disable_full_page_plugin_for_types
application/vnd.fdf,application/pdf
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Mobility Radeon HD 6370
Vendor ID
0x1002
Device ID
0x68e4
Adapter RAM
512
Adapter Drivers
atiu9p64.dll atiuxp64 atiuxp64 atiu9pag atiuxpag atiuxpag atiumdva atiumd6a atitmm64
Driver Version
8.771.1.0
Driver Date
9-9-2010
Adapter Description (GPU #2)
Intel(R) HD Graphics
Vendor ID (GPU #2)
0x8086
Device ID (GPU #2)
0x0046
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version (GPU #2)
8.771.1.0
Driver Date (GPU #2)
9-9-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Mobility Radeon HD 6370 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS Util
3.13.4.0
3.13.4.0
NSS SSL
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS S/MIME
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

What do you mean with losing focus?

Where does the focus go to?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


There are a lot of restriction on this forum with the first post that creates the thread like unable to preview and attaching images.

Question owner

You don't know what window focus means? When I say that the window has lost focus, I mean that Firefox does not respond to keystrokes or to scrolling via the mouse wheel. You must click somewhere inside the window to gain focus, then these things work. The most visible sign of focus is the color of the window. Without focus the window looks inactive, which it is. Focus does not go to any other window.

I tried safe mode and Firefox restarted without focus. So this would seem to eliminate add-ons and plugins.

tzhu07 0 solutions 4 answers

RETierney, thanks for posting this issue. I have the same problem.

I'm on Firefox 13 with Windows 7 64-bit, and whenever I load Firefox up and go to a site like Youtube, my Firefox window loses focus shortly after the page loads. And it does it here and there seemingly randomly too. It's really annoying when I'm scrolling through a page and it does this, and then of course I have to click into the window again before I can continue scrolling.

Please Firefox team fix this on the next Firefox update!

BTW I tried using Firefox in Safe mode with all extensions disabled and it still does the same thing. I'm thinking this is inherently a Firefox issue.

Modified by tzhu07

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Did you try if it still happens in Safe mode or with all extensions disabled?

tzhu07 0 solutions 4 answers

OK, I think I know what causes the problem: the Flash plugin. I'm using version 11.3.300.257.

When I disabled Flash on Firefox and loaded up Youtube, my window no longer loses focus. So I believe it's definitely the interaction between Firefox and Flash that is causing problems. No idea who's fault it is, but someone please fix it!

Modified by tzhu07

tzhu07 0 solutions 4 answers

cor-el, reverting back to Flash 11.2 worked! Hopefully Firefox and/or Flash will resolve this issue with their next updates. Having your window constantly lose focus seems like a major UI issue and very high up on the annoyance scale.

BTW I don't know if there's a way to mark this issue as resolved, but as of now this is the solution.

Modified by tzhu07

wstockall 0 solutions 1 answers

Flash 11.3 added "Protected mode for Firefox (Windows® Only)". Shouldn't we want to keep that? I don't see downgrading as a real solution, just removing a symptom of the problem. Are there any other plugins that use the new protected mode? Do they behave the same way?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Adobe and Mozilla are working on a solution for these problems, so this is only a temporarily downgrade in case one of the other proposed solutions aren't working.

Question owner

Oh, I forgot to include in my last post that I had tried safe mode but to no avail. Similar to tzhu07, I disabled Shockwave Flash 11.3 and the symptom has been alleviated. I too will wait. Thank you.

Hey, I just noticed that there is a "Preview" for the posts.

napok 0 solutions 1 answers

Helpful Reply

Oh please fix this ******* issue, it is driving me mad.


Edited by a moderator due to language. See the Rules & Guidelines .

Modified by the-edmeister

Question owner

I know your aggravation, but the man did say that Firefox and Adobe are working on a solution. Using Firefox with Flash disabled works for me in the interim. I would advise against using vulgarities; it will get you nowhere fast, and you may risk disbarment from this forum (speaking unofficially, of course).

rebmcr 0 solutions 2 answers

Actually a bit of profanity can help to make the issue less rigid, and bring a bit of human warmth to the discussion. It's not like it was directed at a person.

For what it's worth, I have this issue too - here's hoping Adobe pull their finger out sooner rather than later. It certainly is fucking annoying!

Question owner

Well, thank you for your insight. Let's just agree to disagree. As for me, vulgarity points to the character of the person--no offense intended, just my last thoughts.

Let's also hope that a resolution will be forthcoming.

Bob-Hill 0 solutions 1 answers

All users with this issue should vote on Adobe bug number 3223393:

https://bugbase.adobe.com/index.cfm?event=bug&id=3223393

The more votes, the higher priority Adobe should assign to the bug.

Kind regards, Bob Hill (just another user, not Adobe employee)

pocketlama 0 solutions 2 answers

Voted... It took but a moment to sign in and seconds to vote. I encourage others to do the same.

bob_the_backpacker 0 solutions 2 answers

I've added my vote on the bug but that doesn't help with the immediate problem. I'd like to know how this is now classed as 'solved' since I, for one, was unable to install 11.2: it refused to download an outdated version. If there's a way round this, what is it?

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24406 answers

The "owner" of this thread marked his question as solved. That designation for this thread has nothing to do with the overall situation regarding Firefox and Adobe Flash.

looncraz 0 solutions 5 answers

....... As are people who think colorful adjectives are "profane" or "vulgar." Who says? ......


The moderator "says" so. Besides editing postings, we can send you "to the corner" for a time-out.

Edited by a moderator due to language. See the Rules & Guidelines .

Modified by the-edmeister

looncraz 0 solutions 5 answers

Helpful Reply

Okay, I have something more constructive: This is how to FIX the problem - without downgrading to Flash 11.2.

Windows Vista/7 1. Find the notepad icon in the start menu 2. Right-click the notepad icon and click "Run As Administrator" 3. Choose "Yes" on the UAC prompt - if it shows up 4. File->Open 32-bit Windows: ...5. open c:\windows\SYSTEM32\macromed\flash\mms.cfg 64-bit Windows ...5. open c:\windows\SYSWOW64\macromed\flash\mms.cfg 6. Add the line as follows: ProtectedMode=0 7. Save. 8. Restart firefox. 9. Problem quickly resolved.