X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This Connection is Untrusted

Posted

I have problem to connect to gmail from my computer with firefox browser. This Untrusted connection message occur.

Modified by ikung adiwar

Additional System Details

This happened

Every time Firefox opened

This started when...

I try to connect to my gmail or facebook account

Installed Plug-ins

none

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

A message says, "this error could mean that someone is
trying to impersonate the site, and you shouldn't continue."
so what should i do to solved this problems...?
a step by step solution with explanation may be a useful.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Helpful Reply

Are you using any add-ons or services that route your connection through a proxy for anonymity?

Do you recall installing any Firefox add-ons recently, or any other software? (Installers for other programs can inject add-ons into Firefox.)


You may want to run some supplemental security scans. These two free tools are highly regarded:

Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free

SUPERAntiSpyware : http://www.superantispyware.com/


By the way, have you considered updating? Firefox 8 is known to have several security vulnerabilities.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Which security software (firewall, anti-virus) do you have?

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

What does it say under the technical details?


You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Modified by cor-el

oldboy 0 solutions 8 answers

I downloaded a trial of "Ashampoo WinOptimizer 9" and this screwed with the browser. Then reloaded new version of "Firfox 14" and had this prob eversince and it's a right pain in the butt !. BUT how to get out of it i'm lost. It appears that all sites visited are the correct ones and most have out of date certificates, ie they are not updated so there are going to be an awful lot of exceptions !.

Modified by oldboy

95yukon 0 solutions 1 answers

I'm having chronic problems with the warnings about the website being untrusted and "Get me out of here" warnings since switching to Windows 7 64 bit Ultimate along with Bit Defender total security 2013. I also use Bit Defender total security on an Windows XP Pro system and have no problems with this message. I ran the USB portable Firefox on other systems with no problems but even it warns me about untrusted websites and the "Get me out of here" warnings when running on my 64 bit system.

Is there something about Win 7 64 bit + Bit defender that is causing it? My only solution is to go back to Explorer or use my old XP Pro system, but have used Firefox for years and never saw this. This is horrible.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can disable Scan SSL in the BitDefender settings.

  • BitDefender -> Privacy settings -> disable Scan SSL
oldboy 0 solutions 8 answers

Hi all, Found the problem with this item for me. It is "Ashampoo" I tried out WinOptimizer 9 and it put an "ADDON/Extension into Firefox 14. Go to Firefox Addon's, then to Extensions and remove items. Save Bookmarks and Passwords. Then remove Firefox. Then restart PC. Then reload Firefox. Tick box to "NOT IMPORT ANYTHING" Then check if Addon's/Extensions have been removed. Reload/Import Bookmarks and Passwords. This might take more than one go. This then clears my problem. Have asked Mozilla to put "Ashampoo" on "Blocked List" !. Rgds.

Modified by oldboy

oldboy 0 solutions 8 answers

Problem back again. I use XP pro 3 with Bit defender & StopZilla. This problem has only started since upgrading to Ver 14. Cant use banking and a number of other sites. Have tried several times reloading/resetting Firefox and removed addons with no luck. Internet explorer works OK.

Modified by oldboy

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi oldboy, could you describe the symptoms in more detail. You are getting invalid certificates on some secure sites? Are there other issues?

oldboy 0 solutions 8 answers

Other problems are:- When going to untrusted site, the site opens in html mode only and therefore cant use the site.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Sites that don't load completely can indicate cache and cookies problems. When you hit one of these sites, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server. Any difference? If not...

2. Clear Firefox's Cache Completely

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

3. If needed, remove the site's cookies in this dialog

While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

have you disabled "scan ssl" inside the bitdefender options as cor-el has described above?

sonubuttar 0 solutions 1 answers

Helpful Reply

nothing to be be worried about if ur problem is as below. just updae and time on ur computer

oldboy 0 solutions 8 answers

In reply to Corel, Why would anyone want to disable SSL ?. With items such as Security Certificates being stolen it seems to be wise to check a bit more carefully.

In general I think this is still down to the earlier prog "ASHAMPOO" download. My other test PC works OK with Bit Defender & Stopzilla. This PC has not had "Ashampoo" loaded on it. Thanks for all ideas.

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello oldboy - bitdefender's option to "scan ssl" won't scan the security certificates but the secure webtraffic itself. normally this traffic will be encrypted by the webserver and decrypted by the browser - now when bitdefender listens into that encrypted stream it looks like a man-in-the-middle-attack for firefox - therefore the error message is shown. maybe it's also possible to add an exception for the certificate bit defender uses while scanning ssl traffic...

oldboy 0 solutions 8 answers

Thanks for that explanation, BUT that also means that IE8 doesn't recognize "man-in-the-middle", does it ?. Also as some sites don't show this problem they cant be sending ssl can they ?. Also as I and many others do a Google search, when allowing this with Firefox, why do we have to allow it so frequently, I would have thought that the Google ssl would be the same for every time you accessed it ?. Thanks.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Also as I and many others do a Google search, when allowing this with Firefox, why do we have to allow it so frequently, I would have thought that the Google ssl would be the same for every time you accessed it ?.

I don't think I've ever had to allow a Google search. Is this a feature of the Bitdefender software/add-on?

oldboy 0 solutions 8 answers

Hi there folks, Reply to madperson & Cor-el. Reluctantly I have disabled SSL checking in BitDefender (BD) and that appears to have cleared up the "Site not Trusted" problem and I have asked BD support to sort out this problem !. As I see it with so many stolen SSL Certs around then we as users need to be aware of the risks with this. Maybe other users can list their AV's with problems ?. Rgds.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Using the SSL check in BD makes it impossible for Firefox to verify that the certificate from a website is valid because Firefox never sees those certificates. Firefox only sees the certificate that BD sends to Firefox. If BD doesn't have a root certificate for the site that you want to go to then you have no way to install such a missing root certificate in Firefox. You are totally dependent on BD for all secure connections and BD is also able to see and scan all data that you send and receive via a secure connection.

oldboy 0 solutions 8 answers

Hi there folks, Have now had an upgrade to BitDefender from 2012 to 2013 version. This appears to work OK !. Also looking at SSL things Intel have Vpro on i5-i7 Cores to allow a more trusted security system !. Looks interesting.

jhardy93 0 solutions 2 answers

I have cleared my cache and this will still not work. I am getting the message that gmail is untrusted. I do use my porxy from work. gmail used to work and then whenever there is a new version I think I have this issue. It started again with FF15

Technical Details

       mail.google.com uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is not trusted.

(Error code: sec_error_untrusted_issuer)

Not sure if I should add the exception or not