X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This Connection is Untrusted

Posted

I have problem to connect to gmail from my computer with firefox browser. This Untrusted connection message occur.

Modified by ikung adiwar

Additional System Details

This happened

Every time Firefox opened

This started when...

I try to connect to my gmail or facebook account

Installed Plug-ins

none

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

A message says, "this error could mean that someone is
trying to impersonate the site, and you shouldn't continue."
so what should i do to solved this problems...?
a step by step solution with explanation may be a useful.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Hi jhardy93, you should not need to add an exception for google.com. As described in an earlier post, you can start the process of adding an exception to call up a dialog that lets you view the details of the certificate to see whether it appears to be from a legitimate source. If you have any doubts, feel free to post what you find here.

For comparison, on mail.google.com (and accounts.google.com, used for login) I get this certificate hierarchy (image attached):

Builtin Object Token: Versign Class 3 Public Primary Certification Authority > Thawte SGC CA > mail.google.com

Builtin Object Token: Versign Class 3 Public Primary Certification Authority > Thawte SGC CA > accounts.google.com

Modified by jscher2000

jhardy93 0 solutions 2 answers

I know I use a proxy server at work, but I can access gmail on IE on Chrome, but just not on Firefox, that is why I though the issue was with Firrefox. I wanted to use gmail on Firefox. I can access https://www.google.com/ and https://www.google.com/calendar both of which are secure connections. I just tried your links above and I can access mail.google.com without being secure. I like to always use https when it is avialable.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Hi jhardy93, I don't have personal experience using a proxy server. When you are not at work, you might have to manually turn off the proxy (i.e., set to No Proxy) if Firefox isn't detecting the change.

orange Firefox button or classic Tools menu > Options > Advanced > Network > "Settings" button


Does your IT support Firefox? Perhaps they have a specific solution for this issue while using their proxy server.

Modified by jscher2000

three_random_words 0 solutions 2 answers

I have been having the same problem, chased my tail around for ages and then realised that my system clock was out of date because my laptop battery is toast.

I reset my clock to today's date and the certificate errors disappeared.

Check your clock?