X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I resolve incompatibility of Adobe Flash with Firefox 13.0?

Posted

As of 6/10/12, Adobe flash 11.3 would NOT work in Firefox 13. On any web site. I had no problems with IE. I run Vista, latest update.

None of the posted answers on this site solved my own particular problems.

This is how I successfully addressed the issue:

1) I removed all Adobe Flash caches as directed in http://helpx.adobe.com/flash-player/kb/flash-player-games-video-or.html#main_6__Remove_Flash_Player_cache .

2) I uninstalled all instances of Adobe Flash through Programs and Features in the Control Panel.

3) I restarted my computer and Firefox.

4) I opened YouTube in Firefox. It directed me (automatically) to install Adobe Flash 11.2.202.235. Though I was aware of that version as the version previous to the current version (11.3), I was unable to locate it for download on the Adobe site.

Flash then worked again in Firefox 13.0.

Modified by Projgeekette

Chosen solution

My initial fix unfortunately only lasted for about an hour.

As what I thought would be my final coup de grace, I disabled Adobe Flash's protected mode - http://forums.adobe.com/message/4468493#4468493 .

That did the trick. Flash now works in ALL web sites. Google Earth also works.

Read this answer in context 1

Additional System Details

Installed Plug-ins

Acrobat, Google Earth, Google Talk, Google Talk Video Accelerator, Google Update, Java Deployment Toolkit, Java Platform, 2 Microsoft Office 2010 plugins, Picasa, Quicktime, RealPlayer, Shockwave Flash, Shockwave for Director, Windows Presentation Foundation

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

This is how I successfully addressed the issue:
1) I removed all Adobe Flash caches as directed in http://helpx.adobe.com/flash-player/kb/flash-player-games-video-or.html#main_6__Remove_Flash_Player_cache .
2) I restarted computer and Firefox.
3) I opened YouTube in Firefox. It directed me (automatically) to install Adobe Flash 11.2.202.235. Though I was aware of that version as the version previous to the current version (11.3), I was unable to locate it for download on the Adobe site.
Flash then worked again in Firefox 13.0.

jscher2000
  • Top 10 Contributor
2348 solutions 20815 answers

Interesting that YouTube provider a link to an older installer. I assume it was a link to somewhere on adobe.com and not their own copy? The download manager (Ctrl+j) might let you see the source if you right-click that download and choose Copy Download Link and paste it into a reply (or your favorite text editor).

Question owner

I followed up on your request. I uninstalled Adobe Flash 11.2.202.235. I removed all YouTube cookies. I rebooted my computer.

This time when I went to YouTube I was asked to install Flash, but this time I received the following links:

First: http://get.adobe.com/flashplayer/

Then: http://aihdownload.adobe.com/bin/install_flashplayer11x32_mssa_aih.exe - download location

So, this time, YouTube downloaded 11.3, and it works!

(What do you think was going on before that made 11.3 malfunction on my computer?)

Modified by Projgeekette

jscher2000
  • Top 10 Contributor
2348 solutions 20815 answers

It's a bit of a mystery. In several other threads, people are reporting problems with 11.3 and trying to go back to 11.2. Perhaps clearing the caches helped in your case??

Question owner

Thanks, Jeff. Except that I cleared the caches before the first install (of Flash 11.2 as selected by YouTube). I didn't clear the caches before the second install (of Flash 11.3 as selected by YouTube). I cleared YouTube cookies before both installations. ...All very confusing to me..

Nice that it's back working, and I'm using the latest version.

Modified by Projgeekette

Question owner

Sadly, Flash 11.3 stopped working after about 1 hour. I re-installed it, to no effect.

Modified by Projgeekette

jscher2000
  • Top 10 Contributor
2348 solutions 20815 answers

There are a number of active threads concerning the latest Flash player plugin (11.3) and the latest Firefox (13). Not all users are experiencing the same issues, but things to check include the following:

- Conflict with Realplayer Browser Record plugin (to disable this, open Add-ons from the orange Firefox button or the classic Tools menu and look under the Extensions and Plugins categories)

- Conflict with Flash 11.3 Protected Mode (see Adobe Forums: How do I disable Flash Player's protected mode for Firefox?)

Scanning down the front of the forums probably will yield additional suggestions: https://support.mozilla.org/en-US/questions

Does any of that appear promising?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96644 answers

Does it help if you disable all other plugins and maybe extensions as well as a test?

Modified by cor-el

dcain84 0 solutions 1 answers

HOLY CRAP!! It was realplayer downloader.... why is it always this plugin!!!???

Question owner

I disabled the RealPlayer plugins, that didn't resolve anything. YouTube is still saying "An error occurred, please try again later."

I do not have any more time to dedicate to this, and will wait until the problem is solved generically.

It would help if Adobe would allow Flash version 11.202.235 to be downloaded, but they block its download. It was the last reliable, functioning version that I used.

Chosen Solution

My initial fix unfortunately only lasted for about an hour.

As what I thought would be my final coup de grace, I disabled Adobe Flash's protected mode - http://forums.adobe.com/message/4468493#4468493 .

That did the trick. Flash now works in ALL web sites. Google Earth also works.

Modified by Projgeekette

thosas 0 solutions 9 answers

Hi guys - for me this helped. Close Firefox - open Internet Explorer - got to the Adobe Flash Player Site:

http://get.adobe.com/de/flashplayer/

In IE you can see there is the 64-bit version - (in Firefox there was just the 32-bit version) - got to: (others)

http://get.adobe.com/de/flashplayer/otherversions/

choose your system and version download it via internet explorer and install the adobe flash player restart firefox and it should work. helped me after wasting one day of my life to find a solution, alle sites work just fine now. hope this helps.

Question owner

Thosas - Do you have a 64-bit processor? Or 32-bit?

thosas 0 solutions 9 answers

64-bit

jscher2000
  • Top 10 Contributor
2348 solutions 20815 answers

Helpful Reply

Firefox for Windows is a 32-bit application.

tstout1000 0 solutions 1 answers

I have the same issues. After a few hours trying to debug. I remembered Adobe Updater updated my Flash to 11.3 on 6/12. I uninstalled it and FF now works great again. The latest Adobe Flash update appears incompatible with FF 13.

floobydust 0 solutions 1 answers

Reinstalled older flashplayer11_2r202_228_win_64bit as temp fix.

mathman 0 solutions 22 answers

I uninstalled flash 11.3 and replaced it with 10.3 and the link problem went away. However Adobe updates it to 11.3 - automatic update. I have tried it twice so far. How do I stop Adobe from updating so I can keep flash 10.3? In other words, how do I turn off the automatic updating of flash?

jscher2000
  • Top 10 Contributor
2348 solutions 20815 answers

How do I stop Adobe from updating so I can keep flash 10.3?

This is for Flash 11, but might also work for Flash 10. Right-click a Flash video and choose Global Settings. On the Advanced Tab, you can choose to be notified rather than having the player updated automatically.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96644 answers

Helpful Reply

Flash Global Notifications Settings Panel:

mathman 0 solutions 22 answers

Latest peculiarity. I have two computers, old one on Windows XP, new one on Windows 7. For the Windows 7 computer I had to go to flash 10.3 and turn off automatic updates. On the other hand, the XP computer has flash 11.3 and does not have the problem being discussed.

Note: thanks for the advice on turning off automatic updates.