X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 13 flash player not working with video (white screen)

Posted

I moved to the new 13 version, but there is a white screen where the video is supposed to run. Youtube is also showing an error (not playing video).

I thought it was the new update to the flash player, but chrome and IE are working fine so it is a firefox thing.

Modified by shriek11

Chosen solution

Moderator Edit: The RealPlayer Record extension is known to cause this issue. Please read the Flash 11.3 doesn't load video KB article for details on disabling this extension.


Hi, I had this issue today and I fixed it with this solution : 1) Uninstall Adobe Flash Player plugin in Windows programs 2) Launch Firefox and go in www.youtube.com 3) Firefox suggests to install Flash Player's plugin (yellow bar at top). Install it.

Read this answer in context 85

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

Alidjow 1 solutions 1 answers

Chosen Solution

Moderator Edit: The RealPlayer Record extension is known to cause this issue. Please read the Flash 11.3 doesn't load video KB article for details on disabling this extension.


Hi, I had this issue today and I fixed it with this solution : 1) Uninstall Adobe Flash Player plugin in Windows programs 2) Launch Firefox and go in www.youtube.com 3) Firefox suggests to install Flash Player's plugin (yellow bar at top). Install it.

Modified by Matt_G

Helpful Reply

It seems that FF 13 is working with 11.2.202.235, while the newest flash plug-in is 11.3.300.257. This is the first time an updated plug-in, not a BETA, has failed in firefox.

Chrome seems to use the IE plugiin, since flash was still working when I uninstalled the non-IE plugin. Mozilla seems to have dropped the ball here.

Modified by shriek11

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You can try to disable protected mode in the Flash 11.3 player if there are problems.

See:

CompaqKidd 0 solutions 1 answers

that was it!! now every video an apps are working again including realplayer

jlbyler 0 solutions 1 answers

Helpful Reply

Hello All,

I just spent hours figuring out a solution for this problem. THEN I noticed that Firefox had an official "response" to the issue, Here .

I didn't try any of the 'fixes' listed in the above article, because I'd already lost my patience and reverted back to a previous version of Flash until a proper and official fix becomes available.

Here are instructions on how to revert back to an old version of the Adobe Flash Plugin.

I've attached pictures for all of the steps below, as a visual reference. To be entirely honest, you may want to just look at the pictures. I tend to go into a lot of detail when typing out instructions, and the pictures may be easier to follow.  :-D

IMPORTANT : First, you must uninstall the current Flash Plugin from the Programs list on your computer. For me (Windows 7), you can do this by going into Control Panel -- Programs and Features -- Find "Adobe Flash Player 11 Plugin" in the programs list -- Right Click -- Uninstall.

Now, follow the steps below. Remember: pictures are attached below for visual representations of each step.


  • Step 1: You need to know which version of Flash to download. Open THIS LINK in a new tab to go to the main Flash Download page, and at the top of the screen you'll see this: Adobe Flash Player 11.3.300.257 (9.36 MB), and directly under it, you'll see this: Your system: Windows 32-bit , English, Firefox. Remember this information. You will be needing it later.
    • NOTE: That is just a sample. Your system could be Mac, Spanish, whatever. The point is, Adobe will let you know which system you're running, and therefore, which Flash Player you'll need.


  • Step 2: After you've seen which system you're running, click on the 'Do you have a different operating system or browser?' link directly below your system info.


  • Step 3: A new page will appear. You DO NOT have to select your operating system or version from the drop down lists. Just look below the "Download Now" button, and you'll see a message saying 'If your operating system/browser combination is not displayed, click here for older versions of Adobe Flash Player.' Click on that light blue "Click Here" link.


  • Step 4: A new page will appear again. This page is titled 'Flash Player Help / Archived Flash Player Versions.' When you get to this page, scroll waaay down until you get to the section titled 'Release and Content Debugger Archives', (directly below the chart).


  • Step 5: Click on any of the listed versions of Flash Player to download. I clicked on the topmost one (Released: 4/13/2012, Version: 11.2.202.233). Download this .zip file to your computer.


  • Step 6: Open the .zip file, and install this version of Flash Player as usual. Again, I'm running Windows 7 32 bit, so from here on out, I can only provide instructions for similar Operating Systems. But I'm sure you'll get the idea.


For Windows 7: Double click on the .zip file you just downloaded to open it. One file folder will be displayed inside (mine was titled fp_11.2.202.233_archive). Open this file folder.

Next, remember which 'bit' your system is running (this information was from Step 1), and click on the appropriate folder. My system is 32 bit, so I clicked on the first 32 bit folder (titled 11_2r202_233_32bit).

A whole bunch of files are contained in this folder. Once again, I can only speak for myself, but I chose the flashplayer11_2r202_233_win_32bit Windows Installer Package file. A setup was executed, and a previous version of Adobe Flash Plugin is now installed on my system.

It's been running flawlessly ever since! YouTube works again, and though I have a huge headache, it works for now until a fix is released by Mozilla.

I don't know a lot of technical terms, but I wanted to at least attempt to explain this fix for others out there with the same YouTube/Flash/Mozilla Firefox problem. If anyone has any questions, feel free to reply and I'll certainly try to help you!

Modified by jlbyler

chances14 0 solutions 2 answers

I had this same problem. solved it by disabling the realdownloader plugin. Hopefully, mozilla can fix this issue in the future because i use the realdownloader plugin on a regular basis

deathbycheese 0 solutions 2 answers

According to Adobe's forum here: http://forums.adobe.com/thread/1018071?tstart=0

The culprit is RealPlayer. It says to disable the RealPlayer Browser Record plug-in and gives instructions how.

This worked great for me! Simple, quick. No fiddling around.

dbc

docwho 0 solutions 1 answers

Disabling the protected mode of flash 11.3 worked for me. I edited my mms.cfg file in the windows system32 and syswow64 macromed flash folders (had to create the one for the system32 folder) by adding the line

ProtectedMode=0

as described in the links above, then shut down and restarted my browser -- I then confirmed proper function by going to youtube and moving my cursor over the video to start it. My RealPlayer video one-click download also worked just fine -- no need to disable the add-on.

Modified by docwho

bigmur001 1 solutions 2 answers

This problem only exists with FF 13.0.1 in Windows Vista. Flash Player 11.3.300.257 works well in Firefox 13.01 under windows 7. I downgraded the flash player to 11.2.202.235 and It now works well with FF 13.0.1 in Vista Ultimate 64 bit.

chances14 0 solutions 2 answers

It's not only vista. I have windows 7 and I had the same problem with flash player not working

Saucer419 0 solutions 3 answers

Problem solved - change browsers.

WendellG 0 solutions 1 answers

Thank you for posting this, was driving me crazy without much time to really researched I switched browsers for a bit and finally came back to it. I had tried to disable real player, didn't work, tried disabling plug in for player 9 I still saw hanging out there, nadda. Your solution above worked, only difference was using 64-bit, so clicked on 64 bit folder, after having to use .exe file and having to extract to new folder finally could click on flashplayer11_2r202_233_win_64bit.exe. Now I can see flash players in browser.

I also made sure to uncheck the "Update Add-ons Automatically" on the settings at top of Add On Manager in FF, just in case.

Again many thanks.

bunter1031 0 solutions 1 answers

Thank you thank you thank you  :) I was trying everything.Your offered solution worked like a charm for me.

bolt48 0 solutions 5 answers

I uninstalled the latest Adobe, and ta daa! Thanks.

GreenCAT 0 solutions 1 answers

This worked for me. I went to the adobe site: http://forums.adobe.com/thread/1018071?tstart=0 and disabled the RealPlayer Browser Record plug-in. Immediately after opening a new window, youtube videos started working again! I was trying to fix this for a whole week and this finally did it!

AudraL1 0 solutions 1 answers

cor - el

Thanks for posting this option. After repeated attempts to troubleshoot firefox 13.0.1 and Flash Player 11.3.300.262, I used your fix and disabled protect mode. Tada, facebook games loaded without complications.

Modified by AudraL1

bolt48 0 solutions 5 answers

Thanks for the help.

smyth1313 0 solutions 1 answers

thank you thank you thank you JLBLYER for taking to time to help with this, finally after months of craziness i can watch my videos....your remedy worked--these computer folks should hire you!!!!! thanks again!!!!!

jgaulon 0 solutions 4 answers

Tried that, didn't work on my end, would not automatically install plugin had to do manual did not work.

Kazuyuki 0 solutions 3 answers

Try disabling Shockwave Flash plugin. In my case, that's the real culprit since there really isn't any Real Player plugin installed in Firefox in the first place (I only used RP in Google Chrome for downloading)