Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Upgraded to Firefox 14 today and immediatly was running slow like I was wiht 12. On the other hand 13 betsa ran like a champ. Any ideads?

  • 5 replies
  • 208 have this problem
  • 1 view
  • Last reply by Tex

more options

Firefox runs painfully slow. I upgraded from 12 to 13 beta recently and the problem went way. With 14 its just like before

All Replies (5)

more options

Given that Firefox 14 is the current beta version, there could be a bug that you're seeing. Have you tried disabling all of your addons or temporarily using a new profile?

more options

I had the problem with FF 14 develop when I went from XP to Windows 7 Pro. I tried every fix in the forum plus uninstalled it using Revo Uninstaller and did a clean install, nothing worked. Then I said to myself "duh" and right clicked on the FF desktop icon and ran a compatibility check. Windows said FF 14 was not compatible with Windows 7 and is now running FF14 in the XP mode (a feature of Windows 7 Pro). It works fine now.

What is odd is that I have 2 other computers running Windows 7 Pro but FF 14 runs fine in Windows 7 on them.

more options

Since going to V 14, found that after a couple of minutes use, keying in to fileds (e.g. Google search input) becomes painfully slow. I have to hold the key down for 2 - 3 secs before it 'takes', for EACH CHARACTER!

Noted the 'running FF14 in the XP mode' & tried this & it apperas to have worked.

THX

more options

Which security software (firewall, anti-virus) do you have?

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.

more options

I was able to install FF15 but I had to remove all my anti-virus, anti-spyware, etc. using http://www.appremover.com/

Next time I'll try it in the Safe Mode and see how that works.