Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps crashing on my iMac running Mavericks

  • 21 replies
  • 19 have this problem
  • 1818 views
  • Last reply by ingo555

more options

Hi Guys,

Firefox keeps crashing on my iMac running latest Mavericks. It's really anoyng cause it happens allot.

bp-4d4f7f49-4f99-44b1-982c-7e58c2140504 - 5/4/14 22:36 bp-b209255f-b1c1-411a-91a3-773642140504 - 5/4/14 22:34 EC183342-2607-4E20-9E13-74805DBAB1E2 - 5/4/14 21:34 3585298B-F6BE-4D71-9694-AEC60051CF39 - 5/4/14 21:25 7D75B950-CFAB-4A44-8A0F-34AE43A2C5E2 - 5/3/14 13:58 7125A674-E769-4461-A2BF-22954B91B228 - 5/3/14 13:13 bp-cbd15c13-a1db-47d9-865b-769dd2140503 - 5/3/14 13:12

Any help would be appreciated , thanks.

All Replies (20)

more options

Hi ingo555, the crash report you are posting is from a previous version of Firefox. Could you please retry this with Firefox 29?

more options

Dear Sander,

Ok, I updated to the latest version. Let's hope it stays stable. I will respond if any problem occur again.

Thank you.

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

more options

Hi Guys,

I updated to FF 29 and remove custom theme back to default. I disabled some add-on and extensions. It's still crashing a couple of times a day.

bp-ebb88be2-00aa-4089-b4de-1d7012140505 - 58 minutes ago bp-180b1457-fc77-4628-bec3-324c12140505 - 6 hours ago bp-ac932ad4-0736-4092-9fe3-b4e542140505 - 9 hours ago

Any suggestions?

more options

Ingo, I can see in the dump that you are not yet running in safe mode - is that right? I still see still extensions and plugins that are non-default. Although I understand that you may need some of these, it's important to narrow down the issue to follow the safe mode steps. Debapriya has given an extensive explanation on the steps to take.

more options

Ok, I understand. Today I will run FF the whole day in Safe mode and lets see what happen. I am in ICT Bangkok, Thailand.

more options

I running the Firefox for 2 days now in Safe mode. It never crashes. What shall I do?

more options

ingo555:

Can you do two things for me?

1) Can you start by giving us the troubleshooting information from the Firefox installation that's having problems. This is an essential step in troubleshooting.

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the sub-menu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.

Now, a new tab containing your troubleshooting information should open.

  • At the top of the page, you should see a button that says "Copy text to clipboard". Click it.
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

2) If Firefox opens up fine with no problems, it's probably one of your extensions that's causing the issue. You can re-enable your add-ons one by one until you find the one that causes the issue upon being re-enabled.
( If this suggestion works, please ignore step 1)

more options

Application Basics


Name: Firefox Version: 29.0 User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0

Crash Reports for the Last 3 Days


Report ID: bp-9b08b915-29e2-47a2-876a-5fcaa2140505 Submitted: 2 days ago

Report ID: bp-ebb88be2-00aa-4089-b4de-1d7012140505 Submitted: 2 days ago

Report ID: bp-180b1457-fc77-4628-bec3-324c12140505 Submitted: 2 days ago

Report ID: bp-ac932ad4-0736-4092-9fe3-b4e542140505 Submitted: 2 days ago

Report ID: bp-4d4f7f49-4f99-44b1-982c-7e58c2140504 Submitted: 3 days ago

Report ID: bp-b209255f-b1c1-411a-91a3-773642140504 Submitted: 3 days ago

All Crash Reports (including 2 pending crashes in the given time range)

Extensions


Name: 1Password Version: 4.1.0 Enabled: true ID: onepassword4@agilebits.com

Name: Adblock Plus Version: 2.6 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Adblock Plus Pop-up Addon Version: 0.9.1 Enabled: true ID: adblockpopups@jessehakanen.net

Name: DownloadHelper Version: 4.9.22 Enabled: true ID: {b9db16a4-6edc-47ec-a1f4-b86292ed211d}

Name: DownThemAll! Version: 2.0.17 Enabled: true ID: {DDC359D1-844A-42a7-9AA1-88A850A938A8}

Name: LastPass Version: 3.1.1 Enabled: true ID: support@lastpass.com

Name: Premiumize.me Version: 0.5 Enabled: true ID: jid1-sirVJT0BXhkuJg@jetpack

Name: Xmarks Version: 4.2.5 Enabled: true ID: foxmarks@kei.com

Name: Adobe Acrobat - Create PDF Version: 2.0 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom

Name: Toggle animated GIFs Version: 1.1 Enabled: false ID: giftoggle@simonsoftware.se

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140421221237 browser.startup.homepage: https://www.google.de/ browser.startup.homepage_override.buildID: 20140421221237 browser.startup.homepage_override.mstone: 29.0 dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 29.0 font.internaluseonly.changed: false keyword.URL: http://search.genieo.com/results.html?v=gim19340001&t=1405&q= mousewheel.enable_pixel_scrolling: false network.cookie.prefsMigrated: true places.database.lastMaintenance: 1399365075 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.sharepointbrowserplugin: 1 print.macosx.pagesetup-2: PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: print.print_command: print.print_downloadfonts: false print.print_duplex: 0 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_paper_data: 0 print.print_paper_height: 11.00 print.print_paper_name: print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8.50 print.print_plex_name: print.print_resolution: 0 print.print_resolution_name: print.print_reversed: false print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 57 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.popups.showBrowserMessage: false privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1397977635

Graphics


Device ID: 0x11a3 GPU Accelerated Windows: 1/1 OpenGL (OMTC) Vendor ID: 0x10de WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce GTX 680MX OpenGL Engine windowLayerManagerRemote: true AzureCanvasBackend: quartz AzureContentBackend: quartz AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3

NSS Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSMIME Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSSL Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSUTIL Expected minimum version: 3.16 Version in use: 3.16

more options

Ooh, looks like Firefox crashed a few times a day. Let's see if I can't figure out what's up. It looks like it's related to some sort of extension but I can't be sure

You say Firefox worked fine in Safe Mode. If Firefox opens up fine with no problems in Safe Mode, it's probably one of your extensions that's causing the issue. Read below to get into Safe Mode again.

  • Windows/Mac: Go to Help > Restart with add-ons disabled

You should re-enable each of your add-ons in Safe Mode (as they are disabled) one-by-one to pinpoint which add-on is misbehaving. I have a suspicion about premiumize but that's just me.

more options

I use premiumize to have a proxy. Some website are blocked by my ISP and I need it to run 24/7.

more options

ingo555:

Ooh, I understand. Did you try my steps above. I'll repaste them here.

  You say Firefox worked fine in Safe Mode. If Firefox opens up fine with no problems in Safe Mode, it's probably one of your extensions that's causing the issue. Read below to get into Safe Mode again.
 *Windows/Mac: Go to Help > Restart with add-ons disabled
 You should re-enable each of your add-ons in Safe Mode (as they are disabled) one-by-one to pinpoint which add-on is misbehaving. I have a suspicion about premiumize but that's just me.
more options

Ok I will try that and lets see. Is there any particular website i can visit that would help speed up the progress? (If that make sense)

more options

Hey, I can't enable any extension in Safe Mode. Only "disable" or "remove".

more options

..but they are all "disabled".

more options

Can you give me a screenshot so I know what you're seeing? Please see How do I create a screenshot of my problem? to create a screenshot
Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.


Be sure you are in Safe Mode! You MUST close Firefox down before opening in Safe Mode. You can also try to start Safe Mode by doing the following while Firefox is completely closed

  • Hold down the OPTION key while clicking the Firefox icon in your Applications Folder or your Dock
more options

See attached Screenshot.

more options
  1. Open your profile folder: Ways to open below
  • Help > Troubleshooting Information > Profile Directory > Show Folder

or

  • Go to about:support and click Show Folder next to Profile Directory.
  1. Close Firefox
  2. Delete the following files if they exist, extensions.cache, extensions.rdf, extensions.ini and extensions.sqlite
  3. Re-start Firefox, it will then rebuild the list on installed extensions

After this, restart in Safe Mode and try to enable your add-ons.

more options

extensions.cache NOT EXIST extensions.rdf NOT EXIST extensions.ini OK extensions.sqlite OK

But still I can't enable Add-Ons or Extensions.

more options

A shot in the dark but you can try to disable hardware acceleration.

Firefox has hardware acceleration set to "on" by default, but it's still young, which means some video cards or drivers might have problems with it. You can try to disable hardware acceleration to see if that alleviates your problems.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps for Firefox version 29.0 and above:

  • Click the menu button New Fx Menu and select {menu Options} for Windows or {menu Preferences} on Mac or Linux. For Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window, click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

  1. 1
  2. 2