X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

After Firefox 13 update Gmail and Twitter won't load

Posted

I have updated to Firefox 13 and now Gmail and Twitter are really slow or won't load at all. I have updated my plugins, I've cleared cache and cookies. What else can I do? Thanks.

Chosen solution

hello, some other users have reported the same issues for gmail & twitter with SPDY enabled (which was introduced in firefox 13).

enter about:config into the location bar & search for the preference named network.http.spdy.enabled and toggle it to false by double-clicking it - this disables the spdy protocol. please see if that works & report back. thank you!

Read this answer in context 134

Additional System Details

Sites Affected

http://

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

Chosen Solution

hello, some other users have reported the same issues for gmail & twitter with SPDY enabled (which was introduced in firefox 13).

enter about:config into the location bar & search for the preference named network.http.spdy.enabled and toggle it to false by double-clicking it - this disables the spdy protocol. please see if that works & report back. thank you!

Rossco 0 solutions 5 answers

Worked for me and for what its worth, I rolled back to FF12 where everything worked and saw this very setting. Turned it on and it broke GMAIL in FF12 too. What exactly is SPDY supposed to do? EDIT: I completely forgot to say thanks for your assistance as well madperson, so "Thanks for your assistance" :) Much appreciated!

Modified by Rossco

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

it actually is supposed to make pages load faster :-/

https://en.wikipedia.org/wiki/SPDY

Question owner

Works a treat, thanks a lot!

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hey, i'm checking back again - another user on the forum has reported, that the problem only occured when the network.http.keep-alive preference in about:config was set to false.

could you have a look if this is also the case on your system? if so please try toggling network.http.keep-alive to "true" (the default value) & network.http.spdy.enabled also back to "true" and see if the sites are still loading normally. because if SPDY is enabled & actually works right this would bring you a performance benefit when loading pages that support the protocol...

if network.http.keep-alive was already set to true, could you look at the other preferences that start with network.http. & see if any of those is not on its default value (=shown in bold) & report it here. this would help further troubleshooting the issue.

Question owner

Hi, I did exactly what you said and both websites load fine. Very helpful, thanks!

Rossco 0 solutions 5 answers

OK, lets see if I got this straight... I tried in FF13 the following combinations... network.http.keep-alive to "true" network.http.spdy.enabled also back to "true"... worked network.http.keep-alive to "false" network.http.spdy.enabled also back to "true"... wouldn't even load the link to GMAIL, failed network.http.keep-alive to "false" network.http.spdy.enabled also back to "false"... worked network.http.keep-alive to "true" network.http.spdy.enabled also back to "false"... worked

Does this help?

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Can we get some more system information from the people who are having this issue? We are trying to figure out if it is OS/Version specific. All the details you can share will help!

Question owner

Its Windows Vista 2007 home premium service pack 2

Rossco 0 solutions 5 answers

So basically SPDY has to be enabled along with KEEPALIVE. If you enable SPDY, KEEPALIVE has to be enabled for everything to work?

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

thanks to both of you for reporting back!

Rossco 0 solutions 5 answers

WIN7 Pro SP1 FF13

Rossco 0 solutions 5 answers

Interesting article about SPDY, thanks for the link!

Modified by Rossco

hereforatick 0 solutions 1 answers

Helpful Reply

I'm unsure if this is your exact problem. However, with my recent update gmail wouldn't load after signing in, and I had to view gmail in html mode.

For anyone with the same issue that has the adbock plus add-on, and has found nothing working:

I just updated the filters, brought up the gmail page that says gmail is taking longer than usual to load, selected in ABP to "disable on this page only," refreshed the page, and re-enabled ABP.

Everything is working as normal now.

Modified by hereforatick

Ian.F 1 solutions 37 answers

Hello all. 1) Yesterday (9th June, 2012) I attempted for the first time since upgrading from FF 12.0 to FF 13.0 to load an attachment in Gmail, which failed; I tried several different types of file, but all attempts immediately generated the message "Attachment Failed". Using madperson's initial suggested solution of setting the value of 'network.http.spdy.enabled' to 'false' solved this problem - many thanks to madperson for that. 2) Concerning possibility that a value of 'false' for network.http.keep-alive is causing problems this was not a factor in my case as the value was already set to 'true'. 3) At madperson's request I have determined that in my case no other values for settings beginning 'network.http' are on their default values except for SPDY that I changed: this is assuming defaults are normally in bold. 4) I am using Windows XP SP3.

Modified by Ian.F

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

thanks for reporting your configuration details ian. (actually it's the other way round, default values are the non-bold ones, but it seems clear from your description that the only setting that was changed is spdy.enabled)

it would also be interesting if the problem is still there in firefox 14, would you mind downloading the beta version of firefox 14 and giving it a test run with network.http.spdy.enabled set to true again for once? you can just download the setup file for the beta version & install it on top of your current installation (and if you want to switch back afterwards its the same; just download & install the release version over the beta version) - your data and settings will be kept.

https://www.mozilla.org/firefox/channel/

Vainaja 0 solutions 1 answers

Worked for me only after clearing the search history. I set the network.http.spdy.enabled to False and didn't touch anything else.

Ian.F 1 solutions 37 answers

madperson, hi. I am afraid I have not got around to checking out FF 14.0 beta, but on my work quad-core computer using Microsoft Multipoint server 2011 I have just attempted to attach a file in Gmail with the FF configs network.http.spdy.enabled and network.http.keep-alive each set to 'true'; the file attached normally and Gmail itself opened without any difficulty. You will recall that, by contrast, using my laptop with Windows XP SP3 I could not attach a file in Gmail with SPDY set to 'true', instead having to change it to 'false'. Perhaps as Matt_G suggested there might be an OS-related issue here. My laptop is about ten years old; could there be a hardware issue?

Modified by Ian.F

Ian.F 1 solutions 37 answers

Madperson, hello again. A quick update. Using the value 'true' for both the SPDY and keep-alive settings I have just successfully attached files in Gmail on another computer - newer than my laptop, though not up to date - using WIndows XP (Pro) SP3, so the issue would appear not to be OS-related, but this does not rule out a hardware issue.

Modified by Ian.F

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

thanks a lot for further investigating the issue & reporting your findings. your case on the old laptop seems to be exceptional, maybe it's related to the hardware or the network equipment you use at home or a combination of both of them. in case it's not reproducible it will probably not be possible to offer a fix for this problem - but hopefully you can live with keeping spdy disabled as a workaround. your old laptop probably won't perform performance stunts any more anyway - no mather if spdy is enabled or not ;-)

for all other users reading here - the general error with spdy related to the network.http.keep-alive setting should be fixed with the release of firefox 14.