X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop getting the prompt to update plugins?

Posted

I don't want to update plugins, Firefox keeps interrupting everything I do the page keeps bumping up and down

Additional System Details

This happened

Every time Firefox opened

This started when...

today May 23

Installed Plug-ins

I'm getting request for all plugins

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

The page is bumping up and down? I'm not exactly sure what you mean -- a bar appears above the page with a button to take some action?

By default, Firefox will update your existing add-ons automatically without asking. If you are getting constant questions, you might have some malware on your computer. You may want to run some supplemental scans. These two tools are highly regarded:

Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free

SUPERAntiSpyware : http://www.superantispyware.com/

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

or in case you are referring to the "missing plugin" info bar, enter "about:config" into the address bar of the browser, search for a preference called "plugins.hide_infobar_for_missing_plugin" & doubleclick it in order to toggle its value to false.

http://kb.mozillazine.org/Plugins.hide_infobar_for_missing_plu...

MikeWilson 0 solutions 28 answers

There shouldn't be a problem updating plugins. Some of them have their own pop ups like FLASH PLAYER.

Go to TOOLS, ADD-ONS, PLUGINS and CHECK FOR UPDATES (at top) . This will tell you which Plugins need updating. I DISABLE all plugins except for the ones I need.

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Attention Windows Users

Apparently, the latest Flash updater doesn't remove the out-of-date Flash components right away, but only when you restart Windows. This is convenient because you don't have to close all your browsers. The downside is that Firefox keeps detecting the out-of-date files and urging you to update.

Obviously it is inconvenient to restart Windows, but at the moment, that appears to be the best workaround. If you are sure you have the current version of Flash (you can check Adobe's About Flash page) and a restart doesn't work, please post back.

The developers are aware of this problem and working on a solution for a future version of Firefox.

(It might be possible to remove the files manually and then restart just Firefox, but this probably is more work than restarting Windows.)


Edit: If someone has this problem, could you check another thing?

After updating Flash, on the add-ons page, you may see two Flash plugins listed. Can you disable the older one and see whether that suppresses the error?

orange Firefox button or classic Tools menu > Add-ons

In the left pane, click Plugins, then look for Shockwave Flash version 10.1 or earlier, and try the Disable button. You might need to restart Firefox for this to take effect.

When you visit a page with Flash video, does the error still appear?

Modified by jscher2000

MikeWilson 0 solutions 28 answers

Perhaps if you update plugins through the TOOLS option as posted above, it might clear out the old components. You may find other plugins out of date also.

wadedotrichard 0 solutions 5 answers

I got a message from Firefox saying that several of my plugins need updating, and that some are vulnerable to attacks from websites. I have tried repeatedly to update the Shockwave Flash and Quicktime Plug-in 7.6.4, but I keep getting the message that updated versions for my Mac with Power PC (using OSX 10.4.11) are not available. I have followed all instructions, as ambiguous and confusing as they are, to update all my Mac-compatible software as much as possible, BUT when I visit various websites I still keep getting a yellow dropdown message bar telling me that “Some plugins used by this page are out of date.” It gives me only the options to “Update Plugins,” which I’ve already tried to do in vain, or to close the message bar, which only reappears when I visit another page on the same site, or visit a different site.

HOW DO I TURN THIS OFF? This seems to be coming from Firefox, since it keeps wanting me to return to the Firefox “update your plugins” page. I’ve done all I can given what I have to work with.

This is just the latest irritating thing about Firefox, including the inability to leave comments at online magazine or newspaper websites. For that, I have to visit the sites using Safari. Firefox is also frequently telling me that I need to update to the latest version of Firefox, but when I try, it tells me that my computer cant handle the new version. THEN STOP TELLING ME TO UPDATE! If I can’t get Firefox to stop harassing me with messages insisting that I update things that I cannot update, I’ll just uninstall Firefox entirely and use other browsers.

Please advise.

Richard Wade (email removed by mod)

Modified by Tyler Downer

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Helpful Reply

You can set the Boolean pref plugins.hide_infobar_for_outdated_plugin to true on the about:config page.

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Hi Richard, I regret that Firefox is no longer supporting PowerPC-based Macs or OSX 10.4. Over time, Firefox 3.6.28 will become increasingly insecure, so you may indeed want to try some other browsers to see whether they meet your needs. Some folks have developed a Firefox-based browser named TenFourFox. It has some limitations -- such as not running plugins at all -- but might be worth a try if you don't love Safari.

mikepday 0 solutions 2 answers

Hi, I believe that Richard didn't ask for further support for Firefox, he asked how to turn off the "some plugins are out of date " notification on his CURRENT edition of Firefox, I would like to ask the same question. I am running OSX 10.5.8 and firefox 3.6.28 on a PPC Mac and have NO intention of changing or updating any of them. They were just fine as they were before some bright spark created an update for Firefox for Intel macs etc. Surely there is a line of code we can use, in fact I am 99% certain there will a line of code we can implement, because its a line of code that's making it happen, its just I dont know what it is. I dont want further support in terms of security, I just want you to return my Firefox app to what it was before YOU changed it and told me it was "out of date"...... I'm out of date but I seem to get on just fine, I cant afford a new Intel Mac and new Lion and Firefox etc....... we're in a recession just in case you hadn't figured it out. Thanks. Mike.

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Hi mikepday, did you read the reply two above yours? https://support.mozilla.org/en-US/questions/927963#answer-336067

Since Firefox 3.6.28 has multiple publicly disclosed security vulnerabilities, please practice safe computing and also keep good backups of your system.

mikepday 0 solutions 2 answers

jscher2000, Thanks for the reply, in short yes I did see the reply but I'll be honest as a general computer user, it seemed a little technical, i was hoping for a step by step guide from Mozilla..... That said, I have slowly followed the instructions in the post and have actioned the "Boolean toggle to true".... whatever that means! and it has worked, it was a little easier than I thought. Thanks for your time to reply, however an idiots guide to doing this would be helpful for the Idiots amongst us.... me included! Thanks once again. Mike.

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Helpful Reply

Hi mikepday, for future reference for anyone concerned, this is the general strategy for making preference changes in the about:config editor, using this specific example:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste infobar and pause while the list is filtered

(3) Choose your action:

(i) Switch between true and false (only for type "boolean" (true/false)):

Double-click plugins.hide_infobar_for_outdated_plugin to switch it. It will turn bold when it has been customized, and will be in normal type when it is set to its default value.

(ii) Edit value (for type "integer" (whole number) or "string" (any text)):

Double-click the preference name to open a little input box to enter a value. Not relevant to this particular preference.

(iii) Return to default:

Right-click plugins.hide_infobar_for_outdated_plugin and choose Reset. (Mac users: I don't know how you call up that right-click context menu, but you probably know.)