Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Still having problems saving passwords

  • 13 replies
  • 2 have this problem
  • 8 views
  • Last reply by rtbell

more options

I have followed the instructions contained in: http://support.mozilla.org/en-US/kb/make-firefox-remember-usernames-and-passwords?s=Saving+Passwords&r=5&e=es&as=s But I still cannot get the browser to prompt me to save the password. I have deleted and reinstalled Firefox twice today. The first time without deleting personal data and the second time with deletion, but still I cannot get the browser to store passwords. I am at a loss as to how to continue.

Chosen solution

Eureka. The disabling of the hardware acceleration fixed the problem. What the heck does hardware acceleration have to do with saving the password? 8^{

Read this answer in context 👍 3

All Replies (13)

more options

see in Tools > Options > Privacy > "Clear history when Firefox closes" is unchecked, or that under Settings, "Saved Passwords" is not checked.

see for more info : Passwords cleared with Clear Recent History

see also: Options window - Privacy panel - History - Use custom settings for history


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

more options

maybe one of your password related extensions or the IDondemand plugin is interfering with the built-in password manager in firefox. try disabling them.

more options

I appreciate the reply, but I have already tried that. None of the erase passwords check boxes have been checked. My problem is even more basic in that I do not even get the dialog to save a password in the first place. Any other ideas?

more options

I just added those with this last reinstall. I can disable them, but I don't think that is the issue since I do not even get the dialog to save passwords.

more options

I just tried disabling the two addons, but it still does not prompt me for the password. I was signing into the support account on mozilla.org.

more options

then please also try disabling the idondemand thingy in the plugins tab of the addons manager & restart the browser.

more options

i think you all ready see if : Always use private browsing mode is unchecked

Private Browsing


thanks again

more options

Ok. I disabled the IDonDemand Plugin and verified that the "always use private browsing" is not checked. I restarted and the problem persists.

more options

Did you try if it work in Save mode?

  • Help > Restart with Add-ons Disabled
more options

Interesting. I did what cor-el suggested and low and behold, I got the dialog box. Now I need to go through one plugin at a time to see what failed it. Thanks.

more options

This can also be caused by hardware acceleration not working properly.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
more options

When I bring up Firefox in safe mode as cor-el suggested, the password save became enabled. When I went through and disable all of the plugins and extensions manually, I could not get back to the point where I got the dialog box. I will try disabling the accelerator.

more options

Chosen Solution

Eureka. The disabling of the hardware acceleration fixed the problem. What the heck does hardware acceleration have to do with saving the password? 8^{