X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Bad Request Your browser sent a request that this server could not understand

Posted

Bad Request

Your browser sent a request that this server could not understand.

I get this message every time I try to upload a picture anywhere in the internet. I have cleared cookies, I have dumped my firefox account, I have cleared my cache, I have removed all history, I have re-installed firefox. Still getting this issue and 've been looking for solution for the last 3 hours and no luck

Chosen solution

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.
Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Read this answer in context 2

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • EA Battlefield Heroes Updater
  • 1.118.0
  • Google Update
  • 1.116.0
  • 4.1.10111.0
  • DivX Plus Web Player version 2.2.0.52
  • 0.70.4
  • Pando Web Plugin
  • DivX VOD Helper Plug-in
  • NPWLPG
  • Wacom Dynamic Link Library

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Bad Request
Your browser sent a request that this server could not understand.
Apache/2.2.16 (Debian) Server at ns227978.ovh.net Port 80

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

That issue can be caused by corrupted cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Helpful Reply

As I said I've cleared cache and removed cookies. Anyways I did it again and no luck, still the same error:

Bad Request

Your browser sent a request that this server could not understand. Apache/2.2.16 (Debian) Server at ylilauta.fi Port 80

It's not just ylilauta.fi, any other site does this as well

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Chosen Solution

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.
Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Helpful Reply

Okay, so I tried deleting cookies.sqlite. Didn't work out. Then I tried safe mode, and it did work. Weird because even after re-installing it did not work without all the addons. Anyways, now I need to find out which of the addons is conflicting with uploading, any idea how I could identify the one that is causing problems?

Question owner

Oh well, I cleared out the list and only left the necessities. Thanks for the support, everything seems to be working out now

mods315 0 solutions 2 answers

This worked for me also. A Firefox add-on ( not sure which yet) was preventing an extension from being installed into Joomla

pioppogatto 0 solutions 1 answers

Hi, I had a similar problem uploading a file. I followed your suggestions and I found this plug-in: Microsoft DRM 9.0.0.4503 Network Object After after disabling that plug-in, it works for me

dwarbe 0 solutions 1 answers

Worked for me as well, I had an issue where i was being blocked from viewing only 1of 4 php apps(not wp plugins), on my wordpress website. The website was also viewable with no errors. I only removed the cookies for that domain and that was enough to fix it thanks!

Modified by dwarbe

zante 0 solutions 1 answers

Check your permalinks of your web site: make sure are configured correctly; and/or reconfigure them. If you are using "custom permalinks" consult with Wordpress.org how to use custom permalinks.