X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 12.0 will not open on 2nd display by default

Posted

I just upgraded to Firefox 12.0. I have a second monitor connected to my MacBook Pro. With Firefox 11 and all previous versions, I had it set up that Firefox would automatically open on the second monitor when I open the program. With Firefox 12, it absolutely will not do this any longer. It's extremely annoying and makes me want to switch to Safari or Chrome, both of which do correctly open on the 2nd monitor.

Here's what I tried:

-Resizing the window and moving it to the second display, then quitting the program and reopening it.

-Moving the window to the second display and maximizing it, then quitting the program and reopening it.

-Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then reinstalling version 12.0

-Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then reinstalling version 13.0b

-Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then running disk utility to repair permissions and disk, THEN reinstalling version 12.0.

What will correct the problem (though not a solution):

-Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then reverting back to reinstalling version 11 and turning off the automatic updates.

The tech specs:

MacBook Pro 15" 2.66 GHz Intel Core i7, 8 GB 1067 MHz DDR3

Mac OS X Lion 10.7.3 (11D50)

Intel HD Graphics:

 Chipset Model:	Intel HD Graphics
 Type:	GPU
 Bus:	Built-In
 VRAM (Total):	288 MB
 Vendor:	Intel (0x8086)
 Device ID:	0x0046
 Revision ID:	0x0018
 gMux Version:	1.9.21

NVIDIA GeForce GT 330M:

 Chipset Model:	NVIDIA GeForce GT 330M
 Type:	GPU
 Bus:	PCIe
 PCIe Lane Width:	x16
 VRAM (Total):	512 MB
 Vendor:	NVIDIA (0x10de)
 Device ID:	0x0a29
 Revision ID:	0x00a2
 ROM Revision:	3560
 gMux Version:	1.9.21
 Displays:

Color LCD:

 Resolution:	1440 x 900
 Pixel Depth:	32-Bit Color (ARGB8888)
 Main Display:	Yes
 Mirror:	Off
 Online:	Yes
 Built-In:	Yes

Sharp LL-191A-B:

 Resolution:	1280 x 1024 @ 75 Hz
 Pixel Depth:	32-Bit Color (ARGB8888)
 Display Serial Number:	4H065468    
 Mirror:	Off
 Online:	Yes
 Rotation:	Supported
 Adapter Type:	Apple Mini DisplayPort To VGA Adapter
 Adapter Firmware Version:	1.03
I just upgraded to Firefox 12.0. I have a second monitor connected to my MacBook Pro. With Firefox 11 and all previous versions, I had it set up that Firefox would automatically open on the second monitor when I open the program. With Firefox 12, it absolutely will '''not''' do this any longer. It's extremely annoying and makes me want to switch to Safari or Chrome, both of which do correctly open on the 2nd monitor. Here's what I tried: -Resizing the window and moving it to the second display, then quitting the program and reopening it. -Moving the window to the second display and maximizing it, then quitting the program and reopening it. -Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then reinstalling version 12.0 -Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then reinstalling version 13.0b -Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then running disk utility to repair permissions and disk, THEN reinstalling version 12.0. What will correct the problem (though not a solution): -Uninstalling Firefox and deleting ALL files (including those in the Library Application Support and Preferences folders), then reverting back to reinstalling version 11 and turning off the automatic updates. The tech specs: MacBook Pro 15" 2.66 GHz Intel Core i7, 8 GB 1067 MHz DDR3 Mac OS X Lion 10.7.3 (11D50) Intel HD Graphics: Chipset Model: Intel HD Graphics Type: GPU Bus: Built-In VRAM (Total): 288 MB Vendor: Intel (0x8086) Device ID: 0x0046 Revision ID: 0x0018 gMux Version: 1.9.21 NVIDIA GeForce GT 330M: Chipset Model: NVIDIA GeForce GT 330M Type: GPU Bus: PCIe PCIe Lane Width: x16 VRAM (Total): 512 MB Vendor: NVIDIA (0x10de) Device ID: 0x0a29 Revision ID: 0x00a2 ROM Revision: 3560 gMux Version: 1.9.21 Displays: Color LCD: Resolution: 1440 x 900 Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes Built-In: Yes Sharp LL-191A-B: Resolution: 1280 x 1024 @ 75 Hz Pixel Depth: 32-Bit Color (ARGB8888) Display Serial Number: 4H065468 Mirror: Off Online: Yes Rotation: Supported Adapter Type: Apple Mini DisplayPort To VGA Adapter Adapter Firmware Version: 1.03

Additional System Details

This happened

Every time Firefox opened

This started when...

I upgraded to firefox version 12.

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.3
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.0.61118.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Application Basics
Name
Firefox
Version
12.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
1Password
3.9.4
true
onepassword@agilebits.com
Context Search
0.4.6
true
{902D2C4A-457A-4EF9-AD43-7014562929FF}
Password Exporter
1.2.1
true
{B17C1C5A-04B1-11DB-9804-B622A1EF5492}
PrivacyChoice TrackerBlock
2.2
true
trackerblock@privacychoice.org
SearchLoad Options
0.6.3
true
searchloadoptions@esteban.torres
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20120420145725
browser.startup.homepage_override.mstone
rv:12.0
browser.tabs.onTop
false
extensions.lastAppVersion
12.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1335586198
places.history.expiration.transient_current_max_pages
104858
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.sessions
false
privacy.donottrackheader.enabled
true
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
security.warn_viewing_mixed
false
Graphics
Vendor ID
0x10de
Device ID
0x a29
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-7.18.11
GPU Accelerated Windows
1/1 OpenGL
AzureBackend
quartz

ideato 893 solutions 6250 answers

Try if this helps : Move the Firefox window to your second display, then shut down your Mac and do not turn off the second display. Restart the Mac with both screens on.


thank you

Try if this helps : Move the Firefox window to your second display, then shut down your Mac and do not turn off the second display. Restart the Mac with both screens on. thank you

Helpful Reply

Thanks for the response. I did try what you suggested above, but unfortunately it did not work. Firefox will still only open on the main monitor (unlike before I upgraded to version 12).

Thanks for the response. I did try what you suggested above, but unfortunately it did not work. Firefox will still only open on the main monitor (unlike before I upgraded to version 12).
ideato 893 solutions 6250 answers
Probably [http://kb.mozillazine.org/Corrupt_localstore.rdf Corrupt localstore.rdf] see also: http://forums.mozillazine.org/viewtopic.php?f=9&t=564827 thanks again

Helpful Reply

Thank you again for helping troubleshoot this.

Before I posted here, I did google the problem and found those web sites you linked to. I tried the solution and it did not work. I tried it again now just to make sure, and unfortunately the problem persists.

If it helps and to clarify, this problem goes away if I delete all Firefox files, directories, etc., and reinstall Firefox version 11. As soon as I try upgrading to version 12 however, the problem comes back. It appears to be something that was introduced with version 12.

Thank you again for helping troubleshoot this. Before I posted here, I did google the problem and found those web sites you linked to. I tried the solution and it did not work. I tried it again now just to make sure, and unfortunately the problem persists. If it helps and to clarify, this problem goes away if I delete ''all'' Firefox files, directories, etc., and reinstall Firefox version 11. As soon as I try upgrading to version 12 however, the problem comes back. It appears to be something that was introduced with version 12.
ideato 893 solutions 6250 answers

Another option:

1. Un-maximise Firefox window 2. Position un-maximised window on monitor of you choice (second) 3. Close Firefox window 4. Reopen Firefox window 5. Maximise Firefox window 6. Close Firefox window

Now, probably, firefox will open maximised on the second monitor.

thanks again

Another option: 1. Un-maximise Firefox window 2. Position '''un-maximised''' window on monitor of you choice (second) 3. Close Firefox window 4. Reopen Firefox window 5. Maximise Firefox window 6. Close Firefox window Now, probably, firefox will open maximised on the second monitor. thanks again

Question owner

Thanks for continuing to try.

Tried this several times... no luck. It always reopens back on the first monitor.

Thanks for continuing to try. Tried this several times... no luck. It always reopens back on the first monitor.
dno_bot 0 solutions 4 answers

I am having this same issue. It seems every time theres an update this happens. I have attempted all of the above techniques; deleting the localstore.rdf, unmaximizin- maximizing, all combinations of above, etc. with no results.

Please fix this bug. I really need to stop updating for these "fixes" only to break something else.

I am having this same issue. It seems every time theres an update this happens. I have attempted all of the above techniques; deleting the localstore.rdf, unmaximizin- maximizing, all combinations of above, etc. with no results. Please fix this bug. I really need to stop updating for these "fixes" only to break something else.

Question owner

I am relieve to see someone else having this problem so I know it's not just me. This appears to be a bug with something introduced in Firefox 12. How would I go about filing an official bug report or is that necessary?

I am relieve to see someone else having this problem so I know it's not just me. This appears to be a bug with something introduced in Firefox 12. How would I go about filing an official bug report or is that necessary?
dno_bot 0 solutions 4 answers

if you do find a solution, please post it here. I really don't want to hassle with everything to roll it back to 11

if you do find a solution, please post it here. I really don't want to hassle with everything to roll it back to 11
jmarkt 0 solutions 2 answers

Just like Scott, dno_bot...and the many others across Google that are experiencing this same problem.

Previous versions behaved properly - Version 12.0 has a bug! hopefully it is fixed before they lose users to the likes of Chrome, Safari, IE, Aurora, Opera, etc, etc. There is a reason we chose Firefox, and there could be a reason why we chose to delete it????

Just like Scott, dno_bot...and the many others across Google that are experiencing this same problem. Previous versions behaved properly - Version 12.0 has a bug! hopefully it is fixed before they lose users to the likes of Chrome, Safari, IE, Aurora, Opera, etc, etc. There is a reason we chose Firefox, and there could be a reason why we chose to delete it????
dno_bot 0 solutions 4 answers

they have about a week to fix it before I switch to chrome permanently.

they have about a week to fix it before I switch to chrome permanently.

Question owner

dno_bot - While I understand your frustration, I really doubt that a threat is really going to accomplish anything here. Keep in mind that most of the people who help develop Firefox are volunteers.

I have opened a bug on Mozilla here: https://bugzilla.mozilla.org/show_bug.cgi?id=752149

dno_bot - While I understand your frustration, I really doubt that a threat is really going to accomplish anything here. Keep in mind that most of the people who help develop Firefox are volunteers. I have opened a bug on Mozilla here: https://bugzilla.mozilla.org/show_bug.cgi?id=752149
jmarkt 0 solutions 2 answers

Scott - Perhaps your subsequent frustration will be similar...if the same thing happens to your Bug report to Mozilla as has happened with mine - nothing!
https://bugzilla.mozilla.org/show_bug.cgi?id=750999

(link fixed by Mod.)

Scott - Perhaps your subsequent frustration will be similar...if the same thing happens to your Bug report to Mozilla as has happened with mine - nothing!<br /> [https://bugzilla.mozilla.org/show_bug.cgi?id=750999] ''(link fixed by Mod.)''

Modified by cor-el

Question owner

I couldn't open your link for some reason.

If everyone who is having this problem would go to https://bugzilla.mozilla.org/show_bug.cgi?id=752149 and vote for this bug, it will move it up in priority.

I couldn't open your link for some reason. If everyone who is having this problem would go to https://bugzilla.mozilla.org/show_bug.cgi?id=752149 and vote for this bug, it will move it up in priority.
dno_bot 0 solutions 4 answers

based on that bugzilla thread it looks like they might not fix it until release 13.... guess I'll just skip 12. rolled back to 11 and turned off updates. let me know if this ever gets fixed.

based on that bugzilla thread it looks like they might not fix it until release 13.... guess I'll just skip 12. rolled back to 11 and turned off updates. let me know if this ever gets fixed.

Modified by dno_bot

Question owner

Yes, I opened the bug report and have been following the thread. They have identified the problem but they need to ensure that by instituting the fix, they don't regress some other bug or cause a new one.

Being that Firefox 13 is well into beta, it won't give them enough time to adequately test the fix before FF 13 is released. It will most likely be in FF 14. I am on the Firefox beta channel for updates and have been using the FF 13 beta. It's very stable. I assume the FF 14 beta will be to, so once they move FF 14 from alpha to beta and implement the fix, I'll switch to FF 14. If this bug is a huge issue for you, I'd recommend doing the same. I'm sure they would appreciate more people who experience this bug testing the fix when it is released into beta.

Yes, I opened the bug report and have been following the thread. They have identified the problem but they need to ensure that by instituting the fix, they don't regress some other bug or cause a new one. Being that Firefox 13 is well into beta, it won't give them enough time to adequately test the fix before FF 13 is released. It will most likely be in FF 14. I am on the Firefox beta channel for updates and have been using the FF 13 beta. It's very stable. I assume the FF 14 beta will be to, so once they move FF 14 from alpha to beta and implement the fix, I'll switch to FF 14. If this bug is a huge issue for you, I'd recommend doing the same. I'm sure they would appreciate more people who experience this bug testing the fix when it is released into beta.