Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I keep getting a pop-up that tells me to upgrade my operating system. How do I turn this pop-up off?

  • 24 replies
  • 49 have this problem
  • 1204 views
  • Last reply by finitarry

more options

There's an annoying pop-up that loads every time I start Firefox. It tells me to upgrade my operating system, as the latest version of Firefox doesn't support it. But it's the most advanced version of the OS my system will cope with, so that's not an option.

How do I turn the pop-up off?

Chosen solution

For Windows 2000 also see:

On Windows 2000 this pop-up is generated by this extension:
Firefox Notification Hotfix 20120430.01:

So you can disable it to stop the popup.

  • Tools > Add-ons > Extensions
Read this answer in context 👍 5

All Replies (20)

more options

This could be difficult to answer unless someone has Windows 2000 around to play with...

One other thought: Since Firefox 12 will become less safe to use over time (more security vulnerabilities are revealed each time security patches are released), you might want to consider adding some sandboxing software in the near future to protect the rest of your system from whatever comes through your browser.

more options

See https://support.mozilla.org/kb/firefox-no-longer-works-windows-2000

You probably need to disable the update check to avoid that message.

  • Tools > Options > Advanced : Update
more options

I have "Never check for updates" and the nag pop-up still shows its freaky head every time I start FF12.

more options

I'm also getting annoyed with this problem. I have set 'never check for updates' but it still appears. My Win2k system is old and slow but it is has lots of disk space, is extremely reliable and it runs all my old peripherals. I use it for most of my internet access to keep the nasties away from my other computers and I have no desire to stop using it. I also don't have the time to see about updating the OS, it would have to be XP which may also become obsolete before long, who knows. I have been using Firefox for years and Netscape before that, I don't want to change. However, this popup is going to become more and more irritating. I seem to remember there used to be a text file containing all the parameters which you could edit (I never tried) but I can't find it any more. I was wondering if there was something in that which could tell it to stop the popup (if it still exists). Otherwise, should I backtrack to version 11 (assuming I can find it)?

more options

No, don't revert to Firefox 11. Just never close Firefox 12 unless you really have to. :-)

But semi-seriously, I suspect it won't be long before someone releases an add-on to suppress the message.

More seriously, if you plan to run any out-of-date browser, you should consider using "sandboxing" (virtualization) software that prevents browser-based threats from infecting the rest of your computer.

more options

I'm about ready to delete Firefox and use Opera or another browser that doesn't think I'm not good enough simply because I can't afford to buy a new computer. Or I may just use Netscape 9.

more options

You can set another page as the home page (not the default http://start.mozilla.org/en-US/) to avoid that pop-up.

more options

That isn't my home page.

more options

Hi uncle_wilf, I'm having trouble understanding your comment.

Edit: Are you saying that you get the message no matter what home page you try?

Modified by jscher2000

more options

Cor-el suggested changing from the default homepage to cure the problem. But my homepage is not the default homepage.

more options

I have Firefox set to start with a blank page, so I don't think the home page has anything to do with it.

more options

Same problem. Because I use a PPC G5, I cannot run FireFox newer than 3.6. I can live with that, since I don't have an extra $7500 to buy a comparable Intel PowerMac. But about a week ago, the yellow pop-up thing started showing up on EVERY PAGE I GO TO, and having updates turned off has not helped. I doubt this issue will be addressed, but I am about to go postal over here with rage...

more options

Chosen Solution

For Windows 2000 also see:

On Windows 2000 this pop-up is generated by this extension:
Firefox Notification Hotfix 20120430.01:

So you can disable it to stop the popup.

  • Tools > Add-ons > Extensions
more options

Thanks cor-el, that did it. :-)

more options

@TatuhHedd

Type about:config in Location (address) bar and filter for plugins.hide_infobar_for_outdated_plugin and double-left-click or right-click and toggle this to true

more options

I overwrote Firefox 12 with Firefox 3.6.28 and the popup stopped. I notice that it doesn't have the Firefox Notification Hotfix extension, so maybe this is what did it.

more options

This answers my early question: I seem to remember there used to be a text file containing all the parameters which you could edit - about:config is the key!! Thank you very much.

more options

I found a solution, though I don't know how long it will work....

I am now using this, and it is working great, so far:

link text

Thanks for everyone's help, and I hope this will solve the problem for at least some of you others...:)

more options

Where would I get sandbox software for Mac OS Tiger? I did a search, but did not see anything promising.

more options

Hi finitarry, if you have an Intel-based Mac, you could try VirtualBox (I haven't tried it myself).

  1. 1
  2. 2