Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Force Update 24 april

  • 8 replies
  • 8 have this problem
  • 89 views
  • Last reply by James

more options

My preferences for automatic update is unchecked. Will the force update of 24 april overrule these preferences? I don't want to update version 3.6.28 due a medical software that I use.

Chosen solution

If you don't have automatic update checked off, you won't be updated to Firefox 11. However, as swarnava said, there will not be any more updates for Firefox 3.6, period. It will be vulnerable to security holes in the future, as well as stability issues.

Is there a reason you don't want to update to Firefox 11 that maybe I can help you? There are lots of reasons to update, better performance, support for new web standards, better memory usage, hardware acceleration, etc. And with the new Versions, most add-ons are defaulted to compatible with Firefox 11.

Read this answer in context 👍 2

All Replies (8)

more options

Will the force update of 24april overrule these preferences?

  • No
more options

So I can keep version 3.6.28 if I choose to and I don't need to update to version 12.

more options

But Firefox 3.6 is now end of life, it means no more update, suport and maintaince, chemspill only

more options

thx 4 your reply swarnava

more options

If there's no support for 3.6.28, that wouldn't be a problem. As long as Mozilla does not update against my will.

more options

Chosen Solution

If you don't have automatic update checked off, you won't be updated to Firefox 11. However, as swarnava said, there will not be any more updates for Firefox 3.6, period. It will be vulnerable to security holes in the future, as well as stability issues.

Is there a reason you don't want to update to Firefox 11 that maybe I can help you? There are lots of reasons to update, better performance, support for new web standards, better memory usage, hardware acceleration, etc. And with the new Versions, most add-ons are defaulted to compatible with Firefox 11.

more options

@Tylerdowner thx 4 your reply. Im not keen on updating my firefox right now, cause I'm using a software that's not fully compatible with a newer version. The company is working on this compatibility problem though.

thx a bunch guys!

more options

Swarnava wrote "But Firefox 3.6 is now end of life, it means no more update, suport and maintaince, chemspill only"

There will not be any chemspill updates for 3.6.* either as the 3.6.28 is it.

Also the chemspill refers to the updates for 4.0 and newer versions that could not wait for the next major version.