X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

YouTube muted after Flash upgrade

Posted

Following a recent Flash upgrade, I cannot hear sound on YouTube videos. I can still hear sound on the FF video test page, here: https://addons.mozilla.org/firefox/addon/navigational-sounds

So I went to this help page: https://support.mozilla.org/en-US/kb/No%20sound%20in%20Firefox?s=sound+youtube&r=0&e=es&as=s

On that page, it references a Windows function called "Volume Mixer". The screenshot shows three applications in the Volume Mixer function, these are called "System Sounds", "Mozilla Firefox" and "Plugin Container for Firefox".

I only have the one called "System Sounds". The other two are missing. Why is this so, and how do I reinstate them? On the Microsoft forum, they tell me that applications are added here automatically.

Another forum suggested the plugin was blocked by my firewall. This is not so. And yet another forum suggested that I disable crash protection using an about:config setting: there is no way I am going to do that.

Modified by pendle

Chosen solution

Alice: I've now uninstalled Flash, which was a beta version because the latest "stable" version made FF crash when viewing Google Docs. I then installed the recommended latest version of Flash in the usual way and this combined with upgrading FF to version 11 seems to have solved both problems. Thanks for your help.

Read this answer in context 1

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Google Update
  • Shockwave Flash 11.3 r300
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Classic Java Plug-in 1.6.0_31 for Netscape and Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8008 answers

Firefox 3.6 will shortly reach End Of Life it may be worth thinking about updating to Firefox 11 now.

From what you are saying it would seem to be a Windows problem rather than a Firefox problem. You should try Firefox in Troubleshoot Firefox issues using Safe Mode and then installing Flash Player.

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

I don't see a "plugin-container" volume mixer icon in Firefox 3.6 either, even though I can hear audio on this YouTube test page, notwithstanding the Firefox 3.6 instructions in the What to do if Firefox won't play any sounds article .

When I click the Play icon, I hear sound. When I check the Windows Volume mixer, I see a "System Sounds" icon and a "YouTube Help - YouTube - Mozilla Firefox" icon.

pendle, can you see if you get audio in the above YouTube video when you click the "Play" button? What about when you run in Firefox Troubleshoot Firefox issues using Safe Mode, as John99 suggested? Firefox Safe Mode disables added extensions (among other things) which can interfere with audio.

See Fix common audio and video issues for other solutions (also recommended by John99).

Modified by AliceWyman

Question owner

Thank you both for your quick replies.

John99: Safe Mode made no difference. I have now upgraded to FF11. This has put a "Mozilla Firefox" icon in the volume mixer, but still no "Plugin Container for Firefox".

All the Microsoft help pages and forums say that the Volume Mixer is a sort of background process, not something you actively configure. This is borne out by these two observations:

(1) When I watch a YouTube video using Chrome, I get the sound OK, and a "Chrome" icon appears automatically in the Volume Mixer.

(2) When I watch a YouTube video using FF 4.0.1 Portable on a USB stick, I get the sound OK, and a "Plugin Container for Firefox" icon appears automatically in the Volume Mixer.

So I don't think I will be able to do anything about this from the Windows end.

AliceWyman: The YouTubeHelp video was still mute. And while it was playing, no extra icons appeared in the Volume Mixer.

There must be a way I can force the plugin container in the FF 11 installed on my hard drive to appear in the volume mixer just like the one on the stick did. Presumably it is something that is always up to date, since I don't remember ever downloading or updating it. Does it have a version number? Where can I check it is up to date?

I am tempted to delete the mainstream version of FF from my computer and copy FF 4.0.1 Portable from the stick to the hard drive. I don't care if it's out of date, I just need it to work.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8008 answers

I do not have Vista. I have tried firefox 3.6 on Windows 7 . That gives a speaker as a single device when I click the taskbar volume icon. That device has a lower clickcable blue part labled mixer, clicking that expands it to the volume mixer. The "Sytem Sounds" shows, and once I start a you tube video playing the "Plugin Container for Firefox" volume control also appears. Interestingly there is no separate control for firefox 3.6, although other versions do show, so aurora will show a volume control if I start that up.

Rather than using an unsupported version why not try Fifrefox Beta http://www.mozilla.org/en-US/firefox/all-beta.html . Also Firefox Portable is now updated to Firefox 11 and so you should also think about upgrading that. (Although no doubt you will leave that until Firefox works again).

If we re looking at this as likley to be a Firefox problem then while in Troubleshoot Firefox issues using Safe Mode also disable all plugins. It is probably worth creating and using a new profile as a test, ensure the new profile has no add-ons and only Flashplayer as a plugin.

The videos presumably play but without sound and so I assume if you use TaskManager you can see plugincontainer.exe running.(Otherwise maybe you have already disabled it). I would also try a site other than you tube to see if that gives you sound on Flash videos

Another line of attack for this problem would be to disable plugincontainer, so that Flash Runs directly in Firefox. That may not be ideal but it may be a method of getting your sound back on videos.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Try to clear the Flash cookies (LSO) and settings.

  • Windows Control Panel > Flash Player, click Delete All and Delete Data

Flash Website Storage Settings panel:

Global Storage Settings Panel:

Flash Local storage settings Help:

Question owner

John:

Tried Safe Mode, new profile, no difference. I reset the about:config setting, this disabled the plugin container, but had no effect.

I found another test page which works, here:

http://camendesign.com/code/video_for_everybody/test.html

This is MP4, OGG, WebM and flv, the page detects the browser and selects a format accordingly. The Firefox test page

http://www.mozilla.org/en-US/firefox/video/

works the same way.

cor-el:

I cleared the cookies again, I had already done this a few days ago following your advice on my other thread. No effect. I also set the two options in the storage settings to off. No effect.

Modified by pendle

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

So, when you play a video at http://www.mozilla.org/en-US/firefox/video/ you do hear sound in Firefox 11? And do you see the Mozilla Firefox icon in the Windows Volume mixer? The HTML5 video on that page don't require Flash or any other plugin (see Viewing HTML5 audio and video in Firefox for more information).

You said that when you watch a YouTube video using Chrome, you get the sound OK, and a "Chrome" icon appears automatically in the Volume Mixer. Just so you know, Flash Player is integrated into Chrome (it's part of the browser) while. Firefox uses the system Flash plugin that you must install separately from Adobe's download page . Since the problem began after upgrading Flash, Try completely uninstalling and then reinstalling the Flash Player. See

...which links to:

Chosen Solution

Alice: I've now uninstalled Flash, which was a beta version because the latest "stable" version made FF crash when viewing Google Docs. I then installed the recommended latest version of Flash in the usual way and this combined with upgrading FF to version 11 seems to have solved both problems. Thanks for your help.

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

Hey, that's great! Thanks for posting back that you solved the problems you were having by uninstalling your current Flash version (which I see now was Flash 11.3 Beta) and installing the latest recommended version (currently Flash 11.2, available here).

I also see that there's a separate Flash 11.3 uninstaller linked from the Flash 11.3 Beta page, for anyone else having this problem.

Modified by AliceWyman

Question owner

Yes, I should have mentioned that uninstalling Flash using the Flash procedure worked differently from the usual Windows uninstall of a program. I had to manually delete some folders and files. It's quite likely that I had not fully uninstalled Flash 11.2 properly when I installed 11.3, which might have contributed to the problem.