X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot install "plugin/extension name" because Firefox cannot modify the needed file. This is happening for any and every kind of plugin theme you could think of. This started when I upgraded to Firefox 11 just now.

Posted

I just upgraded to Firefox 11.0 (unwillingly) and I get the following whenever I try to install ANYTHING at all. Themes, add-ons...it doesn't matter, the result is the same.

"Cannot install "plugin name here" because Firefox cannot modify the needed file.

If the fix requires installing a plugin...well, that's not going to work obviously.

Anybody know how to fix this?

Additional System Details

Installed Plug-ins

None - All erased during upgrade.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.79 Safari/535.11

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You shouldn't see such an error.
That error usually indicates that an extension or dictionary needs to be unpacked to make it work.

Firefox 4 and later no longer unpacks an extension automatically, but renames the XPI file to the ID of the extension and copies that file to the extensions folder in the Firefox Profile Folder. If an extension needs to be unpacked then there should be an unpack directive (<em:unpack>true</em:unpack>) in the install.rdf file of that extension

You can try to set the Boolean pref extensions.alwaysUnpack to true on the about:config page.