X
Tap here to go to the mobile version of the site.

Support Forum

Some websites claim that Javascript is not activated, but Firefox says it is.

Posted

Certain websites claim that I do not have Javascript activated, but it is activated according to Firefox settings (Tools > Options > Content). One example is the German site www. autoscout24.de; when I go there I get the message "Bitte aktivieren Sie JavaScript in Ihrem Browser, um alle Funktionalitäten unserer Webseite nutzen zu können" in red, with tips on how to activate Javascript. Another site is my e-mail service, in which I cannot use certain features which require Javascript. Their help service recommends I clear the cache (did that, didn't help) and delete all cookies (don't want to do that as it would cause annoyance on some websites, so I just deleted cookies pertaining to e-mail service; didn't help either). I also tried starting Firefox in 'safe mode', which didn't help either.

Certain websites claim that I do not have Javascript activated, but it is activated according to Firefox settings (Tools > Options > Content). One example is the German site www. autoscout24.de; when I go there I get the message "Bitte aktivieren Sie JavaScript in Ihrem Browser, um alle Funktionalitäten unserer Webseite nutzen zu können" in red, with tips on how to activate Javascript. Another site is my e-mail service, in which I cannot use certain features which require Javascript. Their help service recommends I clear the cache (did that, didn't help) and delete all cookies (don't want to do that as it would cause annoyance on some websites, so I just deleted cookies pertaining to e-mail service; didn't help either). I also tried starting Firefox in 'safe mode', which didn't help either.

Additional System Details

Sites Affected

http://www.autoscout24.de

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 8.3.1
  • Picasa plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Using Firefox 11 under Windows XP (SP3). Java is up to date. Problem does *not* occur using IE8 on same PC, or using Firefox (various levels) on other PCs (various Windows). Problem is therefore on my PC, not on websites.

jscher2000
  • Top 10 Contributor
3402 solutions 30881 answers

Do you use any security add-ons that could selectively block scripts based on the URL? NoScript is the leading example of such an add-on, but there might be others. If you use a proxy server in Firefox but not your other browsers, that also could filter your results.

Generally speaking, if you start up in Safe Mode, you can bypass most add-ons, so if that didn't work, you could try a follow-up step of testing with a new profile.

First, I recommend backing up your Firefox settings in case something goes wrong. See Backing up your information. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, close all Firefox windows and start up to the Firefox Profile Manager as described in: Managing profiles.

Create a new blank profile and check those sites. Any change?

To switch back to your normal profile, close all Firefox windows, start up the Profile Manager, and choose that profile.

Do you use any security add-ons that could selectively block scripts based on the URL? NoScript is the leading example of such an add-on, but there might be others. If you use a proxy server in Firefox but not your other browsers, that also could filter your results. Generally speaking, if you start up in Safe Mode, you can bypass most add-ons, so if that didn't work, you could try a follow-up step of testing with a new profile. First, I recommend backing up your Firefox settings in case something goes wrong. See [https://support.mozilla.com/en-US/kb/Backing+up+your+information Backing up your information]. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.) Next, close all Firefox windows and start up to the Firefox Profile Manager as described in: [http://support.mozilla.com/kb/Managing+profiles Managing profiles]. Create a new blank profile and check those sites. Any change? To switch back to your normal profile, close all Firefox windows, start up the Profile Manager, and choose that profile.

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
12523 solutions 115465 answers

There is also security software (firewall) that can block JavaScript, so can can check there as well.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

There is also security software (firewall) that can block JavaScript, so can can check there as well. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Firewalls *https://support.mozilla.org/kb/Server+not+found

Question owner

Thanks for your help. I created a new profile as you suggested, and indeed, in the new profile, the problem is gone - the sites I have problems with work properly.

So there is something in my default profile which is causing the problem.

Now how can I identify and correct the offending setting (or whatever it is)?

I have tried disabling all extensions and plug-ins, to no avail. Problem must be elsewhere.

Thanks for your help. I created a new profile as you suggested, and indeed, in the new profile, the problem is gone - the sites I have problems with work properly. So there is something in my default profile which is causing the problem. Now how can I identify and correct the offending setting (or whatever it is)? I have tried disabling all extensions and plug-ins, to no avail. Problem must be elsewhere.

Modified by Dogmatix

jscher2000
  • Top 10 Contributor
3402 solutions 30881 answers

You can check for proxy settings here:

orange Firefox button or classic Tools menu > Options > Advanced

then, on the Network mini-tab, check the Settings button for any custom settings

And... how about "third party" cookies? If you have blocked all third party cookies, try changing the setting to allow them for the current session. This article has some screen shots: https://support.mozilla.org/en-US/kb/Disabling%20third%20party%20cookies

Any luck?

You can check for proxy settings here: orange Firefox button ''or'' classic Tools menu > Options > Advanced then, on the Network mini-tab, check the Settings button for any custom settings And... how about "third party" cookies? If you have blocked all third party cookies, try changing the setting to allow them for the current session. This article has some screen shots: https://support.mozilla.org/en-US/kb/Disabling%20third%20party%20cookies Any luck?
cor-el
  • Top 10 Contributor
  • Moderator
12523 solutions 115465 answers

Did you try to clear the cache folder on disk (about:cache)?

You can also try to delete some SQLite database files like permissions.sqlite and webappsstore.sqlite

Did you try to clear the cache folder on disk (about:cache)? You can also try to delete some SQLite database files like permissions.sqlite and webappsstore.sqlite