Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Excel 2010 cut and paste does not work when firefox is open

  • 5 replies
  • 60 have this problem
  • 3299 views
  • Last reply by Betina

more options

When I have MS-Excel 2010 open at the same time as Firefox, I cannot cut and paste formulas in Excel. The boxes in Excel do not show the flashing dotted lines (indicating the cell contents are to be copied) and I cannot copy and past anything except tests or numbers. Any formulas I copy and past are pasted as the result. So if I have in cell A2 "=A1 + 1" and A2 shows "1" as its contents, when I copy and paste, only the value "1" copies over, no formula.

I also cannot copy and paste across multiple cells. For example, if I have the word "test" in a cell, I copy it, and then attempt to paste it in to cells in the same column, it does not work. I get an error message saying that the copy and paste areas are not the same size. If I close Firefox, this function works without a problem. Also, when Firefox is open, the only "Paste Special" option available is text. When Firefox closes, all the options return.

Modified by dakotafrost

Chosen solution

To resolve this issue, I called Microsoft, and was forced to go through my PC vendor, HP, first because Office came installed on my machine. I knew that would be futile, and it was. Once I had established that HP could not resolve the issue, Microsoft tried to help. They couldn't help while on the phone, but a manager later emailed me the solution.

Here is the solution, cut and pasted directly from the email:

"RESOLUTION for the Issue: The issue is due to the ‘Skype Click To Call’ add-on for browsers. If you disable the add-on/plugin from the browser, or uninstall it from appwiz.cpl, the issue disappears even if the browsers are open"

This is a complex conflict and is dependent on other add-ons that the user has running. So for some, Excel works fine with a browser and the Skype click to call add-on open.

This solution worked for me, but additionally, I found that if you update to latest versions of IE9 and Firefox, the problem is resolved. I updated to Firefox 11.0, and now I can use the Skype add-on, Firefox, and Excel at the same time with no issues.

Read this answer in context 👍 33

All Replies (5)

more options

Hi,

Please check if this happens in Safe Mode.

Problematic Extensions

Troubleshooting Extensions and Themes

Uninstalling Add-ons

Uninstalling Toolbars

Safe mode disables the installed Extensions, and themes (Appearance) in Tools (Alt + T) > Add-ons. Hardware acceleration is also temporarily disabled - the manual setting is Tools > Options > Advanced > General > Use hardware acceleration when available. Options > Advanced. All these settings/add-ons can also be individually or collectively disabled/enabled/changed in Firefox normal mode to check if an extension, theme or hardware acceleration is causing issues.

Options

more options

Chosen Solution

To resolve this issue, I called Microsoft, and was forced to go through my PC vendor, HP, first because Office came installed on my machine. I knew that would be futile, and it was. Once I had established that HP could not resolve the issue, Microsoft tried to help. They couldn't help while on the phone, but a manager later emailed me the solution.

Here is the solution, cut and pasted directly from the email:

"RESOLUTION for the Issue: The issue is due to the ‘Skype Click To Call’ add-on for browsers. If you disable the add-on/plugin from the browser, or uninstall it from appwiz.cpl, the issue disappears even if the browsers are open"

This is a complex conflict and is dependent on other add-ons that the user has running. So for some, Excel works fine with a browser and the Skype click to call add-on open.

This solution worked for me, but additionally, I found that if you update to latest versions of IE9 and Firefox, the problem is resolved. I updated to Firefox 11.0, and now I can use the Skype add-on, Firefox, and Excel at the same time with no issues.

more options

Thanks for the detailed helpful info.

more options

Thanks so much for researching the solution. I was pulling my hair out.

more options

I have Firefox 11.0 and still had to disable Skype Click to Call to get the copy options back in Excel.