Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks toolbar disappears every time I open firefox

  • 16 replies
  • 10 have this problem
  • 4164 views
  • Last reply by nravery

more options

I'm running nightly 14.0a1 currently on Windows 7 x86.

My firefox with the bookmarks tab visible looks like this with it in the same row as open tabs in the top right corner:

http://img32.imageshack.us/img32/1334/firefoxbookmarks.png

It's the easiest to access and most convenient position.

It started recently when I was still using version 13 something and just updated to 14.0a1 today but it didn't fix the problem. It just randomly disappeared and to get it back I have to open up the customize window, do nothing but click "done" and it reappears. I don't have to add it back or anything, as it's visible when I open the customize window. This happens every time I reopen firefox.

Chosen solution

Does that only happen with the Bookmarks Toolbar folder item on the Tab bar?

You can try:

Read this answer in context 👍 1

All Replies (16)

more options

Hi hatrix,

You should look at the article How to fix preferences that won't save. It sounds like it just might not be able to save your preference to your pref.js file.

Hopefully this helps!

more options

Thanks for the info, but that doesn't seem to be the issue. I've tried deleting my preferences file and all my settings such as my default home page save and stay the same, but the bookmarks menu still disappears from the top right corner.

Modified by hatrix

more options

Chosen Solution

Does that only happen with the Bookmarks Toolbar folder item on the Tab bar?

You can try:

more options

That seemed to work. I just deleted my localstore and it started saving after generating a new one. The icon for bookmarks is different now but it still functions the same so no matter. Thanks for the help !

more options

hatrix,

I know you've already gotten your answer solved, but I'm trying to chase down a similar problem in Firefox 12; could you provide a list of extensions that you're running?

(You can get an easy-to-copy list by going to Nightly > Help > Troubleshooting Info)

Thanks for your help.

more options

Sure thing. Here they are:

  1. Adblock Plus
  2. Add-on Compatibility Reporter
  3. FillForm
  4. Flagfox
  5. Greasemonkey
  6. HTTPS-Everywhere
  7. PDF Viewer

Everything is enabled but the PDF viewer in case you were wondering.

Modified by hatrix

more options

Thanks for the help!

more options

Sorry to follow up again, do you have any disabled extensions (or extensions that were disabled because they weren't compatible?). We've found that All-in-One sidebar causes this problem in Firefox 12 but it wasn't on your list of extensions.

more options

Nope, just PDF viewer.

more options

Me too! Bookmarks Toolbar URLs disappear every time Firefox 12.0 is closed. Empty bar remains on restart. Switching off and on BMT in View restores it till the next close.

I tried restoring an older localstore.rdf and then deleting it but it makes no difference. I don't have All-in-One installed.

Any ideas, please?

more options

Some other add-ons also cause this behavior... what addons do you have?

more options

Better Privacy 1.68, Blacksheep 1.7.2, Checkplaces 2.6.2, Cleanest Addon Manager 1.5, FireFTP 2.0.4, FireFTP Button 1.1.1d, Ghostery 2.7.2, HTTPS-Everywhere 2.0.2, Password Exporter 1.2.1, AdBlockPlus 2.0.3

Also plugins: Acrobat, Active Touch Gen. Ctr, Java, Office 2010, Shockwave, Silverlight, VLC

more options

I'd start with FireFTP Button but I guess try disabling them one at a time?

more options

Did you try Save mode?

  • Help > Restart with Add-ons Disabled
more options

Been using that for 4 or 5 years with no problems

more options

Well, I did just try Safe Mode and then reenabled each add-on singly until I had all of them going again. None seemed to cause an issue but now the bookmarks toolbar works correctly. Go figure!. Many thanks cor-el and Cww for you assistance!