X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't register Hotmail javascript protocol handler

Posted

I do this, it won't work. make Hotmail a mailto: option in FF.

To make Firefox use Hotmail for mailto links, do the following.

  1. Type about:config into your location bar and hit enter. If you've never edited used about:config before, you'll see a warning.
  2. Click "I'll be careful, I promise!" This will bring you to the about:config window.
  3. In the filter field type "gecko". Double click the first entry gecko.handlerService.allowRegisterFromDifferentHost to change the value to true.
  4. Copy and paste the following text into the location bar and hit enter: javascript:navigator.registerProtocolHandler('mailto','http://hotmail.msn.com/secure/start?action=compose&to=%s','Hotmail');
  5. You will see an information bar drop down at the top of the window. Click "Add Application". You've finished installing the Hotmail protocol now you just need to select it.
  6. Go to Firefox>Preferences>Applications, if you are using a Mac, or Tools>Options>Applications, if you are using Windows. Now scroll down the list by content type and find mailto. In the drop-down menu to the right select "Use Hotmail".
  7. Next, return to about:config.
  8. If the warning comes up again, click "I'll be careful, I promise!"
  9. In the filter field type "gecko", and double click the first entry gecko.handlerService.allowRegisterFromDifferentHost to change the value back to false.

Modified by Noah_SUMO

Chosen solution

The problem might be due to a security change in Firefox that restricts the use of "javascript:" in the location bar, which is required for step 4.

Try this as a substitute for Step 4:

(a) Open the Web Console using one of these methods:

Ctrl+Shift+k
orange Firefox button > Web Developer > Web Console
classic Tools menu > Web Developer > Web Console

A small area should open above the current page.

(b) Copy the following line of script and paste it next to the ">" at the bottom of the Web Console (it all goes on one long line):


navigator.registerProtocolHandler('mailto','http://hotmail.msn.com/secure/start?action=compose&to=%s','Hotmail');

Then press the Enter key to execute it.

After completing Step 5, you can close the Web Console using any of the same method you used for opening it.

Does that work?

Read this answer in context 8

Additional System Details

This started when...

na

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 15.0.2.72
  • Picasa plugin
  • GEPlugin
  • Google Update
  • 4.1.10111.0
  • Yahoo Application State Plugin version 1.0.0.7
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • Shockwave Flash 11.1 r102
  • AmazonMP3DownloaderPlugin 1.0.15
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • NPWLPG
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

see above

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Chosen Solution

The problem might be due to a security change in Firefox that restricts the use of "javascript:" in the location bar, which is required for step 4.

Try this as a substitute for Step 4:

(a) Open the Web Console using one of these methods:

Ctrl+Shift+k
orange Firefox button > Web Developer > Web Console
classic Tools menu > Web Developer > Web Console

A small area should open above the current page.

(b) Copy the following line of script and paste it next to the ">" at the bottom of the Web Console (it all goes on one long line):


navigator.registerProtocolHandler('mailto','http://hotmail.msn.com/secure/start?action=compose&to=%s','Hotmail');

Then press the Enter key to execute it.

After completing Step 5, you can close the Web Console using any of the same method you used for opening it.

Does that work?

Modified by jscher2000

Helpful Reply

it sure did! initially, I typed in:

<br>navigator.registerProtocolHandler('mailto','http://hotmail.msn.com/secure/start?action=compose&to=%s','Hotmail');

didn't work. so I removed the <br> and there ya go. thanks again.

PS- WHY isn't hotmail listed as an option, and why do we have to go to such lengths?

Modified by cor-el

Question owner

I spoke too soon. It did indeed add 'hotmail' as an application next to Yahoo and Gmail..but when I click on a link---no good. Sorry, there's a problem with Hotmail right now Hotmail wasn't able to complete this request. Microsoft may contact you about any issues you report. Try to return to Hotmail

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

I'm not sure why Windows Live Mail/Hotmail isn't a pre-configured option; who decides?

Anyway, that handler does work for me, it takes me to the live.com site to compose a message.

You could try adding this one (direct to live.com) and see whether it works better with your account:


navigator.registerProtocolHandler('mailto','http://mail.live.com/secure/start?action=compose&to=%s','Live Mail');

Question owner

that one works!

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Cool, thanks for confirming that.

vimarin 0 solutions 5 answers

To resolve the Hotmail malfunction problem, did all that from the admin account -- and the problem with Hotmail was resolved, BUT solely for this account: the other user accounts remained with the same problem, neither the intention to repeat of the 1 to 9 steps from these accounts helped.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

@vimarin -

Firefox probably has separate profile folders for each distinct Windows user. You can confirm the location of the currently active profile folder using Help > Troubleshooting Information, then clicking the Open Containing Folder button.

I'm not familiar with how to change Firefox settings in Windows accounts with limited privileges (what differences there might be). Hopefully someone else can answer that.

Modified by jscher2000

vimarin 0 solutions 5 answers

Obviously, there is his own profile for each user, that's why the procedure was repeated being logged-in as each one.

     Anyway, the problem was solved fairly simply for every user  (and I hope, forever) merely by going to hotmail via https://www.hotmail.com instead of http:/www.hot* 
  This way, everything works as before.
  All that thanking to "titi77".
  Anyway, my problem might be not the same as the one of this thread: I could get into my Hotmail account, but I could not go beyond that into any of my messages, folders, etc. , and the same occurred simultaneously to IExplorer, and Chrome, too.

Modified by vimarin

BobS 0 solutions 8 answers

Thank you, that worked for me to add iCloud mail by substituting the icloud URL. I did find that step 4 could use some clarification. "the text between the text " still doesn't make sense to me.

BobS 0 solutions 8 answers

I was mistaken it is only partially working. It navigates to the iCloud mail application but not the compose page. Here is the script/string I entered:

javascript:navigator.registerProtocolHandler('mailto','https://www.icloud.com/#mail/secure/start?action=message/en-us/#compose&to=mailto:%s", iCloud Mail')

What have I done wrong? I've been playing with variations but this script get me the best result.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

How did you get the iCloud URL? Is that what appears when you click an email link in Safari? (Not having an iCloud account, I am not in a good position to experiment.)

BobS 0 solutions 8 answers

I am using Fierfox on windows 7 machine. If I manually navigate to iCloud mail https://wwwicloud.com/#mail I then have to click on the 'compose' icon to compose a new message. If I click 'reply' from a message in my inbox this is the URL:

'https://www.icloud.com/mail/message/en-u/#reply?guid=message%3AINBOX%2F58' How would I modify this URL to work with "mail to"?
jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hmmm, I'm a little skeptical about this new URL. The information at the end ("guid=message:INBOX/58") isn't possible to ascertain from a random web page. What happens if you try that URL without that parameter?

dstarfire 0 solutions 2 answers

One other note: if you've turned on hotmail's option to always use https, you need to change url in that javascript code to start with https, like this (navigator.registerProtocolHandler('mailto','https://hotmail.msn.com/secure/start?action=compose&to=%s','Hotmail');