X
Tap here to go to the mobile version of the site.

Support Forum

HTML5 based player from Soundcloud, doesn't work when embedded on my website. Why?

Posted

Soundcloud HTML5 based widged doesn't show on my website when embedded. It use to work, now there's only blank content box. It works on Chrome and Explorer.

Does anyone have a clue why is that? Really need help.

Thx

Soundcloud HTML5 based widged doesn't show on my website when embedded. It use to work, now there's only blank content box. It works on Chrome and Explorer. Does anyone have a clue why is that? Really need help. Thx

Chosen solution

Can you post a link to a public page that doesn't require authentication (log in) to access it?

Did you check the the server sends the file with the correct MIME type?

Apache:

AddType audio/ogg oga ogg
AddType video/ogg ogv
AddType video/webm .webm

A good place to ask advice about web development is at the MozillaZine "Web Development/Standards Evangelism" forum.

The helpers at that forum are more knowledgeable about web development issues.
You need to register at the MozillaZine forum site in order to post at that forum.

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 4.1.10111.0
  • Shockwave Flash 11.1 r102
  • iTunes Detector Plug-in
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • Adobe PDF Plug-In For Firefox and Netscape
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Chosen Solution

Can you post a link to a public page that doesn't require authentication (log in) to access it?

Did you check the the server sends the file with the correct MIME type?

Apache:

AddType audio/ogg oga ogg
AddType video/ogg ogv
AddType video/webm .webm

A good place to ask advice about web development is at the MozillaZine "Web Development/Standards Evangelism" forum.

The helpers at that forum are more knowledgeable about web development issues.
You need to register at the MozillaZine forum site in order to post at that forum.

Can you post a link to a public page that doesn't require authentication (log in) to access it? Did you check the the server sends the file with the correct MIME type? * https://developer.mozilla.org/En/Media_formats_supported_by_the_audio_and_video_elements * https://developer.mozilla.org/en/Configuring_servers_for_Ogg_media * http://en.wikipedia.org/wiki/Use_of_Ogg_formats_in_HTML5 Apache: AddType audio/ogg oga ogg AddType video/ogg ogv AddType video/webm .webm ---- A good place to ask advice about web development is at the MozillaZine "Web Development/Standards Evangelism" forum. *http://forums.mozillazine.org/viewforum.php?f=25 The helpers at that forum are more knowledgeable about web development issues.<br> You need to register at the MozillaZine forum site in order to post at that forum.
lbcsrw 0 solutions 4 answers

Here's a screen grab, taken just a few moments ago, that show a similar problem:

Screen Shot

Here's a screen grab, taken just a few moments ago, that show a similar problem: [http://radicalgratitude.com/pix/FirefoxSoundcloudError.jpg Screen Shot]
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

That is not HTML5, but a simple Flash player on the lbpost.com site.

Looks that you are blocking some content if you do not see the iframe with the SoundCloud Flash player.
Does this link have the same problem?

Having trouble viewing the SoundCloud player? Click here.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

That is not HTML5, but a simple Flash player on the lbpost.com site. *www.lbpost.com/life/sander/1309300324 Looks that you are blocking some content if you do not see the iframe with the SoundCloud Flash player.<br /> Does this link have the same problem? Having trouble viewing the SoundCloud player? Click here. *http://soundcloud.com/sanderis/long-beach-arts-candidate ---- Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
lbcsrw 0 solutions 4 answers

The Soundcloud page works perfectly.

I restarted in safe mode, but the LBPost page still did not display the embedded player.

The Soundcloud page works perfectly. I restarted in safe mode, but the LBPost page still did not display the embedded player.
lbcsrw 0 solutions 4 answers

Just to clarify, when you click on 'share' at soundcloud, there are two main choices: HTML5 and Flash. The flash version works perfectly, but the HTML5 version does not. (See image below)

Just to clarify, when you click on 'share' at soundcloud, there are two main choices: HTML5 and Flash. The flash version works perfectly, but the HTML5 version does not. (See image below)
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

The video tag only works with a supported MIME type like video/ogg or video/webm

The video tag only works with a supported MIME type like video/ogg or video/webm *https://developer.mozilla.org/En/HTML/Element/Video
lbcsrw 0 solutions 4 answers

I'm sorry, but I have no idea what video tag you're referring to. This is the code that soundcloud's system produces:

<iframe width="100%" height="166" scrolling="no" frameborder="no" src="http://w.soundcloud.com/player/?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F40605063&auto_play=false&show_artwork=true&color=8c00ff"></iframe>

I don't see any video tag here.

I'm sorry, but I have no idea what video tag you're referring to. This is the code that soundcloud's system produces: <iframe width="100%" height="166" scrolling="no" frameborder="no" src="http://w.soundcloud.com/player/?url=http%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F40605063&amp;auto_play=false&amp;show_artwork=true&amp;color=8c00ff"></iframe> I don't see any video tag here.
discohub 0 solutions 2 answers

Same here. I have noticed that soundcloud HTML5 players don't show up in any window or iframe on Firefox, whereas they display and work properly on Chrome and Safari (running on Mac OS X 10.7.3).
I have emptied every cache possible, restarted in safe mode, and it still doesn't work.
The basic flash player works perfectly fine in every browser.
Every browser is up to date.

Example :
http://www.wearethebeat.co.uk/2012/04/mr-pinks-disco-discharge-promo-mix.html

(image 1 : Firefox)
(image 2 : Chrome)
(image 3 : Safari)

Same here. I have noticed that soundcloud HTML5 players don't show up in any window or iframe on Firefox, whereas they display and work properly on Chrome and Safari (running on Mac OS X 10.7.3).<br /> I have emptied every cache possible, restarted in safe mode, and it still doesn't work.<br /> The basic flash player works perfectly fine in every browser.<br /> Every browser is up to date. Example :<br /> http://www.wearethebeat.co.uk/2012/04/mr-pinks-disco-discharge-promo-mix.html (image 1 : Firefox)<br /> (image 2 : Chrome)<br /> (image 3 : Safari)

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

Helpful Reply

Works fine here on Linux with Firefox 11 and Firefox 12 (beta).

Did you try to clear the cookies as well?

Works fine here on Linux with Firefox 11 and Firefox 12 (beta). Did you try to clear the cookies as well?
discohub 0 solutions 2 answers

Helpful Reply

That fixed it. Just forgot to clear the cookies. I thought I had done it. Thanks a lot!

That fixed it. Just forgot to clear the cookies. I thought I had done it. Thanks a lot!
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158896 answers

You're welcome

You're welcome