X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Default firefox start page search engine doesn't use Google anymore, it uses "Search-results". How do I change this?!

Posted

I was told that this "search-results" are due to a malware program called "searchqu". I've deleted everything about searchqu from my computer, I've run mal-ware scans, and virus scans, and I have gone into the about:config to do google's start page. I just want the original firefox start page back because it has the restore session button and USED TO have google as the default search engine. Please help.

Chosen solution

Assuming that you are using the default Firefox 4.0+ homepage which is about:home.

With the about:home homepage showing:
Firefox button > Web Developer -> Scratchpad -
copy and paste this script into Scratchpad > then hit Execute > Run

 
javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}
 
Read this answer in context 6

Additional System Details

This happened

Every time Firefox opened

This started when...

I believe when I updated firefox, but unsure

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Google Update
  • Facebook Video Calling Plugin
  • 4.1.10111.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • Version 2.6.1.5251
  • Google Talk Plugin Video Accelerator version:0.1.44.14
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 1.96.0
  • 0.70.3
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24406 answers

Chosen Solution

Assuming that you are using the default Firefox 4.0+ homepage which is about:home.

With the about:home homepage showing:
Firefox button > Web Developer -> Scratchpad -
copy and paste this script into Scratchpad > then hit Execute > Run

 
javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}
 

Helpful Reply

Thank you! That made it work once I saved that code. I'm still not sure why it was happening, but I'm glad you could help!

Searchqu Support Team 8 solutions 46 answers

Hi,

@frustrateduser- my name is John, and I'm a member of the Searchqu Support Team. I'm here to help :)

When the software installed onto your pc it offered two basic installs, typical installation, which lists the add-on features such as searchqu default search, and Custom installation, which allows you to select the add-ons that you wish to install. There's no need to worry if you did the typical install - this isn't a virus, nor malware, and there's no need to Perform a virus scan against it.

Please let us know if you need any more instructions on how to uninstall Searchqu, we are here to assist! :)

The Searchqu support team

Question owner

John,

Please help me. I don't know how Searchqu became installed, and I don't want it on my computer. It does not show up in Add/remove programs and is by all accounts in my book a virus or malware. It was not intentionally installed and I cannot get rid of it. Please help me make this disappear. Anytime I type directly into my search bar it uses Searchqu.

Searchqu Support Team 8 solutions 46 answers

Hi,

@frustrateduser- Please follow the next instructions:

Write in the URL address:

"about:config"

It'll warn you to be careful. Go in anyway. Search for:

keyword.url

In the filter and double click keyword.url From here you can change your default engine to a multitude of sites. For google, enter:

http://www.google.com/search?&q=

Please let us know if the issue persists.

Thank you,

The Searchqu support team.

marcdahan 0 solutions 2 answers

Dear Searchqu team like frustateduser , I am also VERY frustated even if after your latest post search-result ,now,is not apparently my default search engine in url bar... As far I know , I don't remember when your program had been installed in my computer but...it has has been. So, please, I would like to know the way to uninstall "search-result.com" (= to uninstall "searchqu.com) from my computer, like all other programs of the world!

a frustated user

Marc

marcdahan 0 solutions 2 answers

a yes, Uninstall searchqu is the same as uninstall search-result.com or searchnu.com also

Searchqu Support Team 8 solutions 46 answers

@Marcdahan- We don't know anything about "Search-result.com". However, if you like to uninstall Searchqu please go to Control Panel > Add/Remove Programs > look for windows searchqu toolbar > Uninstall.

For step by step Video instructions on how to uninstall, please see our demonstration:http://bit.ly/searchqutoolbar

Thank you,

The Searchqu support team

boothlove 0 solutions 1 answers

NOTHING is working!! For God's sake, just tell us how to take the damn thing out once and for all.Every time I change the keyword.url in the about:config page to Google,I get a notice saying that searchqu has blocked the move.When I select the option to disable current settings and restore to Google and return to the browser...it's STILL THERE. HELP.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

See these threads and pages about searchqu/searchnu:


If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.