X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Remove AVG Search from Address Bar

Posted

I've seen a few posts about the AVG 2012 Search, but none match what I'm looking for.

My homepage is set to google.ca, and my quick search toolbar is set to google as well with all other search engines removed.

I didn't have this problem before until yesterday when I formatted my computer and re-installed everything.

If I type in the address bar terms to search, hit enter, it use to come up with a Google results page. Now when I type up there, hit enter I get an AVG secure search page powered by Google, and the address bar icon changes from a Google logo to AVG.

Only if I type in the address bar. When I open a new tab the cursor always defaults into the address window not the google search page so, always forget to click into the google page and type. In any case, if I search with the google search bar or on the google webpage it's fine, it's just if I type in the address bar and hit enter that I get this http://isearch.avg.com page.

Anyway to switch it back to google?

Additional System Details

This happened

Every time Firefox opened

This started when...

Fresh install Win7 yesterday

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • iTunes Detector Plug-in
  • Plugin for Wacom tablets.
  • Wacom Dynamic Link Library
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • 4.0.50401.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

More Information

Win7 64bit, fresh install from a fully formatted disc, Firefox 10.0.1, AVG Internet Security 2012.

Michael Verdi
  • Administrator
  • Moderator
110 solutions 745 answers

You should be able to fix this with the steps in the first section of What to do when searches take you to the wrong search website

Question owner

No such luck... default value is blank, if I add www.google.ca, or just google.ca, if I type in a search term into the location bar, for example "test" it automatically tries to send me to "www.test.com" instead of showing results.

Michael Verdi
  • Administrator
  • Moderator
110 solutions 745 answers

Helpful Reply

Sorry - I see the problem now. Google.ca wasn't the default to begin with. To change it you need to change the default to http://google.ca/search?q=

Those instructions are here Changing the internet keyword service

Question owner

Awesome, now it's working again...

I tried clicking default but it was greyed out and the value was just blank, but just tried http://google.ca/search?q= and gave it a test and it's back to normal.

Thanks!

clrush69 0 solutions 3 answers

I had AVG Secure Search take over my Google bar and homepage today. I uninstalled AVG from my sys, but it still shows in Firefox search bar, altho I reset my homepage as Speed Dial. Can't find it in registry. Not impressed - can you tell me how to rid Firefox of any AVG remnants?

Vaydayell 0 solutions 1 answers

Spent some time too and found that uninstalling it from Control Panel / Programs and Features works for me. (so far)

KerriB 0 solutions 7 answers

Helpful Reply

Here is what I just found to rid ourselves of this:

http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=196402#post_196402