Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

address bar problem - not working correct!

  • 6 replies
  • 20 have this problem
  • 1229 views
  • Last reply by cor-el

more options

pressing enter does not work when a site address is entered, you have to manually click the 'go' arrow. also selecting bookmark from address drop down only puts the site address in the address bar and you have to then press the 'go' arrow to get the site to load. if i use the bookmark button in the tool bar it opens the list and i can click a bookmark and it will load as normal. please help!

Chosen solution

That issue can be caused by an AVG extension (AVG Safe Search).

Read this answer in context 👍 0

All Replies (6)

more options

Have you tried Safe Mode?

  • Support: Safe Mode
    • If Safe Mode helps, then you need to disable Add-Ons/Plugins to find out which on is messing things up.

There were reports of this some time ago, back in FF3&4, nothing certain was said to reslove the problem. Some people noticed; Firebug & Delicious add-on were causing the issue, others noted that disabling the "Smart Location Bar" helpw.

I just disabled FF Sync to fix the issue when I had troubles with the Address Bar randomly not working. but that was much later than FF4

Modified by iMarshmellow

more options

Chosen Solution

That issue can be caused by an AVG extension (AVG Safe Search).

more options

just disabled agv and it now works fine, thank you so much cor-el :D

more options

I have this problem as well, but when I go to my extensions nothing shows up! What can I do?

more options

Problem solved. For those of you having the same issue, just go back to a previous version of FF and you'll be able to see your extensions. Then just disable the AVG safe search. Hope this helps!

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (e.g. extensions.sqlite, extensions.ini, extensions.cache) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is a compatibility update available.

You may have to reset the preferences as well.