Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

for the search engine, is there way to change the default search engine

  • 25 replies
  • 164 have this problem
  • 2777 views
  • Last reply by HousesGalore

more options

for the search engine, is there way to change the default search engine instead of changing it each time i open firefox. (ie: mine is currently yahoo and i want to use google)?

Chosen solution

Type about:config in the Location (address) bar and press the "Enter" key. When you see a warning, click I'll be careful, I promise! button.

  • Preferences that have been modified are shown as bold (user set).
  • Preferences can be Reset to the default or changed via the right-click context menu.
  • http://kb.mozillazine.org/About:config

-> In the Filter bar, type keyword.URL

-> In the Filter bar, type browser.search.defaultenginename

  • right-click the preference browser.search.defaultenginename and choose Reset from the menu
  • OR choose Modify -> type Google
  • click OK

-> In the Filter bar, type browser.search.selectedEngine

  • right-click the preference browser.search.selectedEngine and choose Reset from the menu
  • OR choose Modify -> type Google
  • click OK

-> Close the about:config tab and Restart Firefox.

Check and tell if its working.

Read this answer in context 👍 39

All Replies (20)

more options

You want to change the Search Engine from the Search bar or Location bar ??

Modified by Hasan

more options

search bar. mine has a yahoo icon, but i rather use google. I tried the drop down menu and there is no option for default.

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Perform the suggestions mentioned in the following article:

Check and tell if its working.

more options

Thanks for your help, but when I do that and close the window and reopen it, its not on google anymore, but back to yahoo. I am looking to change the default to google.

more options

@cor-el, I am confused about how you wrote it up. You wrote don't make any changes in safe mode. If I don't make changes there, where do I make them? Do I just use safe mode to figure out where the problem is and then change it out of safe mode? Thanks again!

more options

Cor-el said : Don't make any changes on the Safe mode start window

By this he means that Don't Select any of the 5 Checkmark Options presented in the attached screenshot of the Safe Mode window. Just click Continue in Safe Mode button.

Check and tell if its working.

Modified by Hasan

more options

Thanks for the suggestion. I finally had a chance to try it and in safe mode it is still listing yahoo as the default. I noticed the change after my dad had me install iobit software or another program. In safe mode, it was disabled and yahoo still listed as search engine. I tried setting it back to default settings in the window you told me not to, and its listed as yahoo. Any other suggestions? Or I guess I can just live with always changing it. You would think when you go to the manage search engines, there is a way to choose default.

more options

An extension may change the setting back to Yahoo after you've changed the search engine to Google either via the user interface or on the about:config page.

So if you've changed the search engine Google and the change doesn't keep then you can check out if an extension is causing it.

more options

cor-el: i am new to all of this safe mode stuff and extensions, themes, etc. but if it was an extension, in safe mode it would have been disabled and google, would have apppeared correct? maybe it would be just easier to export my bookmarks. delete firefox completely from my computer, reinstall, reinstall my bookmakers?

more options

Chosen Solution

Type about:config in the Location (address) bar and press the "Enter" key. When you see a warning, click I'll be careful, I promise! button.

  • Preferences that have been modified are shown as bold (user set).
  • Preferences can be Reset to the default or changed via the right-click context menu.
  • http://kb.mozillazine.org/About:config

-> In the Filter bar, type keyword.URL

-> In the Filter bar, type browser.search.defaultenginename

  • right-click the preference browser.search.defaultenginename and choose Reset from the menu
  • OR choose Modify -> type Google
  • click OK

-> In the Filter bar, type browser.search.selectedEngine

  • right-click the preference browser.search.selectedEngine and choose Reset from the menu
  • OR choose Modify -> type Google
  • click OK

-> Close the about:config tab and Restart Firefox.

Check and tell if its working.

Modified by Hasan

more options

thanks mha007! it worked!!! i don't know what program changed it, but they were all in bold (i don't know by changing the first one if that caused the other 2 to be bold). i didn't realize that this is what you wanted me to do in your previous message!

thanks again!

more options

Glad to see its working.

more options

mha007...one more question. in the process, of doing it a screen came up saying that a program was trying to change my search engine so i hit ignore so that i could change it. now, i can't find the program that prevents this to change the settings back. any idea of what program it may be? i have malwarebytes, iobit, avg, ccleaner, a whole bunch of programs on my computer. or is it part of firefox or windows? thanks again!

more options

That message was not from Firefox. It must be from one of the security programs that prevents the internet connecting softwares from making changes.

For Firefox to run successfully, best for you is to prevent these programs from interfering with Firefox.

  • DON'T SELECT FIREFOX in These Programs' SETTINGS
  • These softwares can be responsible for Changing and Deleting your Firefox Settings.
more options

I have not selected firefox in any of the programs. its just a warning box that comes up. but from what i think you are saying, i shouldn't be concerned that i can't remember what program used to come up with the message?

thanks again!

more options

i think its part of windows under "search settings" but i can't figure out how to get it back.

more options

No its not from Windows. Its from on of those Security/Privacy/Registry softwares.

Modified by Hasan

more options

so just forget about it? i don't want a program to try and change it without me realizing it.

more options

You will have to thoroughly check these programs' settings/options/preferences. In those settings, there will be a section of Applications or Programs which will list all the programs that Connect to the Internet, keep Cache, Homepage Settings, Search Engine Settings, etc.

  • Remove Checkmark(unselect) Firefox in any of the settings you find. Apparently you will find out which program was causing the Firefox-controlling behavior.
  1. 1
  2. 2