X
Tap here to go to the mobile version of the site.

Support Forum

Edit-Bookmark window truncated, so can't bookmark

Posted

I have been using Firefox in XP & in Ubuntu for many years. I have over 3000 bookmarks in a lot of folders, so this is not new to me. I just installed Ubuntu 11.10 & found Firefox 9.0.1 When I try to add a new bookmark, at the second star-click, the Edit-Bookmark window opens OK, but when I try to select a folder from the drop-down list, then the window is truncated at bottom & at right side. Clicking on a target folder highlights it OK but I can not see any button for confirming, so nothing is saved to right folder. All attempts end up in unsorted bookmarks. Screenshot below. [IMG]http://i838.photobucket.com/albums/zz309/2CV67/Bookmarks.jpg/IMG

I have been using Firefox in XP & in Ubuntu for many years. I have over 3000 bookmarks in a lot of folders, so this is not new to me. I just installed Ubuntu 11.10 & found Firefox 9.0.1 When I try to add a new bookmark, at the second star-click, the Edit-Bookmark window opens OK, but when I try to select a folder from the drop-down list, then the window is truncated at bottom & at right side. Clicking on a target folder highlights it OK but I can not see any button for confirming, so nothing is saved to right folder. All attempts end up in unsorted bookmarks. Screenshot below. [IMG]http://i838.photobucket.com/albums/zz309/2CV67/Bookmarks.jpg[/IMG]

Modified by 2CV67

Chosen solution

You can of course choose a smaller value than the 60em that I posted, but at least you can see that it has worked.
You can also add a height (or min-height) if that needs to be adjusted as well.
I don't know what value is needed for the height, so just experiment to see what works (try 20em or 25em).


#editBookmarkPanel {
 width: 40em !important;
 min-height: 25em !important;
}
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • The IcedTea-Web Plugin executes Java applets.
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

[IMG]http://i838.photobucket.com/albums/zz309/2CV67/Bookmarks.jpg[/IMG]

cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159077 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode
John99 971 solutions 13138 answers

Carefully manually backup all your current bookmarks in both the XP and Ubuntu systems. In addition note firefox will store some automated bookmark backups, these are in a folder in your profilethe easiest way ti find that in both XP and Ubuntu is to use:

  • firefox button -> Help -> troubleshooting -> [open containing folder]
    • once found copy it somewhere safe outside the profile and outside the firefox program paths, your Windows Desktop, or Ubuntu workspace for example

Now that you have both the auto backups and manual backups safe you can attempt the easiest solution which is to load one of the backups, starting with the most recent of the auto backups. You do this from the bookmark library (Shortcuts Ctrl+shift+B , in Windows; Ctrl+Shift+O in Ubuntu). Do not spend too long on this it may not work anyway!

Remember any restore you do overwrites anything that pre exists, if a restore works also back that working restore up manually. It is good working practice to back up bookmarks anyway.

The problem may well not be the bookmarks files themselves. Something else may be interfering, or something else may be corrupt so you will also need to try: safe mode, a new profile and probably reseting the controls.

See also

If you are already using firefox sync that may prove useful,but remember to manually backup bookmarks on all machines.

Carefully manually backup all your current bookmarks in both the XP and Ubuntu systems. In addition note firefox will store some automated bookmark backups, these are in a folder in your [[profiles|profile]]the easiest way ti find that in both XP and Ubuntu is to use: * firefox button -> Help -> troubleshooting -> [open containing folder] ** once found copy it somewhere safe outside the profile and outside the firefox program paths, your Windows Desktop, or Ubuntu workspace for example Now that you have both the auto backups and manual backups safe you can attempt the easiest solution which is to load one of the backups, starting with the most recent of the auto backups. You do this from the bookmark library (Shortcuts Ctrl+shift+B , in Windows; Ctrl+Shift+O in Ubuntu). Do not spend too long on this it may not work anyway! Remember any restore you do overwrites anything that pre exists, if a restore works also back that working restore up manually. It is good working practice to back up bookmarks anyway. The problem may well not be the bookmarks files themselves. Something else may be interfering, or something else may be corrupt so you will also need to try: safe mode, a new profile and probably reseting the controls. See also * <s>[[backng up and restoringbookmarks]]</s> edit<br>[[backing up and restoring bookmarks]] * [[safe mode]] (may enter from Help -> restart with add-ons disabled)<br/>Initially at least do not make changes in the first dialoge Window, just click on continue ** if problems persist than whilst still in safe mode disable all plugins * [[basic troubleshooting]] *[[back and forward or other toolbar items are missing]] *[[what is firefox sync?]] If you are already using firefox sync that may prove useful,but remember to manually backup bookmarks on all machines.

Modified by John99

Question owner

Thanks very much for replies!

Taking things one step at a time: 1.The situation is exactly the same in safe mode.

Next?

Thanks very much for replies! Taking things one step at a time: 1.The situation is exactly the same in safe mode. Next?
John99 971 solutions 13138 answers

As a first step I would make

  1. manual backups of the current bookmarks,
  2. and copies of the bookmarks backup folders that firefox automatically produces (with the files they contain)

Are you currently using firefox on both Windows XP and Ubuntu, and if so do you already have two sets of synchronised bookmarks ?

I forgot to say try firefox in its default theme but note cor-el beat me to a reply and said that anyhow. Next whilst using firefox in firefox's safe mode disable all the plugins.

After that my suggestion is to reset the controls, and toolbars from safe mode, that is a change and you do loose settings, but fairly inconsequential compared with the missing 3000 bookmarks.

As a first step I would make # manual backups of the current bookmarks, #and copies of the bookmarks backup folders that firefox automatically produces (with the files they contain) Are you currently using firefox on both Windows XP and Ubuntu, and if so do you already have two sets of synchronised bookmarks ? I forgot to say try firefox in its default theme but note cor-el beat me to a reply and said that anyhow. Next whilst using firefox in firefox's safe mode disable all the plugins. After that my suggestion is to reset the controls, and toolbars from safe mode, that is a change and you do loose settings, but fairly inconsequential compared with the missing 3000 bookmarks.

Question owner

Thanks again! I have copies of all the bookmarks on my desk. I am currently using various versions of FF in XP, Ubuntu-10.04 & Windows-7 as well as the problematic new FF in Ubuntu-11.10. They all have bookmarks sync'd by X-Marks so I have plenty of escape routes. Note that all my bookmarks are present & available in all versions - it is just that I can't add new ones in the right folders in 11.10.

Following your instructions:

2. I went to safe mode & Disabled all Plugins - no change.

3. I went to safe mode & Disabled all Add-ons and Reset Toolbars & Controls - no change.

From where I am now, I may as well try uninstalling & reinstalling FF I suppose, unless you have more suggestions? I will wait for a reply anyway...

Thanks!

Thanks again! I have copies of all the bookmarks on my desk. I am currently using various versions of FF in XP, Ubuntu-10.04 & Windows-7 as well as the problematic new FF in Ubuntu-11.10. They all have bookmarks sync'd by X-Marks so I have plenty of escape routes. Note that all my bookmarks are present & available in all versions - it is just that I can't add new ones in the right folders in 11.10. Following your instructions: 2. I went to safe mode & Disabled all Plugins - no change. 3. I went to safe mode & Disabled all Add-ons and Reset Toolbars & Controls - no change. From where I am now, I may as well try uninstalling & reinstalling FF I suppose, unless you have more suggestions? I will wait for a reply anyway... Thanks!

Modified by 2CV67

John99 971 solutions 13138 answers

Next suggestions are

  • reset controls by using safe mode (there are other methods)
  • create and try a new profile (some users find that easier than, a fresh install) and in any event if it is a profile fault a fresh install does not solve the problem anyway

Did you try a manual backup of the bookmarks, and did you try a restore of bookmarks to a previous days ? (not that I suspect it would solve your problem, but it is an easy option)

Next suggestions are * reset controls by using safe mode (there are other methods) * create and try a new profile (some users find that easier than, a fresh install) and in any event if it is a profile fault a fresh install does not solve the problem anyway Did you try a manual backup of the bookmarks, and did you try a restore of bookmarks to a previous days ? (not that I suspect it would solve your problem, but it is an easy option) * the backup info link should have been [[backing up and restoring bookmarks]] * reset toolbars and controls is more likely to be successful see illustration [[safe mode#w_safe-mode-window]]_safe-mode-window

Question owner

As I said at 3. above (I just edited some blank spaces in there for clarity) I did try resetting toolbars & controls on entering safe mode - no change.

4. I tried a new profile - no change.

5. I restored the original default bookmarks from a couple of days ago, before any of mine were added - no change.

By the way, are you able to see the screenshot in my original post or should I use a different method?

Thanks

As I said at 3. above (I just edited some blank spaces in there for clarity) I did try resetting toolbars & controls on entering safe mode - no change. 4. I tried a new profile - no change. 5. I restored the original default bookmarks from a couple of days ago, before any of mine were added - no change. By the way, are you able to see the screenshot in my original post or should I use a different method? Thanks

Question owner

Sorry I forgot to mention error messages in Terminal when using "firefox -p".

(firefox:2181): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

Any connexion?

Sorry I forgot to mention error messages in Terminal when using "firefox -p". ''(firefox:2181): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",'' Any connexion?
John99 971 solutions 13138 answers

Hi again,

Not familiar with Ubuntu but hazarding a guess that the message could merely indicate it is not finding an expected packaged item, because it is in safe mode. I am in Windows XP at present, will try later on Ubuntu see if I get such an error message with firefox safe mode. (On a live cd at least I do get similar errors to yours in the terminal)

I did see the linked image ok. It is also possible to attach images directly to messages on this forum.

What happens by the way if you try to open the bookmarks library do you see the bookmarks in the old profile then or not. And what happens in the new profile. It could be instructive to see a screenshot of you clicking on a bookmark edit star in the new profile.

Hi again, Not familiar with Ubuntu but hazarding a guess that the message could merely indicate it is not finding an expected packaged item, because it is in safe mode. I am in Windows XP at present, will try later on Ubuntu see if I get such an error message with firefox safe mode. (On a live cd at least I do get similar errors to yours in the terminal) I did see the linked image ok. It is also possible to attach images directly to messages on this forum. What happens by the way if you try to open the bookmarks library do you see the bookmarks in the old profile then or not. And what happens in the new profile. It could be instructive to see a screenshot of you clicking on a bookmark edit star in the new profile.

Modified by John99

Question owner

"What happens by the way if you try to open the bookmarks library do you see the bookmarks in the old profile then or not."

Not sure exactly what you are asking there.

"It could be instructive to see a screenshot of you clicking on a bookmark edit star in the new profile. "

Adding image (I hope)...

"What happens by the way if you try to open the bookmarks library do you see the bookmarks in the old profile then or not." Not sure exactly what you are asking there. "It could be instructive to see a screenshot of you clicking on a bookmark edit star in the new profile. " Adding image (I hope)...
John99 971 solutions 13138 answers

The new profile still shows the edit box dropdown truncated on Right-Hand-Side and probably lower edge as well.

You could try importing bookmarks into the new profile to see if they then work.

I was asking if the bookmarks show up ok in the library (or for that matter in the sidebar) In windows Ctrl+Shift+B for library and Ctrl+B for sidebar. In Ubuntu Ctrl+Shift+O and Ctrl+B . I am asking because I expect the bookmarks may be there but you are not seeing them displayed.

The safe mode and reset in safe mode suggests that the profile is not causing a problem. If you do consider an install of firefox you should consider doing a clean reinstall, deleting the program files but not the profile files

The new profile still shows the edit box dropdown truncated on Right-Hand-Side and probably lower edge as well. You could try importing bookmarks into the new profile to see if they then work. I was asking if the bookmarks show up ok in the library (or for that matter in the sidebar) In windows Ctrl+Shift+B for library and Ctrl+B for sidebar. In Ubuntu Ctrl+Shift+O and Ctrl+B . I am asking because I expect the bookmarks may be there but you are not seeing them displayed. The safe mode and reset in safe mode suggests that the profile is not causing a problem. If you do consider an install of firefox you should consider doing a clean reinstall, deleting the program files but not the profile files * see http://kb.mozillazine.org/Standard_diagnostic_%28Firefox%29#Clean_reinstall <br/> this relates to Windows but you may do similar in Ubuntu.

Question owner

There has never been any problem in seeing & using existing bookmarks.

The only (but killer) problem is I cannot add new bookmarks because I cannot see the buttons to add them in the drop-down window.

Removing applications in Ubuntu is not like in Windows. Normally you can remove them either using "Software Center" or using "Synaptic Package Manager". This latter offers 2 levels of removal - "Removal" & "Complete Removal" which should take out all traces.

I tried "Complete Removal" & rebooting & then adding Firefox again, but was left with the same problem & was surprised to see I still had all my bookmarks...

So I did a search for all files with "firefox" in their name in my file system & deleted them all.

After that, I installed Firefox again, which included downloading 17.4MB of new stuff. When I open my new Firefox, which is now obviously new - I have the same problem. See screenshot.

If I can't fix this soon I will need to abandon FF & move to Chromium.

There has never been any problem in seeing & using existing bookmarks. The only (but killer) problem is I cannot add new bookmarks because I cannot see the buttons to add them in the drop-down window. Removing applications in Ubuntu is not like in Windows. Normally you can remove them either using "Software Center" or using "Synaptic Package Manager". This latter offers 2 levels of removal - "Removal" & "Complete Removal" which should take out all traces. I tried "Complete Removal" & rebooting & then adding Firefox again, but was left with the same problem & was surprised to see I still had all my bookmarks... So I did a search for all files with "firefox" in their name in my file system & deleted them all. After that, I installed Firefox again, which included downloading 17.4MB of new stuff. When I open my new Firefox, which is now obviously new - I have the same problem. See screenshot. If I can't fix this soon I will need to abandon FF & move to Chromium.
cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159077 answers

If text doesn't fit in that window then that usually means that the font size is too large and that Firefox doesn't accommodate for that.

Try code in userChrome.css to increase the width of that edit window.


Add code to userChrome.css below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#editBookmarkPanel { width: 60em !important; }
If text doesn't fit in that window then that usually means that the font size is too large and that Firefox doesn't accommodate for that. Try code in userChrome.css to increase the width of that edit window. ---- Add code to userChrome.css below the default @namespace line. *http://kb.mozillazine.org/userChrome.css The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder. *http://kb.mozillazine.org/Editing_configuration ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #editBookmarkPanel { width: 60em !important; } </nowiki></pre>

Question owner

Thanks, cor-el, that looks a bit ridiculous but has fixed the width problem. :)

Now need to fix the height problem!

Screenshots show:

1. Complete window after first star-click.

2. Full-width window truncated in height (no buttons) after second star-click.

3. Full-width & full-height window (how it should be) that I have seen twice but every other time it is like #2...

Thanks, cor-el, that looks a bit ridiculous but has fixed the width problem. :) Now need to fix the height problem! Screenshots show: 1. Complete window after first star-click. 2. Full-width window truncated in height (no buttons) after second star-click. 3. Full-width & full-height window (how it should be) that I have seen twice but every other time it is like #2...

Modified by 2CV67

cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159077 answers

Chosen Solution

You can of course choose a smaller value than the 60em that I posted, but at least you can see that it has worked.
You can also add a height (or min-height) if that needs to be adjusted as well.
I don't know what value is needed for the height, so just experiment to see what works (try 20em or 25em).


#editBookmarkPanel {
 width: 40em !important;
 min-height: 25em !important;
}
You can of course choose a smaller value than the 60em that I posted, but at least you can see that it has worked.<br /> You can also add a height (or min-height) if that needs to be adjusted as well.<br /> I don't know what value is needed for the height, so just experiment to see what works (try 20em or 25em). ---- <pre><nowiki>#editBookmarkPanel { width: 40em !important; min-height: 25em !important; }</nowiki></pre>

Modified by cor-el

Question owner

Thanks again, cor-el!

I found a "best" compromise with 35em width & 30em height.

It seems to work reliably over a short but intense test...

I very much appreciated the rapidity & quality of help here!  :D

Thanks again, cor-el! I found a "best" compromise with 35em width & 30em height. It seems to work reliably over a short but intense test... I very much appreciated the rapidity & quality of help here! :D

Modified by 2CV67

cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159077 answers

You're welcome.

You're welcome.
John99 971 solutions 13138 answers

Glad to see cor-el gave you a solution.

Also note you can easily add bookmarks without using the star. They will copy and paste into the library/manager or the sidebar.

Glad to see cor-el gave you a solution. Also note you can easily add bookmarks without using the star. They will copy and paste into the library/manager or the sidebar.