Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

search button does not work

  • 7 replies
  • 2 have this problem
  • 2 views
  • Last reply by zac1

more options

When I open the start page and it shows the typing bar so you can type in a question when I click on the search button at the side nothing happens, so the only way I can search the web is to click on the small google search icon at the top right hand side and type in my question and then it will take me to the desired page.

Why will the main search button not work!!!

All Replies (7)

more options

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.
Close and restart Firefox.

more options

Thanks for the reply cor-el but can you please put the above in layman's terms, I went into the about:config page but it is a maze of stuff and I am not fully understanding what I should be doing. If it is not too much trouble can you please step out the directions so I do not make a mistake.

Thanks

more options

1. Open the about:config page via the location bar and confirm that you want to go to that page.
2. Type in the Filter at the top: mstone

That should bring the browser.startup.homepage_override.mstone pref in view.
3. Right click that pref line to bring up the right-click context menu and click the Reset entry.
4. Close and restart Firefox to see if it has helped.

See also:

more options

Thanks cor-el, did as instructed restarted Firefox but no difference, the search button depresses when I click on it as if it is allowing me to connect to a web page but then it just sit's there.

more options

Also as a side issue, I know one problem at a time, but hopefully when you have helped me out with the above issue you can see if you know how to fix this, when I go into my Outlook 2010 and if there is a link in an email once I click on the link I get this error message come up, see added image. It still allows the link to open but I am not sure why it has suddenly started happening as it never happend until I upgraded Firefox. I thought this upgrade was supposed to make Firefox better but I am getting more problems than if I had never bothered to upgrade.

Thanks Mate

more options
more options

Tried all 3 no go.