Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Home page won't set to my home page

  • 15 replies
  • 45 have this problem
  • 7 views
  • Last reply by yepytzme

more options

I set my home page to "www.yahoo.ca". When I click 'home' it goes to yahoo.ca which is what I want..But..if I close firefox and reopen, it goes to http://rogers.my.yahoo.com/?_bc=1, which is not what I set up for my home page. When I click 'tool', 'options', 'general' this always comes up http://www.rogers.com/smartkey as 'show my home page'. Doesn't matter how many time I change my home page to www.yahoo.ca it still comes up as www.rogers.com/smartkey.

I would appreciate a reply notice to this to my e-mail if possible to inouh82cme@rogers.com

Modified by yepytzme

Chosen solution

Your system details list shows a Flash 10.3 r183 version.

  • Shockwave Flash 10.3 r183

Do you still have that version or did you update to Flash 11?

Chrome and IE both use their own Flash plugin and not the NPAPI plugin that Firefox uses.

Read this answer in context 👍 0

All Replies (15)

more options

Please follow the steps at https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved and post back your results

more options

Hi fmdeveloper, thank you for the response, but..still didn't work. I followed all the instruction, to the T, exercised all the options, still, after close and reopen, the home page URL comes up as 'http://rogers.my.yahoo.com/?_bc=1' which is not my chosen page. Also, after I change the show my home page to 'yahoo.ca' under options, close and reopen the 'show my home page' under options AGAIN reads 'http://www.rogers.com/smartkey'. I've sent a message to my ISP [Rogers] to ask them how to remove that from my system and am still waiting for a response...other than "this is an automated response, your message has been passed on to the appropriate department and you will receive a reply within 24 to 48 hours". What else is new! [see attachment of unwanted home page] Still flabbergasted.

yepytzme

more options

Let's see what Rogers says....they may have a branded version of Firefox installed, or have an application that changes your home page.

Post back when you hear from them

more options

Did you look for a file user.js in the profile folder?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Hi cor-el, thanks for the assistance. Yes I found the .js file, deleted it, tried changing my home page to default, still same result. If you read my reply to fmdeveloper I think I'll wait till someone from Firefox tries to reply to the same query and see what they say...if anything...like getting blood from a stone.

Also did the 'default' you suggested but there is nothing there to change [see attachment]

Modified by yepytzme

more options

Hello again, fmdeveloper. I went on Rogers' "live chat line" where I chatted on the 'puter with a person from Rogers. What a waste of time. When I told him what the problem was he said "We don't deal with Firefox so I can't help with your problem". I said 'wait a minute, whether you deal with Firefox or not the fact remains that it IS a Rogers problem, it was a Rogers tech. who installed the new modem, it was a Rogers tech who set it up..AND the home page that always comes up it "ROGERS.com/smartkey" so are still telling me it's not a Rogers problem?' He said "we don't deal with Firefox so I can't help you with that problem." How ignorant is this guy? Like butting your head against the wall with Rogers.

more options

Did you try to start in Safe mode?

In Firefox 4+ versions you can use one of these to start in Safe mode:


Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

I did all that cor-el..and more...three times, still no change. Did the safe mode changes, did the new profile changes, nothing works.

Modified by yepytzme

more options

What do you see in the file prefs.js if you set the correct home page and close Firefox?

Look for browser.startup.* prefs in the file prefs.js

more options

Hi cor-el, I think I found the problem..not the fix, but the problem. Mozilla.cfg file reads: //Firefox Default Settings pref("browser.startup.homepage", "http://www.rogers.com/smartkey"); THAT is the reason I cannot change my homepage. And I can't alter that cfg file. I tried deleting it altogether but then Firefox would not open at all, it said cannot open, no cfg file found, so I had to restore the cfg file to open Firefox. Any idea how I can change that file to read what I want it to read?

more options

In addition to the above message, the 'prefs.js' files you asked about are shown in the attachment below. Also, the following is a list of .js files shown under other files for mozilla: [not sure if this is of any value to you but seems like an exercise in futility, in addition to this list there is an additional approx. 30 more similar files]

channel-prefs.js..(Program files\Mozilla Firefox\defaults\pref)

local-settings.js..(Program files\Mozilla Firefox\defaults\pref)

security-prefs.js..(Program files\Mozilla Firefox\defaults(2)\pref(2))

prefs.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\govgl25d.default)

sessionstore.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\govgl25d.default)

prefs.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\h5g01vae.***(my personal user name))

sessionstore.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\h5g01vae.*** (personal user name))

DialogsAPI.js..(Documents and Settings\Owner\Local Settings\Application Data\Conduit\Community Alerts\Dialogs)

DialogsAPI.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\govgl25d.default\ConduitEngine\Dialogs)

excanvas.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\govgl25d.default\ConduitEngine\Dialogs)

settings.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\govgl25d.default\ConduitEngine\Dialogs)

settings.js..(Documents and Settings\Owner\Application Data\Mozilla\Firefox\Profiles\govgl25d.default\CT2504091\Dialogs)

Modified by yepytzme

more options

You need to remove the file local-settings.js to stop using mozilla.cfg

local-settings.js..(Program files\Mozilla Firefox\defaults\pref) 

See:

more options

Thanks Cor-el, that did the trick...or at least part of it. My home page does now come up the way I want, thanks for the heads up on the local-settings.js file. But, firefox is still 'semi-foxed' up, if you get my drift. I can't watch videos in firefox. I never had any problems before but with this new upgraded modem the videos won't work. They work with no problems in Google Chrome and I.E. but not firefox. Each time it says I must upgrade my flash player. My flash player is already #10 and it always worked before [and still works in chrome & I.E.] So I went ahead and upgraded to 11. When I click on a video it STILL says I have to upgrade my flash player. For some reason Firefox does not recognize that I have ANY flash player at all. [see attachment]

more options

Chosen Solution

Your system details list shows a Flash 10.3 r183 version.

  • Shockwave Flash 10.3 r183

Do you still have that version or did you update to Flash 11?

Chrome and IE both use their own Flash plugin and not the NPAPI plugin that Firefox uses.

more options

Problem solved. I uninstalled Firefox completely and reinstalled it and everything..EVERYTHING is working fine now.

Thanks for your assistance.