X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 9 painfully slow site loads

Posted

Since upgrading to 9 I find that visiting web sites invariably means a 10 second or more wait until they load.

Once the site eventually loads subsequent clicks to other pages are much faster.

This happens even with all add ons deactivated.

Modified by perryb

Chosen solution

Check tools/options and then go to advanced/network and check on how Firefox is connecting to the internet. When I downloaded 9.1, I found that it had changed that parameter automatically and I had to change it back. It is especially problematic on Windows 7, it seems. So experiment with the changes between proxy and no proxy. It seemed to resolve on mine with the "no proxy" concerning web page load speed.

I finally went to the Beta channel and downloaded that after I had sped up 9.01, and the Beta is definitely superior! Try that if you are a brave soul and can't get relief with 9.1

Read this answer in context 19

Additional System Details

This happened

Every time Firefox opened

This started when...

Since Firefox 9 upgrade

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • 4.0.60831.0
  • Picasa plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Adobe Shockwave for Director Netscape plug-in, version 11.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

lomamonster 2 solutions 3 answers

Chosen Solution

Check tools/options and then go to advanced/network and check on how Firefox is connecting to the internet. When I downloaded 9.1, I found that it had changed that parameter automatically and I had to change it back. It is especially problematic on Windows 7, it seems. So experiment with the changes between proxy and no proxy. It seemed to resolve on mine with the "no proxy" concerning web page load speed.

I finally went to the Beta channel and downloaded that after I had sped up 9.01, and the Beta is definitely superior! Try that if you are a brave soul and can't get relief with 9.1

Question owner

No change I'm afraid - I am behind a corporate firewall and FF isn't the default browser but even so I have had trouble free use for years both with FF Portable and with FF officially installed by the IT dept.

The last few iterations of FF have become steadily less usable in this context - which is frustrating as the supported browser - IE7 - is locked down and does not have any of the development tools that I use in FF.

Carson 0 solutions 1 answers

Hello. I got the same issue after upgrading to FX 9.0.1 and I solved it by creating a brand new profile. ref: http://support.mozilla.com/en-US/kb/Managing-profiles

Hope this helps.

sheamansenior 0 solutions 1 answers

Not the best solution, but it is working, I have gone back to Firefox 3.6, everything is back to normal speed. When I first started using Firefox 9 everything was fine, but after an update it went pear shape, very slow loading a web page, really poor. Would like to know an answer, I have visited several forums and none of the suggestions work for me. I am using Windows 7

Modified by sheamansenior

BillVero 0 solutions 1 answers

I found this suggestion to work for me. I experiment with the changes between proxy and no proxy. The proxy option worked much faster for me. Thank you.

samsterid 0 solutions 2 answers

Helpful Reply

SOLVED for me:

I had the same issue. Firefox 3.6 was just fine loading pages, switching between tabs, etc. Firefox 8 & 9 were just awful - not just page load speed, but switching between loaded tabs, accessing Firefox menus - everything was really poky.

I did an uninstall with RevoUninstaller, then made sure every trace of FF was gone, and then did a clean reinstall of FF 9.1 - still the same problem. FF 9 ran just fine in Safe mode, so I disabled all plugins, and no extensions were installed yet, but no difference.

Then I looked over Help/Troubleshooting from the FF 9 menu, and noticed that OpenGL might be enabled for faster graphics rendering. I know that other apps (Photoshop) can actually slow down if your video card doesn't fully support OpenGL acceleration.

TRY THIS

So I looked in FF Options/Advanced and noticed under the General tab that hardware acceleration is checked by default. I UNchecked hardware acceleration and now it's back to normal - and somewhat faster than 3.6. YAY!

I'm not sure if my OpenGL theory is correct, but that fixed the slowness for me.

(running Windows 7 64-bit with a first generation AMD 64 X2 Dual Core; Nvidia Geforce 6800 video card)

Sam

Modified by samsterid